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CAPITOLO 1

Benvenuti in Agent!
Congratulazioni per aver scelto Agent, il vostro strumento di comunicazione per Internet. Con
Agent avrete il meglio di due ambienti in un pacchetto unico e armonizzato: un efficiente
programma di gestione email e un newsreader online/offline. Con queste due funzioni,
completamente integrate in un unico pacchetto, non avrete mai bisogno di passare ad una
diversa applicazione quando vorrete leggere la vostra posta o seguire i gruppi di discussione
su Usenet.

Agent vi fornisce più funzionalità di quelle che avreste mai creduto possibili. Ad esempio,
potete:

• combattere lo spam in email e su Usenet con i kill e con i watch filter

• suddividere tutti i vostri messaggi di email e dei newsgroup in cartelle
• inviare e ricevere file in vari formati
• personalizzare ogni cosa, dalle barra degli strumenti alla disposizione delle finestre

Soprattutto, Agent è facile da usare. Non dovrete diventare dei "tennici", quindi rilassatevi!
Buon divertimento.

Nel Capitolo 1 conoscerete:

1 le caratteristiche di Agent

1 cosa sono le email e i newsgroup

1 come ottenere un aiuto

1 questa Guida all’Utente
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Caratteristiche di Agent
• Installazione e configurazione senza fatica  – Installerete Agent in un

attimo. L’installazione guidata di Agent vi condurrà attraverso le
procedure di setup in pochi minuti. L’installazione non potrebbe essere
più facile.

• Supporto per Windows 95 e Windows NT – la versione a 32-bit di
Agent supporta i nomi di file lunghi, come pure la connessione telefonica
(Windows 95) e i Servizi di Accesso Remoto (Windows NT).

• Complete funzionalità di email – Potete inviare e ricevere messaggi di
posta elettronica, e creare una rubrica per i vostri indirizzi email di uso
più frequente. Potete anche dire ad Agent di usare i servizi MAPI per
inviare mail, se preferite.

• Supporto MIME - Agent gestisce il protocollo di trasferimento messaggi
(largamente accettato) chiamato MIME, che consente la più grande
flessibilità nell’invio di messaggi e di file allegati.

• File allegati – Con Agent potete inviare e ricevere una grande varietà di
file nei messaggi email e su Usenet. Agent unisce automaticamente gli
allegati suddivisi in più parti per ridurre il disordine.

• Possibilità di uso Online/Offline  – La possibilità di lavorare sia online
che offline vi consente di valutare le considerazioni economiche in
contrapposizione al desiderio di comodità. Se l’economia è il vostro
interesse primario, usando la modalità offline ridurrete il tempo di
connessione al server quanto basta a ricevere le nuove intestazioni,
quindi potrete leggere i messaggi offline, a vostro piacimento. Se invece
è più importante la comodità, usando la modalità online Agent mantiene
la connessione al server, in maniera tale da evitare l’attesa per ristabilire
il collegamento durante una sessione.

• Facilità di lettura – Con Agent è comodo provare velocemente un
newsgroup. Ad esempio, per scoprire di cosa tratta alt.usenet.kooks
potete prelevare i messaggi più recenti del gruppo, e poi iscrivervi per
prelevare altri messaggi, oppure abbandonarlo e spostarvi su altri gruppi.

• Disposizione delle finestre configurabile – L’ambiente di lavoro di
Agent è suddiviso in tre pannelli: Groups/Folders, Message List e
Message. Potete configurare questi pannelli per adattarli alle vostre
esigenze.
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• Threading e Navigazione- Agent utilizza il threading a più livelli,
ordinando le risposte sotto il messaggio iniziale, così potete seguire una
discussione senza dover cercare le risposte. Agent dispone di numerose
scorciatoie da tastiera che vi consentono di muovervi efficientemente fra
tutti i vostri messaggi.

• Comandi Ignore e Watch - Usenet riceve così tanti messaggi che
potrebbe essere necessario un gran lavoro per trovare quello che vi
interessa. Per ridurre il disordine, Agent ha le opzioni Ignore e Watch,
che consentono di saltare o scaricare i messaggi nei thread specificati.

• Filtri Usenet – Per ridurre ulteriormente il disordine nei newsgroup,
Agent dispone dei filtri Usenet (chiamati Kill e Watch). Potete cancellare
o ricevere automaticamente i messaggi con uno specifico subject, autore
o lunghezza.

• Gestione del crosspost - Agent vi consente di filtrare i messaggi che
sono stati postati su più newsgroup, in maniera tale da non dover
leggere lo stesso post più di una volta.

• Cartelle - Archiviate le informazioni a vostro piacimento. Create dei
folder per ogni argomento che desiderate, quindi semplicemente
“prendete” con il mouse i messaggi selezionati e “portateli” nel folder
desiderato. In più, i messaggi diretti alla vostra mailbox possono essere
automaticamente archiviati in un folder specifico.

• Ordinamento - Agent rende facile e veloce la ricerca di messaggi
specifici, grazie alla possibilità di ordinare i messaggi nei gruppi e nei
folder.

• Lancio delle URL – Tutte le URL nei messaggi (ad esempio, indirizzi
web e di email) vengono evidenziati come link interattivi e possono
essere lanciati con un semplice doppio click su di essi.

• Eliminazione dei messaggi e compressione degli archivi  - Agent vi
consente di gestire lo spazio occupato sul vostro hard disk definendo
una strategia di eliminazione dei messaggi (ad esempio, mantenere i
post solo fino a quando sono disponibili sul server). Dopo l’eliminazione
dei messaggi potete compattare il vostro database, per recuperare lo
spazio su disco usato in precedenza.

• Correttore ortografico – Ogni volta che componete un messaggio,
potete verificare gli errori di battitura usando il correttore ortografico
integrato in Agent. Potete scegliere da un elenco di dizionari in lingue
specifiche.
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• Barre degli strumenti personalizzabili – Potendo scegliere tra più di
150 comandi, non avrete difficoltà a personalizzare la barra degli
strumenti di Agent in maniera tale che contenga le funzioni che usate di
più.

• Lingue - Agent dispone di un vasto assortimento di set di caratteri per
differenti lingue, inclusi quelli con speciali caratteri accentati come il
Francese, o con un set di caratteri unico come il Russo. Questi set di
caratteri consentono di vedere i messaggi in una data lingua in maniera
corretta.

Email e Newsgroup
Agent è un newsreader che contiene un programma di gestione email
integrato. Se non avete familiarità con questi concetti, ecco una breve
spiegazione.

Email
La parola "email" è il termine tecnico più comune per la posta elettronica. In
pochi anni l’email è diventata uno strumento di comunicazione completo e
una valida alternativa al telefono in molti posti di lavoro e abitazioni. Le
aziende con una rete interna di computer usano spesso un qualche
programma di posta che consente agli impiegati di condividere idee e
argomenti da discutere con uno o più colleghi. In casa, le persone che
stanno cominciando ad accedere ad Internet sono in aumento ed usano la
posta elettronica per comunicare con gli amici e le persone care.

Agent ha reso facile l’invio e la ricezione delle email. Potete preparare ed
inviare messaggi a indirizzi singoli o ad una lista di persone. Quando ricevete
la posta potete dire ad Agent di archiviare automaticamente i messaggi
provenienti da determinati mittenti o con subject specifici in cartelle apposite.
Potete anche creare un Address Book nel quale custodire i vostri indirizzi
email di uso più frequente.

Tutti gli indirizzi email hanno una struttura comune: l’identificativo dell’utente,
il carattere "@", il server e il “dominio” (ad esempio .com per le ditte
commerciali, o .edu per le istituzioni scolastiche). Ecco qui due esempi:
jdoe@acmeinc.com (un indirizzo di un’azienda) e msmith@csu.edu (un
indirizzo di una università).

Newsgroup

I newsgroup sono dei luoghi virtuali di discussione pubblica che coprono una
vasta gamma di argomenti. In questi gruppi, le persone possono scambiarsi
idee e informazioni. Potete leggere quello che pensano altre persone in
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merito ad un particolare argomento e unirvi voi stessi alla discussione, se lo
desiderate.

Se non avete mai visto prima un elenco di newsgroup potreste essere
facilmente disorientati iniziando a leggere i nomi nella lista dei gruppi. I nomi
di molti newsgroup non sono chiari. Le abbreviazioni criptiche e gli acronimi
usati sono ostacoli che confondono i novizi.

Ad esempio, potete dire di cosa trattano abg.uucp.waffle,
fidonet.openbeta , linux.act.hams, o sfnet.csc.tiedotukset? Non siete gli
unici a cui questi nomi appaiano senza senso. Tuttavia, Usenet utilizza dei
termini convenzionali specifici, per chiarire un po’ le cose. La tabella
seguente descrive alcune delle convenzioni più usate.

Convenzione di
denominazione

Argomenti di pertinenza

comp
Argomenti relativi ai computer, come ad esempio il
gruppo comp.infosystems.

misc
Argomenti vari: lavoro, vendita di articoli, tutto
quello che non può essere inserito in un altro
gruppo, come ad esempio il newsgroup
misc.invest.canada.

news
Informazioni sui newsgroup stessi, incluse le
istruzioni per cercare ed usare i gruppi di
discussione, come ad esempio
news.groups.reviews [ in italiano it.news.aiuto]

rec
Argomenti ricreativi: hobby, sport, cinema, arte,
come il gruppo rec.humor.

sci
Argomenti scientifici: discussioni riguardo una
grande varietà di ricerche scientifiche, come ad
esempio il gruppo sci.space.shuttle .

soc
Una vasta gamma di problemi sociali, come ad
esempio discussioni in merito a differenti tipologie
di società e sottoculture, come pure argomenti
sociopolitici, tipo il gruppo soc.culture.berber.

talk
Dibattiti su politica, religione, e quant’altro c’è di
controverso, come il gruppo talk.politics.china.

alt
Argomenti alternativi, che variano dal serio
(computer e psicologia) al bizzarro e non
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convenzionale (occulto e stili di vita alternativi).

it
La gerarchia in lingua italiana

Ecco qui un piccolo esempio di quello che potrete trovare nel mondo dei
newsgroups:

Nome del gruppo Argomenti di pertinenza

alt.comedy.british Discussioni sulla commedia britannica, dai Monty
Python a The Black Adder.

Nashville.general Tutto (ma proprio tutto) su Nashville, dalla musica
ai cornioli in fiore.

soc.culture.esperanto Comunicate in questa lingua del futuro con altri
appassionati.

Come ottenere un aiuto
Se avete una domanda su Agent e non trovate la soluzione in questo
manuale avete molte altre possibilità di ottenere una risposta al vostro
quesito. Questa sezione descrive ognuna delle seguenti opzioni e come
accedere esattamente ad esse:

• Help in linea

• Internet Service Provider

• World Wide Web

• Newsgroup

• Richiesta di assistenza (Support Question)

Help in linea - il programma è provvisto di un esteso help in linea, che
fornisce informazioni su tutti gli aspetti delle operazioni di Agent. Così, se
non trovate qualcosa, ecco quello che dovete fare.

Come accedere all’Help in linea di Agent

• Per un argomento particolare - Selezionate Help dalla barra dei menu
di Agent per aprire l’Help alla pagina dei contenuti. Da questa pagina
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potete accedere ai vari argomenti selezionando How to oppure Search
for Help on.

• Per una finestra di dialogo – Se state esaminando una finestra di
dialogo e avete bisogno di aiuto perché non capite cosa fare, premete il
pulsante Help nella finestra di dialogo e verrà visualizzato l’help specifico
per quella finestra.

Per accedere alle Release Notes:

Dal menu Help in Agent, scegliete Release Notes. Vedrete un elenco dei più
recenti miglioramenti e cambiamenti che sono stati apportati ad Agent.

Internet Service Provider (ISP) – Dal vostro fornitore di accesso ad
Internet possono dipendere eventuali difficoltà di connessione. Nel caso,
potete contattarlo.

World Wide Web - Per ottenere informazioni sull’ultima versione di Agent
e le risposte alle domande poste più spesso (FAQ), fate riferimento al sito
Web della Forté su http://www.forteinc.com.

Newsgroup - Chiedete e rispondete alle domande su Agent insieme ai
vostri colleghi di utilizzo in questi newsgroup:

• alt.usenet.offline-reader.forte-agent

• comp.os.ms-windows.apps.winsock.news

• it.comp.software.newsreader, in italiano.

Anche se questi newsgroup non sono i punti di riferimento “ufficiali” di Agent,
il personale della Forté osserva questi gruppi e spesso risponde alle
domande e pubblica avvisi.

Richiesta di assistenza - Potete contattare velocemente il Team di
Supporto di Agent per porre delle domande selezionando "Support Question"
dal menu Post. Scrivete la vostra domanda nella finestra di composizione
messaggio (già completa di indirizzo) che comparirà e inviatecela. Noi siamo
impazienti di aiutarvi. Assicuratevi di avere impostato un indirizzo corretto a
cui rispondere, in caso contrario non saremo in grado di mandarvi la nostra
risposta.
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Questa Guida all’Utente
Per seguire meglio i contenuti di questa guida, fate attenzione alle seguenti
convenzioni utilizzate per chiarire i differenti tipi di informazioni. Questa
sezione descrive inoltre i vari capitoli che compongono questa guida,
consentendovi di vedere in un attimo come è organizzata.

Convenzioni tipografiche
Courier per le parole e i caratteri da digitare. I caratteri da

immettere sono sempre mostrati in minuscolo, a
meno che debbano essere scritti in maiuscolo per
operare correttamente.

“ virgolettato” per i termini nuovi e i singoli caratteri di tastiera.

Grassetto per i nomi dei newsgroup e gli indirizzi URL.

Corsivo per i campi nelle finestra di dialogo, le icone della
barra degli strumenti e i pulsanti.

Menu→Dialog→Tab per la sequenza dei click del mouse necessari per
visualizzare una finestra di dialogo.

per suggerimenti, promemoria o avvertimenti.

In aggiunta alle convenzioni sopra riportate avete anche dei sistemi
alternativi per richiamare le opzioni dei menu di Agent, come nell’esempio
qui sotto:

Pulsante sulla Barra degli strumenti:

Opzione di Menu: Message→Watch Thread

Scorciatoia da tastiera: W

Nota: Le schermate e le finestre di dialogo [finestra di dialogo] mostrate in
questa Guida provengono dalla versione di Agent per Windows 95, a meno
di diversa indicazione.
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Struttura

Capitolo 1, Benvenuti in Agent, presenta una breve panoramica delle
molte caratteristiche di Agent, presenta la Guida e vi dice come ottenere un
aiuto quando avete delle domande su Agent.

Capitolo 2, Come cominciare , vi conduce nell’installazione di Agent.
Durante questa sessione iniziale scaricherete la lista di tutti i newsgroup
disponibili sul vostro news server, preleverete un campione di header dai
gruppi, e sottoscriverete i gruppi di vostro interesse. Questo capitolo descrive
anche come controllare la posta per la prima volta.

Capitolo 3, Fondamenti di Agent, vi introduce a diversi concetti chiave sul
modo in cui Agent è stato pensato per lavorare, su come le informazioni
vengono visualizzate nell’ambiente di lavoro a tre pannelli di Agent, su come
muovervi efficientemente in questi pannelli, su come potete definire le
proprietà specifiche dei newsgroup e su come lavorare online o offline.

Capitolo 4, Tutto sui messaggi, vi mostra come archiviare i messaggi nelle
cartelle, come scaricare e visualizzare solo i post che volete seguire e come
eliminare i messaggi dopo un certo periodo di tempo.

Capitolo 5, Comporre ed inviare i messaggi, comprende le informazioni su
come comporre un messaggio, come creare una signature, come includere
un attachment, come definire le preferenze per la composizione e la
spedizione dei messaggi e come far sì che Agent usi i servizi MAPI per
inviare i post.

Capitolo 6, Usare gli attachment, descrive come allegare dei file (ad
esempio delle immagini in formato GIF) ai messaggi che scrivete. Potrete
anche vedere come sia facile visualizzare o salvare gli attachment inclusi nei
messaggi che voi ricevete.

Capitolo 7, Agent ed altre applicazioni, descrive come lanciare le URL da
Agent nel vostro web browser, come rendere Agent il vostro lettore di
newsgroup ed email predefinito, e come importare ed esportare i file newsrc.

Capitolo 8, Personalizzazione di Agent, descrive come personalizzare le
barre degli strumenti di Agent, i menu dei folder, la disposizione delle
finestre, l’aspetto degli header e del testo nel corpo dei messaggi.
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CAPITOLO 2

Come cominciare
Questo capitolo vi aiuta a preparare e far partire Agent. Installerete Agent, scaricherete la
lista di tutti i newsgroup disponibili, vi iscriverete ai gruppi di vostro interesse, scaricherete gli
header dei messaggi e leggerete le vostre email. Installare Agent usando la procedura di
installazione guidata non è faticoso. In pochi minuti riceverete migliaia di newsgroup e potrete
iniziare a partecipare attivamente alle discussioni.

Ecco come è organizzato questo capitolo:

1 Installare Agent

1 Scaricare una lista completa dei gruppi

1 La disposizione a tre pannelli di Agent

1 La vostra prima sessione con Agent

1 Ricevere le email per la prima volta

Installare Agent
Sono disponibili due versioni di Agent: a 16-bit e a 32-bit.

La versione a 16 bit è comunemente usata nei PC su cui gira Windows 3.1
(o superiore) come sistema operativo.

La versione a 32 bit è progettata per girare sui più nuovi e più potenti PC
che usano Windows 95 o Windows NT come sistema operativo (Agent non
può girare usando Windows 3.1 con Win32S.) La versione a 32-bit di Agent
supporta:

• Multitasking, consentendovi di lanciare diverse sessioni
contemporaneamente.

• Nomi di file lunghi (più di otto caratteri).
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• Connessione telefonica (Windows 95) e Servizi di Accesso Remoto
(Windows NT).

Requisiti PC

Prima di installare Agent, dovrete assicurarvi che il PC soddisfi i seguenti
requisiti:

• IBM PC o compatibile (con almeno un processore 386SX o superiore).

• Un minimo di 4 MB di RAM (anche se noi raccomandiamo 16 MB di
RAM per gli utenti di Windows 95 e 8 MB di RAM per gli utenti di
Windows 3.x).

• Un minimo di 8 MB di spazio libero sull’hard disk per l’installazione.

Requisiti per Agent a 16 Bit

• Windows 3.1 o superiore, oppure Windows NT 3.5 o superiore.

• Un driver TCP/IP che supporti le applicazioni Winsock 1.1.

• Accesso a un news server NNTP.

• Accesso a un mail server SMTP per la spedizione delle email.

• Accesso a un mail server POP o SMTP per ricevere le email.

Requisiti per Agent a 32 Bit

• Windows 95 o Windows NT 3.5 o superiore.

• Protocollo TCP/IP che supporti Winsock a 32 bit.

• Accesso a un news server NNTP.

• Accesso a un mail server SMTP per la spedizione delle email.

• Accesso a un mail server POP o SMTP per ricevere le email.

Metodi di installazione
Potete installare Agent in uno di questi due modi:

• elettronicamente, scaricando il programma da Internet

• comprando una versione confezionata, dove il programma è su dischetti
o CD ROM.
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Per installare Agent elettronicamente:

1. Se non avete già una copia di Agent, dovete scaricare il file EXE di
installazione. Potete accedere al file EXE dal sito web della Forté a
http://www.forteinc.com/store/getagent.htm .

2. Eseguite il file EXE per attivare l’installazione guidata

In Windows 95 - selezionate Esegui dal menu Start, inserite il percorso
del file EXE nel riquadro Apri e premete OK.

Windows 3.x - selezionate Esegui dal menu File, inserite il percorso del
file EXE nel riquadro con la linea di comando, e premete OK.

La procedura di installazione che appare vi guiderà attraverso le
operazioni di setup. Seguite semplicemente le istruzioni spiegate
chiaramente sullo schermo. In ogni momento potete sospendere il
procedimento o retrocedere negli schermi precedenti per cambiare
qualsiasi informazione inserita o opzione selezionata.

Per installare Agent usando una versione pre-confezionata:

1. Inserite il CD ROM o i dischetti contenenti il programma nel drive
appropriato (tipicamente d: per i CD ROM e a: per i dischetti).

2. Eseguite il file SETUP.EXE per attivare l’installazione guidata.

In Windows 95 - selezionate Esegui dal menu Start, inserite il percorso
del file SETUP.EXE (ad esempio d:\setup.exe) nel riquadro Apri e
premete OK.

Windows 3.x - selezionate Esegui dal menu File, inserite il percorso del
file SETUP.EXE (ad esempio a:\setup.exe) nel riquadro con la linea di
comando e premete OK.

La procedura di installazione che appare vi guiderà attraverso le
operazioni di setup. Seguite semplicemente le istruzioni spiegate
chiaramente sullo schermo. In ogni momento potete sospendere il
procedimento o retrocedere negli schermi precedenti per cambiare
qualsiasi informazione inserita o opzione selezionata.
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Registrare Agent
Prima di poter usare Agent dovete inizializzare il programma [1] immettendo
il numero di registrazione e il nome del vostro mail server e news server.
Inoltre, se il vostro news server richiede uno username o una password per
consentirvi l’accesso o se state usando una connessione telefonica o i
Servizi di Accesso Remoto (RAS), dovete configurare correttamente Agent
per queste caratteristiche.

Per registrare Agent:

1. Eseguite Agent.

Windows 95 – Cliccate il pulsante Start, selezionate Programmi, quindi il
menu a tendina Agent e cliccate l’icona di Agent.

Windows 3.x - In Program Manager, aprite il gruppo Agent e fate un
doppio click sull’icona Agent.

2. Leggete il contratto di licenza (solo nelle versioni scaricate). Cliccate il
pulsante Agree per continuare.

3. Registrate la vostra copia di Agent. Vi viene chiesto di registrare il
vostro software prima di poter usare Agent.

Per le copie di Agent scaricate elettronicamente, copiate il codice di
registrazione che vi è stato spedito via email dopo l’acquisto di Agent e
incollatelo dentro la finestra di dialogo di registrazione di Agent (guardate
l’esempio qui sotto). Quindi premete OK.
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Per le versioni confezionate di Agent, scrivete il vostro nome, il nome
della vostra organizzazione (facoltativo), e il serial number (che si trova
sulla confezione), come mostrato di seguito. Quindi premete OK.

Dopo aver registrato la vostra copia di Agent, comparirà la finestra di dialogo
Agent Setup.
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Nota: se avete installato una versione nuova su una versione precedente, la
finestra di dialogo Agent Setup non comparirà. Nel caso in cui facciate
l’aggiornamento da Free Agent, il procedimento avverrà automaticamente, le
vostre impostazioni di setup verranno mantenute e la finestra di dialogo non
apparirà.

Se state già usando un altro programma per Internet, premete
semplicemente Use Information From Another Program e Agent riempirà
automaticamente le informazioni al vostro posto. Se non usate uno dei
programmi elencati, o se incontrate dei problemi mentre prendete le
informazioni da un altro programma, sarà necessario immettere i dati
manualmente come descritto sotto. Se non siete sicuri riguardo a qualche
particolare contattate cortesemente l’assistenza del vostro provider.

1. News (NNTP) Server - il vostro news server o il suo indirizzo IP.

2. Mail (SMTP) Server – il vostro server email o il suo indirizzo IP.

3. Email Address – il vostro indirizzo email completo.
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4. Full Name - (Facoltativo) il vostro nome completo. Questo nome
sarà contenuto con il vostro indirizzo e-mail nei messaggi che spedite. È
vantaggioso includere il vostro nome completo se il vostro indirizzo email
non contiene il vostro nome. Inoltre alcuni newsreader mostrano il nome
completo, se disponibile, piuttosto che l’indirizzo email.

5. Time Zone - (solo Agent a 16-bit) Selezionate il fuso orario in
cui siete situati. Agent usa il fuso orario per convertire le date dei messaggi
nella vostra ora locale.

6. Automatically adjust for Daylight Saving Time - (solo Agent a 16-bit.
Agent a 32-bit usa le impostazioni dell’ora di Windows). Selezionate
questa casella se vivete dove l’ora legale è in vigore tra Aprile e Ottobre.
Durante questi mesi Agent compenserà automaticamente la differenza di
orario.

Scaricare la lista completa dei gruppi
Appena avrete finito di inserire le informazioni necessarie nella finestra di
dialogo Agent Setup e avrete premuto OK, comparirà una finestra
chiedendovi se volete andare online per ricevere tutti i newsgroup disponibili.

• Se non avete bisogno di un’autentificazione per collegarvi al vostro
news server, premete Yes e Agent si procurerà una lista di tutti i
newsgroup disponibili dal vostro provider. Siccome ci sono migliaia di
gruppi disponibili su Internet, questa operazione potrà richiedere diversi
minuti.

• Se il vostro news server necessita di un’autorizzazione per
collegarsi , dovete fornire le informazioni appropriate per accedere. Fate
attenzione che la maggior parte dei news server non richiede
autenticazione. Se non siete sicuri, verificate con il vostro provider. Per

Per
configura
re la
ricezione
delle
email,
andate a
p. 25
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impostare l’autorizzazione, premete No nella finestra di dialogo suddetta
e seguite queste istruzioni:

Per impostare l’autorizzazione al news server:

Selezionate Options→User and System Profile→User. In questa scheda,
completate le impostazioni seguenti come mostrato qui sotto.

1. Server requires authorization login – Selezionate questa casella
se il vostro news server richiede uno user name e/o una password
per consentirvi l’accesso. Se la casella è selezionata, Agent fornirà
automaticamente il vostro user name quando il news server lo
richiederà.

2. User Name - Inserite lo user name richiesto dal vostro news server
per collegarvi.

3. Remember Password between sessions – Selezionate questa
casella se il vostro news server necessita di una speciale password
per consentirvi l’accesso e volete che Agent immetta
automaticamente la password per voi. Se non selezionate questa
casella, dovrete immettere la vostra password ogni volta che
accedete al vostro news server.

4. Password – Inserite la password richiesta dal vostro news server
per accedere. Per sicurezza, la vostra password compare sotto
forma di asterischi (*).

Adesso che avete impostato l’autorizzazione al news server, selezionate
Online→Get New Groups per ricevere la lista di tutti i newsgroup.



Come iniziare

19

_____________________________________________________________

OO Potete annullare in qualsiasi momento il procedimento di
scaricamento, cliccando il segnale di Stop  sulla barra degli
strumenti. Per ricevere successivamente una lista completa dei gruppi,
dovete selezionare Online→Refresh Groups List. Agent elenca i nomi
dei newsgroup nel pannello Groups/Folders, come mostrato qui sotto.
Nota: Quando scaricate i gruppi per la prima volta, tutti i newsgroup
sono contrassegnati con l’icona New Group . Al successivo
scaricamento dei nuovi gruppi questa icona verrà rimossa dai
newsgroup esistenti, comparendo solo vicino ai nuovi gruppi più
recenti.

_____________________________________________________________

La disposizione a tre pannelli di Agent
Quando Agent inizia a scaricare la lista completa dei gruppi del vostro
server, darete la vostra prima occhiata alla finestra di navigazione principale
di Agent.
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Per default, questa finestra è divisa in tre pannelli . Ogni pannello ha una
funzione distinta. Il pannello superiore sinistro, Groups/Folders, mostra la
lista dei gruppi e delle cartelle, il pannello superiore destro, Message List,
mostra la lista dei messaggi del gruppo selezionato, e il pannello inferiore,
Message, mostra il corpo del messaggio evidenziato. Potete ingrandire
ciascun pannello semplicemente rendendolo attivo con un click (assegnando
cioè il “focus” a quel pannello) e premendo il tasto "z".

Per una descrizione completa di tutte le parti della finestra di navigazione
principale di Agent, date un’occhiata a "L’interfaccia utente di Agent" nel
prossimo capitolo.

La vostra prima sessione con Agent
Adesso che tutti i gruppi sono stati ricevuti, siete pronti per esplorare e
lavorare con Agent. Per aiutarvi a partire, vi abbiamo fornito alcuni semplici
passi da seguire.

Trovare i gruppi di vostro interesse

La prima cosa che occorre fare è di esaminare la lunga lista dei gruppi che
avete scaricato e trovare i gruppi che vi interessano. Potete scorrere l’elenco
e scegliere i gruppi in maniera casuale, oppure usare la funzione Find per
trovare del testo specifico. Quando avete trovato un newsgroup che volete
seguire, potete sottoscriverlo. Questa operazione vi consente di tornare
velocemente a quel gruppo ogni volta che aprite Agent.

Per usare la funzione Find:

1. Selezionate Edit→Find (oppure usate la scorciatoia Ctrl+F) e verrà
visualizzata la finestra di dialogo Find.

2. Inserite una parte del nome del gruppo che volete trovare. Ad esempio,
per trovare il gruppo alt.usenet.offline-reader.forte-agent, potreste
inserire "agent". Premete Find First per passare alla prima
corrispondenza di quel testo nella lista. Se la prima ricorrenza non è il
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gruppo che volete, premete Find Next (oppure usate il tasto F3) per
trovare ulteriori corrispondenze del testo.

Prelevare un campione di headers da un gruppo

Anche se dal nome un gruppo può sembrarvi interessante, potrebbe essere
d’aiuto leggere alcuni messaggi per verificare di cosa tratta realmente il
newsgroup. Agent vi consente di prelevare un campione dei messaggi di
quel gruppo (anziché scaricare tutti i messaggi del gruppo) per darvi un
assaggio dei tipi di argomento trattati.

Per prelevare un campione di header:

1. Fate un doppio-click sul nome del gruppo a cui siete interessati. Siccome
è un gruppo "vuoto", Agent vi mostrerà la finestra di dialogo View Empty
Group.

La seguente tabella descrive le tre funzioni fondamentali che voi potete
eseguire utilizzando la finestra di dialogo View Empty Group.

Scegliete questa opzione... ...per far fare questo ad Agent.

Sample Message Headers /
Number to sample

Scarica il numero specificato di header,
prendendoli tra i più recenti in un gruppo.
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Get All Message Headers
Scarica tutti gli header attualmente
disponibili per un gruppo. Questi possono
ammontare ad alcune migliaia, in certi
newsgroup.

Subscribe to Group Aggiunge questo gruppo alla lista dei gruppi
sottoscritti.
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2. In questa sessione iniziale, inserite il numero dei messaggi che volete
prelevare nel campo Number to sample. Potete lasciare questo campo
impostato sul valore predefinito, che è 50. Premete il pulsante Sample
Message Headers. Agent scaricherà il numero preciso degli header più
recenti nel gruppo selezionato e li visualizzerà nel pannello Message List
(come mostrato sotto).

Scaricare e leggere i body dei messaggi

Nel pannello Message List, esaminate gli header che avete scaricato (ad
esempio, i subject) e selezionate quelli il cui subject vi interessa.

Per selezionare header multipli:

• Per header consecutivi - Cliccate sul primo degli header che volete e
trascinate il mouse verso il basso, oppure selezionate il primo, poi tenete
premuto il tasto Shift e selezionate l’ultimo messaggio.

• Per header non consecutivi  - Cliccate sul primo header e quindi tenete
premuto il tasto Ctrl mentre cliccate sugli altri header desiderati.

Per scaricare i body dei messaggi selezionati:
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Selezionate Online→Get Selected Message Bodies oppure premete Enter.
Se avete selezionato solo un header, potete anche fare un doppio click su di
esso per scaricare il corpo, che comparirà nel pannello Message.

Quando Agent riceve più di un messaggio, mostra il corpo del primo header
selezionato. Per leggere i messaggi successivi usate l’opzione
Navigate→Skip to Next Unread Message Body (oppure la scorciatoia "B").

Sottoscrivere i gruppi che vi interessano

Dopo aver ricevuto un campione di alcuni messaggi, se volete seguire il
gruppo con regolarità potete sottoscrivere il gruppo. La sottoscrizione non vi
costa nulla ed inoltre nessun’altro verrà a saperlo. È solo una procedura
interna di Agent ed è semplicemente un sistema pratico di organizzazione
per consultare con facilità i gruppi che utilizzate spesso.

Per sottoscrivere un gruppo premete  sulla barra degli strumenti, o
selezionate Group→Subscribe, oppure digitate Ctrl+S.

Nella sessione di Agent successiva, sia premendo  sulla barra degli
strumenti o selezionando Online→Get New Headers in Subscribed Groups
scaricherete tutti gli headers nei gruppi sottoscritti.

Per visualizzare solo i vostri gruppi sottoscritti, cliccate la barra del titolo del
pannello Groups/Folders fino a che vedete Subscribed Groups , oppure
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selezionate Group→Show Groups and Folders→Subscribed Groups and
Folders.

Ricevere le email per la prima volta
Durante l’installazione di Agent avevate immesso un profilo del mail
server SMTP usato per la spedizione delle email. Adesso è necessario
impostare Agent per ricevere la posta.

Impostare Agent per ricevere le email:

Scegliete Options→Inbound Email per aprire la finestra di dialogo New
Folder.

La finestra di dialogo New Folder vi dice che per far sì che Agent riceva le
email dovete creare un folder Inbox (potete chiamarlo in qualche altro modo
diverso da "Inbox", se vi pare). Quando premete OK, la cartella Inbox (o altro
nome) viene creata e viene visualizzata la finestra di dialogo Inbound Email.

Vedi anche la
finestra di
dialogo Agent
Setup a
pagina 15.
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Nella scheda System Profile, completate le impostazioni per il tipo di server
che state usando per ricevere la posta. Se non siete sicuri di questi
parametri, verificate con il vostro provider.

1. Receive email with POP – Selezionate questa opzione se ricevete la
posta con un POP server. La maggior parte degli utenti riceve la posta
usando il POP server.

2. POP server – Inserite il nome del vostro POP server o il suo indirizzo IP.
Spesso questo è lo stesso nome del server SMTP.

3. Login with a username and password – Selezionate questa opzione
se avete bisogno di uno username e una password per accedere al
vostro server.

4. Use APOP if supported by the server – Selezionate questa casella per
imporre ad Agent di usare APOP (Authenticated Post Office Protocol,
che può essere richiesta da alcuni POP server) durante l’accesso al
server. Agent utilizzerà APOP se il server mostrerà, nel suo messaggio
di saluto, di accettare APOP. Altrimenti Agent userà il tradizionale
accesso POP.

5. Username – Inserite il nome utilizzato per connettervi al mail server per
ricevere i nuovi messaggi. Ad esempio, gbrown.

6. Remember password between sessions – Selezionate questa casella
e inserite la vostra password al punto 5 per far sì che Agent immetta
automaticamente la vostra password quando verifica se ci sono nuovi
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messaggi. Quando questa casella viene lasciata deselezionata, Agent vi
chiede la password una volta per ciascuna sessione di lavoro.

7. Password – Inserite la vostra password di email se volete che Agent si
colleghi automaticamente al vostro mail server quando controlla i nuovi
messaggi. Nota: per sicurezza, la vostra password compare sotto forma
di asterischi (*).

8. Login with Secure Password Authentication – Questa opzione è
disponibile solo per gli utenti di un sistema a 32 bit. Se state usando un
PC a 16-bit, questa impostazione è oscurata. Selezionate questa
opzione se il vostro server richiede il protocollo Secure Password
Authentication (o SPA) per consentirvi l’accesso. Nota: Quando
selezionate questa opzione, SPA vi chiederà di immettere le vostre
credenziali. Questo è il motivo per cui lo Username e la Password sono
oscurati.

9. Receive email with SMTP – Selezionate questa opzione se la vostra
posta in arrivo viene consegnata via SMTP.

1. Load Winsock on startup – Selezionate questa opzione se volete
collegarvi al vostro provider immediatamente al caricamento di Agent.
Questo consente ad Agent di ricevere la nuova posta ogni volta che il
programma è in esecuzione ed è online, anche se state usando un altro
programma per Internet. Quando questa opzione viene lasciata
deselezionata, Agent può scaricare la posta solo mentre compie qualche
altra operazione online, come comunicare col news server o spedire
messaggi.

Per verificare manualmente se ci sono nuovi messaggi:

Una volta che avete inserito le informazioni in System Profile, potete
scaricare subito la vostra posta selezionando Online→Check for Email
(oppure usando la scorciatoia da tastiera Ctrl+E). Agent va online e si
connette al vostro POP server, controllando la presenza di messaggi
nella vostra mailbox ed eventualmente scaricandoli sul vostro computer.

Impostare Agent per controllare automaticamente la posta:

Cliccate Options→Inbound Email→Checking Mail e selezionate la prima
opzione "Automatically check for email every...". Quindi specificate nella
casella quanti minuti volete che passino tra un controllo della posta e
l’altro. Quando questa casella è selezionata, Agent controllerà
automaticamente la posta subito dopo il lancio, e successivamente ad
intervalli regolari, in base al valore che avete immesso.

Per
maggiori
dettagli,
vedere p.
51.

Per
maggiori
dettagli
riguardo a
questa
scheda,
vedere
pagina 67.
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CAPITOLO 3

Fondamenti di Agent
Il capitolo precedente vi ha condotto passo dopo passo nel processo d’installazione e nel
recupero della lista completa dei newsgroup disponibili sul vostro news server. Una volta
completata quest’ultima operazione molto probabilmente non sarà più necessario ripeterla in
futuro. Ora siete pronti per iniziare ad usare tutti gli strumenti di Agent. Prima di buttarvici a
capofitto però dovreste prendere confidenza con alcuni concetti chiave che stanno dietro il
modo in cui Agent lavora.

1 L’interfaccia utente di Agent

1 Muoversi in Agent

1 Proprietà dei gruppi

1 Multi-Tasking

1 Lavorare Online ed Offline

L’interfaccia utente di Agent

I tre pannelli della finestra principale

Gran parte del tempo opererete nella finestra principale di Agent, che per
default è suddivisa in tre pannelli (come si vede nella figura che segue).
Questa sezione descrive in dettaglio tutti gli elementi di questi tre pannelli.
Imparerete quali informazioni vi sono contenute ed il significato delle diverse
icone che incontrerete nell’utilizzo di Agent.
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Ecco una descrizione di ogni elemento:

Barra dei Menu – Sulla Barra dei Menu sono elencati tutti i menu di comandi
di Agent. Per accedere a un menu potete cliccare sul suo nome o premere
Alt e la lettera che appare sottolineata nel nome stesso (per es., per il menu
File, premete Alt+F).

Barra degli strumenti – I pulsanti della Barra degli strumenti, situata sotto
quella dei Menu, consentono un rapido accesso ad alcuni fra i più comuni
comandi di Agent. Potete personalizzare questa barra in modo che contenga
i comandi che usate più di frequente. Per sapere la funzione di ogni pulsante,
posizionate su di esso il cursore e apparirà una breve descrizione.

Nota: Se in un determinato momento un pulsante non è utilizzabile esso
apparirà oscurato.

Barra del titolo – La Barra del titolo che compare sopra ogni pannello
fornisce informazioni sul suo contenuto (per es., quali gruppi sono
visualizzati o quale vista si sta utilizzando per la lista dei messaggi).

Pannello Groups/Folders – In questo pannello sono elencati i gruppi e le
cartelle. Premendo ripetutamente la Barra del titolo di questo pannello (o
selezionando l’opzione opportuna da Group→Show Groups and Folders),

Vedi "Barre
degli
strumenti" a
pag. 179.
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potrete visualizzare tutti i gruppi e le cartelle, solo i gruppi sottoscritti e le
cartelle, solo i gruppi nuovi, o solo le cartelle.

Pannello Message list – In questo pannello viene visualizzata la lista degli
header dei messaggi contenuti nei gruppi o nelle cartelle selezionati. Per ogni
header sono riportati il subject, l’autore, la data e l’ora.

L’insieme di un messaggio e delle sue risposte viene denominato “thread” e
può essere ristretto per risparmiare spazio sul monitor, o espanso per vedere
tutte le risposte. Quando un thread è espanso, tutte le risposte appaiono con
un rientro, immediatamente sotto il messaggio che le precede, e ne viene
visualizzato solo l’autore, dal momento che il titolo rimane lo stesso del
messaggio precedente.

Nell’esempio mostrato a pag. 30, il pannello attivo è quello con la lista dei
messaggi, come indicato dall’aspetto solido del triangolino, nell’angolo in alto
a sinistra della Barra del titolo. Sebbene si possano vedere
contemporaneamente tutte e tre le finestre, se ne può rendere attiva solo una
alla volta.

Notate che tutte le informazioni contenute nel pannello Message List sono
organizzate in colonne. Nell’esempio di pag. 30, la colonna più a sinistra,
Thread, è sottolineata, ciò indica che i messaggi sono ordinati per thread.
Potete ordinarli per autore, data, dimensione, titolo o thread aprendo il menu
Group→Sort Messages by, o semplicemente cliccando sul titolo della
colonna stessa. Cliccando sul titolo della colonna più a sinistra si alterna fra
l’ordinamento per thread e per dimensione.
_____________________________________________________________

OO Espandendo la finestra (con il tasto "z"), sarete in grado di vedere più
colonne. Queste possono essere facilmente ridimensionate
trascinandone il limite con il mouse, sulla barra del titolo. La colonna
più a sinistra (Thread nell’esempio) non può, però, essere ristretta a
piacimento.

_____________________________________________________________

Quando gli header sono stati appena scaricati, i messaggi corrispondenti non
saranno ancora stati letti. Agent indica ciò visualizzando in rosso i messaggi
non letti. Quando un messaggio viene letto, il suo header diventa nero. Ogni
volta che scaricate i nuovi header da un gruppo, Agent marca
automaticamente come letti i messaggi scaricati in precedenza. In questo
modo i nuovi messaggi vengono messi in evidenza. Potete modificare questa
funzione sulla scheda Group→Properties→Mark Read. (Vedi p. 42 per
maggiori dettagli). Potete anche utilizzare Group→Mark Selected Groups
Read o Group→Mark Selected Groups Unread per modificare la condizione

Vedi
"Espandere e
restringere i
thread" a pag.
41
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letto/non letto di tutti i messaggi di un gruppo, oppure Message→Mark Read
o Message→Mark Unread per intervenire su singoli messaggi [oppure usare
la scorciatoia x].

Pannello Message – Nel pannello più in basso viene visualizzato il “corpo”,
ossia il testo contenuto nel messaggio selezionato.

Barra di scorrimento - Sul lato destro di ogni pannello si trova una barra di
scorrimento che permette di far scorrere verticalmente il contenuto di ciascun
pannello (gruppi e cartelle, intestazioni dei messaggi e testo di questi). Il
pannello del messaggio ha anche una barra di scorrimento orizzontale che
consente lo scorrimento in orizzontale, per visualizzare parti di messaggio
altrimenti non visibili.

Barra di stato – La barra di stato sotto la Finestra del messaggio contiene
informazioni sullo stato di Agent, per es. se si è online od offline.

Menu contestuali - Agent supporta menu sensibili al contesto. Ciò significa
che se cliccate col tasto destro del mouse in uno dei pannelli, comparirà un
menu con i comandi più utilizzati per quel pannello.

Icone e Indicatori

Nella finestra principale di Agent, già mostrata in precedenza, vedrete un
certo numero di icone e di indicatori. Per una descrizione di ognuno di questi
vedete le seguenti tabelle. Esse costituiscono un riferimento generale ed
alcuni dei termini contenuti sono spiegati altrove in questa guida. (I numeri e i
testi nelle tabelle si riferiscono a quanto mostrato nella figura a pag. 30).

Icone del pannello Groups/Folders

Icona Significato

5 / 23737
Contatore dei gruppi - (situato sulla barra del titolo) Il numero
di gruppi mostrati pannello, seguito dal numero totale dei gruppi
disponibili.

144
Contatore dei messaggi non letti  - (precede il nome di ogni
gruppo) Il numero dei messaggi non letti contenuti nel gruppo.

Marca per il recupero – Uno o più messaggi di quel gruppo
sono marcati per essere scaricati successivamente.

Gruppi sottoscritti  - (precede il nome dei gruppi sottoscritti)
Per sottoscrivere e desottoscrivere un gruppo, premete il
pulsante Subscribe sulla barra degli strumenti, selezionate
l’opzione Subscribe nel menu Group, o digitate Ctrl+S.



Fondamenti di Agent

33

Nuovi gruppi  - (precede il nome di ciascun nuovo gruppo) Per
ottenere la lista dei gruppi che sono stati aggiunti sul vostro
news server dall’ultima volta che li avete scaricati, selezionate
Get New Groups  dal menu Online.
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Icone del pannello Message List

Icona Significato

Vista - (situato sulla barra del titolo del pannello) La vista attiva al
momento. Cliccate sul binocolo per selezionarne un’altra.

In recupero – Il testo del messaggio è in fase di recupero.

Espandi il thread –Cliccate su quest’icona per vedere tutte le
risposte.

Restringi il thread –Cliccate su quest’icona per nascondere le
risposte.

[+2]
Numero di risposte – Quando un thread è ristretto, questo è il
numero di risposte al messaggio originale.

21 Numero di linee – Il numero di linee di testo nel messaggio.

Usenet

Email

Corpo del messaggio – Il corpo del messaggio è stato scaricato.
Quando queste icone appaiono bianche, esse indicano che il
messaggio è costituito di solo testo. Se sono gialle il messaggio ha
degli allegati. Quando sono verdi allora tutti gli allegati di quel
messaggio sono stati salvati.

Corpo del messaggio non disponibile – Il messaggio è stato
cancellato dal vostro news server e non può più essere scaricato.

Segui il thread – Agent scaricherà automaticamente il corpo delle
risposte al messaggio in fase di recupero dei nuovi header.

Ignora il thread -Le risposte al messaggio saranno automaticamente
segnate come lette.

Marca per il recupero – Il corpo del messaggio sarà recuperato la
prossima volta che selezionerete Retrieve Marked Messages  dal menu
Online.

Conserva Messaggio – Il messaggio che avete deciso di conservare
non potrà essere cancellato, nè manualmente nè da Agent con la
funzione di purging automatico.

Indicatori della barra del titolo nel pannello Message

Indicatore Significato

Indicatore di stato del messaggio – Sulla barra del titolo è
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indicato lo stato del messaggio (per es., se il messaggio è stato
scaricato o se si trova in un thread da seguire). Sono inoltre
mostrati il titolo e l’autore del messaggio, nonché la data e l’ora
di composizione.

Indicatori della barra di stato

Indicatore Significato

Connecting to server. Descrizione dell’operazione - Vi permette di sapere
quale operazione Agent sta svolgendo.

Offline Stato di Offline od Online – Vi dice se in quel
momento siete connessi al news server (online) o
disconnessi (offline).

Tasks: 1 Stato delle operazioni  – Le operazioni in via di
svolgimento.

Indicatore Significato

6 / 8 Numero di  messaggi non letti  – Il numero di
messaggi non letti ed il numero totale dei messaggi
attualmente visualizzati nel pannello della lista dei
messaggi.

SCRL Stato del tasto Scroll Lock – Lo stato dello Scroll
Lock è indipendente per ciascun pannello di Agent.
Premendo ripetutamente questo tasto, potete abilitare o
disabilitare lo scroll lock per ogni singolo pannello.
Quando questo è abilitato, vedrete SCRL sulla barra di
stato.

OVR
(Nella figura a pag. 30,
questo indicatore e i
precedenti due sono
nascosti dal menu
contestuale.)

Stato di Inserimento/Sovrascrittura  – Nella
composizione di un messaggio, potete sovrascrivere i
caratteri già presenti passando dal “modo inserimento”
al “modo sovrascrittura”. Per fare ciò, posizionate il
cursore nel punto in cui volete iniziare la sovrascrittura,
quindi premete il tasto Ins fino a far comparire OVR
sull’estrema destra della barra di stato. Ora siete in
grado di sovrascrivere il testo. Per tornare al “modo
inserimento”, premete nuovamente il tasto Ins. OVR
scomparirà dalla barra di stato e non sovrascriverete più
i caratteri già esistenti.

Altre finestre di Agent

.In Agent ci sono altre finestre, oltre quella principale a tre pannelli. Queste
finestre (descritte altrove in questa Guida) vi permettono di svolgere altre
operazioni (per es., le finestre della Rubrica e dei Filtri Usenet). Per aprire queste
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finestre, utilizzate il menu Window. Per default, Agent aprirà una sola finestra per
ciascun tipo. Selezionando dal menu Window una finestra già aperta la si rende
attiva. Tenendo premuto Shift mentre si seleziona la finestra, se ne apre una
nuova. Per passare da una finestra aperta ad un’altra potete usare il menu
Window e scegliere dall’elenco delle finestre aperte, oppure potete premere
Ctrl+Tab.

Navigare in Agent
Agent vi fornisce un ricco set di strumenti per muovervi fra newsgroup, cartelle e
messaggi. Si può accedere a questi strumenti dal menu Navigate, dalla barra
degli strumenti o dalla tastiera. Anche se probabilmente non sfrutterete tutte le
opzioni disponibili, questa sezione vi consentirà di familiarizzare con esse in modo
tale che possiate scegliere le tecniche di “navigazione” che più vi sono congeniali.

Muoversi tra i pannelli

, Come già visto nella sezione precedente, Agent si compone di tre pannelli:
Groups/Folders, Message List, Message. Potete visualizzare tutte e tre i pannelli
contemporaneamente o, per visualizzare il maggior numero di informazioni,
ingrandire la finestra attiva in modo da riempire tutta la schermata principale di
Agent.

Per ingrandire (massimizzare) un pannello:

Usate una delle seguenti opzioni.

Icona del pannello:  Windows 95  Windows 3.1

Opzione del menu: Navigate→Zoom Window

Scorciatoia da tastiera: Z

Per tornare ai tre pannelli dopo averne ingrandito uno:

Usate una delle seguenti opzioni.

Icona del pannello:  Windows 95  Windows 3.1
Opzione del menu: Navigate→Zoom Window

Scorciatoia da tastiera: Z

Potete facilmente scegliere la finestra attiva sia con il mouse sia con la tastiera.

Per muoversi tra i pannelli con il mouse:

• Quando i tre pannelli sono tutti visualizzati, semplicemente cliccate sulla
finestra desiderata.
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• Quando un pannello è ingrandito, cliccate sull’etichetta della finestra che
volete visualizzare:

Per muoversi fra i pannelli con la tastiera:

• Premete il tasto Tab per spostarvi da un pannello all’altro, in successione:
lista dei gruppi, lista dei messaggi e messaggio.

• Premete Shift+Tab o Esc per spostarvi in senso opposto.

• Premete i tasti "1", "2", o "3" per scegliere uno dei tre pannelli.

Premendo "1" si rende attivo il pannello dei gruppi, con "2" la lista dei
messaggi, con "3" il messaggio.

Muoversi fra i Messaggi

Muovervi fra i messaggi è probabilmente l’azione che svolgerete più di
frequente in Agent. Questo è il motivo per cui Agent vi dà così tanti modi per
farlo. Prima di entrare in dettagli, vale la pena di capire qual è l’approccio di
Agent alla navigazione fra i messaggi.

I comandi di navigazione di Agent sono organizzati in modo tale da farvi
muovere facilmente fra gli header (per es. “Skip to next unread”, ossia “salta
al prossimo messaggio non letto”) o fra i corpi dei messaggi (per es. “Skip to
the next unread message with a body”, ossia “salta al prossimo messaggio
non letto, con corpo”). Alcuni utenti amano operare soprattutto nella lista dei
messaggi, mentre altri preferiscono lavorare direttamente nel pannello del
messaggio, dove compare il testo. Agent vi consente di effettuare entrambe
le cose molto facilmente.

Per semplificare la navigazione, Agent mette a disposizione i comandi skip e
view. Quando saltate (skip) ad un messaggio, vi portate su di esso ma
rimanete nello stesso pannello, di solito la lista dei Messaggi. Quando invece
lo visualizzate (view), passate al pannello del messaggio, scaricando anche il
corpo se non lo avevate ancora fatto. Le combinazioni da tastiera riflettono
questa distinzione. Per saltare, usate la lettera appropriata (per es. "N" per
saltare al successivo [Next] messaggio non letto). Per visualizzare, usate
Ctrl+lettera (per es . Ctrl+N per visualizzare il successivo [Next] messaggio
non letto).

Ecco i dettagli:

Per spostarsi al messaggio precedente o successivo:

• Nella lista dei messaggi, potete usare le frecce in su e in giù.
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• Nella messaggio o nella lista dei Messaggi, scegliete Navigate→Up to
Previous Message (o premete "U") per andare su al messaggio
immediatamente sopra, o Navigate→Down to Next Message (o premete
"D") per andare giù al messaggio successivo.

• Premete il tasto Backspace,  o la combinazione Alt+Freccia a sinistra, o
ancora selezionate Back Up dal menu Navigate per spostarvi al
messaggio da voi evidenziato in precedenza. Agent vi permette di
ripercorrere fino a 100 operazioni.

• Se avete ripercorso indietro i vostri passi con il comando Backspace,
potete ora rifarli in avanti e ripetere le vostre precedenti operazioni
premendo Shift+Backspace o Alt+Freccia a destra, o selezionando
Navigate→Forward.

Per saltare al successivo messaggio non letto:

Per saltare al successivo messaggio non letto utilizzate una qualunque delle
seguenti opzioni, sia che ne abbiate già scaricato il testo sia che non
l’abbiate ancora fatto.

Pulsante della barra degli strumenti:

Opzione del menu: Navigate→Skip to Next Unread Message

Scorciatoia da tastiera: N

Usate invece queste altre per saltare al successivo messaggio di cui abbiate
scaricato il corpo.

Pulsante della barra degli strumenti:

Opzione del menu: Navigate→Skip to Next Unread Message Body

Scorciatoia da tastiera: B
_________________________________________________________________________________________________________________________________________________________

OO Per default, se il successivo messaggio non letto è in un gruppo
diverso, premendo "N" o "B" Agent apre quel gruppo o quella cartella e
seleziona il primo messaggio da leggere. Se invece preferite tornare
alla lista dei gruppi deselezionate Skipping to next unread message
jumps to first unread message in next group nella scheda
Options→General Preferences→Navigation.

_____________________________________________________________

Per saltare al successivo messaggio non letto nello stesso thread:

Un thread è costituito da una serie di messaggi fra loro correlati, raggruppati
insieme. Per esempio, dato un messaggio iniziale, eventuali repliche a quel



Fondamenti di Agent

39

messaggio vengono comunemente dette follow-up. L’insieme del messaggio
iniziale e dei follow-up viene chiamato thread. Usate una delle seguenti
opzioni.

Pulsante della Barra degli strumenti:

Opzione del menu: Navigate→Skip to Next Unread Message in Thread

Scorciatoia da tastiera: T

Questa operazione è piuttosto comoda perché quando arrivate all’ultimo
messaggio di follow-up, Agent si ferma e vi comunica che quel thread è
esaurito.

Per passare al successivo gruppo (o cartella) non letto:

Usate una delle seguenti opzioni.

Pulsante della Barra degli strumenti:

Opzione del menu: Navigate→Skip to Next Unread Group

Scorciatoia da tastiera: S

Eseguendo questa azione, tutti i messaggi non letti del gruppo (o della
cartella) corrente verranno marcati come letti prima di passare al successivo.
Si tratta di un modo conveniente per dire ad Agent che avete letto tutti i
messaggi di vostro interesse nel gruppo corrente. Per disabilitare questa
funzione deselezionate Skipping to next unread group marks all messages in
current group read nella scheda Options→General Preferences→Navigation.

Per spostarsi sul successivo messaggio con corpo non letto...

...e visualizzarne il testo, usate una delle seguenti opzioni.

Pulsante della Barra degli strumenti:

Opzione del menu: Navigate→View Next Unread Message Body

Scorciatoia da tastiera: Ctrl+B
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Muoversi in Agent e recuperare messaggi allo stesso tempo

Dal momento che per leggere il testo di un messaggio bisogna prima scaricarne
il corpo, Agent vi permette di saltare ad un messaggio non letto e recuperarlo (o
marcarlo per il recupero) in un unico passaggio. Nota: il fatto che Agent recuperi
il messaggio o si limiti a marcarlo per un successivo recupero dipende
dall’opzione Viewing Unretrieved Messages When Offline sulla scheda
Options→User and System Profile→Online.

Quando lavorate offline in genere è preferibile prima marcare per il recupero
tutti i messaggi desiderati e quindi scaricarne i corpi. Per default, quando
marcate un messaggio per il recupero Agent salta a quello non letto
immediatamente successivo (come se premeste "N"). Potete disattivare questa
funzione deselezionando la casella Marking or ignoring a message skips to the
next unread message, nella scheda Options→General
Preferences→Navigation.

Per scaricare il successivo messaggio non letto:

Usate una delle seguenti opzioni.

Pulsante della Barra degli strumenti:

Opzione del menu: Navigate→View Next Unread Message

Scorciatoia da tastiera: Ctrl+N

 Per spostarvi al successivo messaggio non letto nel thread corrente e
recuperarlo, o marcarlo per il recupero:

Usate una delle seguenti opzioni.

Pulsante della Barra degli strumenti:

Opzione del menu: Navigate→View Next Unread Message in Thread

Scorciatoia da tastiera: Ctrl+T

Navigazione monotasto

 Come nei vecchi newsreader in stile Unix, potete usare la barra spaziatrice
per spostarvi da un messaggio all’altro. Per default, la barra esegue il
comando “salta al successivo messaggio non letto” (comando “N”). Per
eseguire invece il comando “vai al prossimo messaggio non letto, con corpo”
(Ctrl+B), andate su Options→General Preferences→Navigation e
selezionate Single Key Read views next unread message body.

Vedi la
sezione
"Offline
Mode" a
pagina 47.
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Espandere e restringere i thread

Agent mostra i messaggi di follow-up con un rientro, immediatamente sotto il
messaggio precedente.

Per risparmiare spazio a video i thread appaiono inizialmente ristretti, in
questo modo risulta visibile solo il primo messaggio della serie. Quando un
thread è ristretto, vicino ad esso compare l’icona Espandi Thread .

Per espandere un thread:

• Cliccate sull’icona Espandi il Thread.

• Selezionate il messaggio e premete il tasto "+".

• Premete la Freccia a destra.

Per espandere tutti i thread di un gruppo:

• Premete i tasti Shift +"+".

• Premete Shift+Freccia a destra. (Se non dovesse funzionare,
assicuratevi che il Num Lock sia disabilitato.)

Quando un thread è espanso, accanto ad esso compare l’icona Restringi il
Thread .

Per restringere un thread:

• Cliccate l’icona Restringi il Thread.

• Selezionate il messaggio e premete il tasto "-".

• Premete la Freccia a sinistra.

Per restringere tutti i thread di un gruppo:

• Premete i tasti Shift + "-".

• Premete i tasti Shift+Freccia a sinistra. (Se non dovesse funzionare,
assicuratevi che il Num Lock sia disabilitato.)

Agent è anche in grado di espandere automaticamente i thread. Per default,
Agent espande i thread quando saltate ad essi con una delle funzioni “skip”.
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Nota: Agent eseguirà quest’ultima azione solo se avete già recuperato il
corpo del messaggio originale.

Per evitare che Agent espanda i thread quando saltate ad essi,
deselezionate la casella Automatically expand threads containing new
messages sulla scheda Options→General Preferences→Navigation.

Se invece volete vedere sempre tutti i thread espansi, deselezionate Show
threads initially collapsed sempre sulla scheda Options→General
Preferences→Navigation. Per maggiori informazioni sull’espansione dei
thread, consultate l’Help in linea di Agent.

Proprietà dei gruppi
Una caratteristica utilissima di Agent è la possibilità di personalizzare fin nei
dettagli la gestione sia globale che del singolo gruppo. E’ importante
sottolineare che ogniqualvolta in questa Guida verranno descritte “Proprietà
dei gruppi”, sarà possibile applicare ognuna delle impostazioni sia a tutti i
gruppi sia soltanto ai gruppi selezionati.

Nota: In questo manuale, la convenzione per indicare il menu delle Proprietà
dei gruppi è Group→Properties→<scheda>. Tenete conto che questo può
riferirsi alle proprietà dei gruppi selezionati (Group→Properties→<scheda>) o
a quelle di tutti i gruppi (Group→Default Properties→<scheda>), a seconda
dell’opzione da voi scelta.

Impostare Proprietà di default per tutti i gruppi

Selezionate Group→Default Properties  per visualizzare la finestra di dialogo
“Default Properties for All Groups”. Apparirà una serie di schede contenenti i
diversi tipi di proprietà da impostare.

Per esempio, un’opzione predefinita sulla scheda Mark Read (mostrata più
sotto) è When retrieving new message headers... Mark all existing messages
read. Ciò significa che, per default, in tutti i gruppi in cui recupererete nuove
intestazioni, tutti i messaggi esistenti verranno marcati come letti.
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Impostare la Proprietà per i gruppi selezionati

Per seguire l’esempio del paragrafo precedente, cosa si deve fare se, per
alcuni gruppi, non si vuole che alcun messaggio venga segnato come letto
allo scaricamento di nuove intestazioni? E’ piuttosto semplice. Selezionate i
gruppi a cui applicare questa modifica, quindi andate su Group→Properties
per visualizzare la finestra di dialogo Properties for Selected Groups.
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La finestra di dialogo Properties for Selected Groups riprende fedelmente
tutte le schede e le opzioni dell’altra finestra di dialogo Default Properties for
All Groups. Per concludere l’operazione dell’esempio è sufficiente
selezionare la casella Override Default Settings sulla scheda Mark Read e
selezionare l’opzione Do not mark any existing messages read.

Quando selezionate più di un gruppo e quindi aprite la finestra Properties for
Selected Groups, le caselle e le opzioni possono essere in uno dei tre
seguenti stati:

• Inizialmente saranno tutte oscurate e le caselle potranno essere
selezionate oppure no. Ciò avviene perché le impostazioni possono
essere differenti nei vari gruppi selezionati.

• Cliccate su Override Default Settings fino a disabilitarlo. Dando "OK" a
questo punto, tutti i gruppi selezionati verranno caratterizzati con le
impostazioni di default per quella scheda.

• Cliccate ancora su Override Default Settings e tutte le caselle e le
opzioni diverranno attive. Impostatele come desiderate e date "OK" per
far sì che tutti i gruppi selezionati acquisiscano quelle caratteristiche.

Le proprietà dei gruppi funzionano così: le proprietà definite per default si
applicano a tutti i gruppi finché, per alcuni di questi, voi non decidete di
scavalcarle in alcuni gruppi. All’aumentare della vostra esperienza con
Agent, probabilmente vi troverete a regolare con grande cura le proprietà dei
singoli gruppi.

Multi-Tasking
Agent vi permette di svolgere numerose operazioni contemporaneamente.
Per esempio, potete leggere i messaggi di un gruppo mentre state
scaricando le intestazioni di un altro. Quando completate un’attività (per es.
marcare per il recupero i messaggi che vi interessano) potreste volerne
iniziare un’altra (per es. recuperare i messaggi marcati) prima di dedicarvi a
un’altra ancora. Se Agent sta già eseguendo un’operazione online, l’attività
che volete iniziare sarà accodata ed intrapresa non appena terminate quelle
che la precedono. La barra di stato di Agent vi dirà il numero di operazioni
accodate e quale di queste è in via di esecuzione.

Potete impostare Agent in modo che consideri alcune operazioni come
prioritarie rispetto alle altre. In particolare, potete far sì che Agent recuperi il
corpo di un messaggio anche se già impegnato in un’altra operazione online.
Questo vi permette di iniziare a leggere i nuovi messaggi di un gruppo
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mentre scaricate le intestazioni di un altro. Per i dettagli vedete la scheda
Options→User and System Profile→Online.

Lavorare Online ed Offline
Una delle migliori caratteristiche di Agent è che vi consente di lavorare online
od offline a seconda delle vostre esigenze individuali.

• Modo Online  - Usate Agent online se per voi il costo orario del
collegamento non è un problema. Nel Modo Online, Agent rimane
connesso al vostro news server, potete quindi recuperare nuovi
messaggi in qualunque momento senza dovervi ricollegare.

• Modo Offline  - Usate Agent offline se volete risparmiare sui costi di
connessione. Nel Modo Offline, Agent si collega al vostro news server
soltanto quando deve eseguire un’operazione online e se ne disconnette
subito dopo averla conclusa.

Quelle che seguono sono le normali operazioni che potreste eseguire in una
tipica sessione di Agent, descritte sia nel Modo Online sia in Modo Offline.
Naturalmente si tratta soltanto di esempi e le vostre sessioni di Agent
possono essere anche molto diverse.

Tenete presente che, anche se il vostro Modo preferito di lavoro è quello
online, passando al Modo Offline disporrete ancora di tutte le informazioni.
Ciò avviene perché, sia che siate online sia che siate offline, Agent conserva
localmente sul vostro disco rigido tutti i messaggi sia delle news che email.
Non avrete mai bisogno di ricollegarvi per rivedere messaggi che avete già
recuperato.

Modo Online

Ecco le operazioni che potrebbero caratterizzare una tipica sessione in Modo
Online:

1. Controllare la posta.  (Questo pulsante può essere aggiunto alla barra degli
strumenti come descritto a pag. 179.)

 Opzione del menu: Online→Check for new Email

 Scorciatoia da tastiera: Ctrl+E

2. Leggere i messaggi e decidere cosa fare.

 Letto un messaggio, potete eseguire una delle seguenti operazioni:

Per maggiori
dettagli,
vedete
"Retrieving
Email
Messages" a
pag. 67.
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• Mandare un messaggio email di risposta. 
 Questo pulsante apre la finestra di composizione del messaggio.
Opzione del menu: Post→Reply via Email
Scorciatoia da tastiera: R

• Archiviare il messaggio in una cartella.

 Copia nella cartella o   Sposta nella cartella (Questi pulsanti possono

essere aggiunti alla barra degli strumenti come descritto a pag. 179.)

 Opzione del menu:Message→Copy to Folder or Message→Move to Folder

 Scorciatoia da tastiera:  Alt+M+C+<numero file> o Alt+M+V+<numero file>

3. Scaricare i nuovi header nei gruppi selezionati. 
Quando vi trovate online è agevole muoversi da gruppo a gruppo, potete
così utilizzare questo comando per i gruppi selezionati. Ovviamente, se
preferite, potete scaricare le intestazione da tutti i gruppi sottoscritti.
Opzione del menu: Online→Get New Headers in Selected Groups
Scorciatoia da tastiera: Alt+O+H

4. Scaricare e leggere messaggi Usenet.
Dopo la lettura ci sono parecchie cose che potreste voler fare.

• Inviare un messaggio Usenet di risposta. 

Questo pulsante apre una finestra di composizione messaggio.

Comando del menu: Post→Follow-Up Usenet Message
Scorciatoia da tastiera: F

• Seguire un thread. 

Questa opzione aiuta a tenere d’occhio i thread d’interesse. Agent
scaricherà automaticamente i corpi dei messaggi nei thread da
seguire ogni volta che recupererete nuove intestazioni da quel
gruppo.

Comando del menu: Message→Watch Thread

Scorciatoia da tastiera: W

• Ignorare un thread. 

Per maggiori
dettagli,
vedete
"Overview"
a pag. 118.

Per i dettagli,
vedete "Filing
Messages in
Folders" a
pag. 57.

Vedete
"Retrieving
Messages in
Groups." a
pag. 62.
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Questa opzione rende possibile evitare i thread non interessanti.
Tutte le risposte nei thread da ignorare verranno automaticamente
marcate come lette.

Comando del menu: Message→Ignore Thread

Scorciatoia da tastiera: I

• Conservare un messaggio. 

 Questo comando segna i messaggi che volete conservare
indefinitamente. In questo modo non verranno cancellati durante
l’operazione di eliminazione automatica.

Comando del menu: Message→Keep

Scorciatoia da tastiera: K

• Archiviare il messaggio in una cartella.

 Copia nella cartella o   Sposta nella cartella (Questi pulsanti possono

essere aggiunti alla barra degli strumenti come descritto a pag. 179.)

 Opzione del menu: Message→Copy to Folder or Message→Move to Folder

 Scorciatoia da tastiera:  Alt+M+C+<numero file> o Alt+M+V+<numero file>

Offline Mode

Una tipica sessione di Agent in Modo Offline potrebbe essere come quella
che segue. Tenete presente che il fine del lavoro offline è quello di
minimizzare i tempi di connessione. Quel che si vuol fare è recuperare le
informazioni tutte insieme per poi leggerle con calma una volta disconnessi
da internet. Nota: potete impostare Agent in modo che vada
automaticamente online per eseguire queste operazioni ed offline dopo
averle concluse (cfr. la sezione seguente).

1. Controllare la posta.  (Questo pulsante può essere aggiunto alla barra degli
strumenti come descritto a pag. 179.)

 Opzione del menu: Online→Check for New Email

 Scorciatoia da tastiera: Ctrl+E

2. Scaricare nuove intestazioni dai gruppi sottoscritti. 

Opzione del menu: Online→Get New Headers in Subscribed Groups

Scorciatoia da tastiera: Alt+O+N

Per maggiori
dettagli vedete
pag. 114.

Per i dettagli
sull’archiviazione
dei messaggi
nelle cartelle,
vedete pag. 57.
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3. Andare offline.

4. Leggere le intestazioni e segnarle per il recupero. 
Questa operazione marca i messaggi che volete recuperare, cosicché
possiate collegarvi una volta sola per scaricarli.

Opzione del menu: Message→Mark for Retrieval

Scorciatoia da tastiera: M

5. Andare online e scaricare i messaggi marcati. 
 In questo modo Agent si connette solo per il tempo necessario a
recuperare i corpi dei messaggi marcati al punto 4.

Opzione del menu: Message→Get Marked message Bodies
Scorciatoia da tastiera: Alt+O+M

6. Disconnettervi e leggere tranquillamente tutti i messaggi. 

7. Potreste voler effettuare anche le seguenti operazioni:

• Scrivere email e messaggi Usenet di risposta.  
 Queste opzioni aprono una finestra di composizione messaggio.
 Opzione del menu: Post→Reply via Email, Post→Follow-Up Usenet Message

 Scorciatoia da tastiera: R, F

Nota! Per la massima efficienza, dopo aver composto ogni

messaggio premete il tasto Send Later  e spediteli tutti insieme
alla fine. (Vedete il punto 8.)

• Seguire un thread. 

Questa opzione aiuta a evidenziare i messaggi d’interesse. Agent
scaricherà automaticamente i corpi dei messaggi nei thread da
seguire ogni volta che recupererete nuove intestazioni da quel
gruppo.

Opzione del menu: Message→Watch Thread

Scorciatoia da tastiera:  W
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• Ignorare un thread. 

Questa opzione aiuta ed evitare i messaggi non interessanti. Tutte le
risposte nei thread da ignorare verranno automaticamente segnate
come lette.
Opzione del menu: Message→Ignore Thread
Scorciatoia da tastiera: I

• Conservare un messaggio. 

Questo comando segna i messaggi che volete conservare
indefinitamente. In questo modo non verranno cancellati durante
l’operazione di eliminazione automatica.

Opzione del menu: Message→Keep

Scorciatoia da tastiera: K

•  Archiviare un messaggio in una cartella.   Copia nella cartella o

 Sposta nella cartella (Questi pulsanti possono essere aggiunti alla barra degli
strumenti come descritto a pag. 179.)

 Opzione del menu: Message→Copy to Folder o Message→Move to Folder

Scorciatoia da tastiera: Alt+M+C+<numero file> o Alt+M+V+<numero file>

• Comporre nuove email o messaggi Usenet.   
 Queste opzioni aprono una finestra di composizione messaggio.
 Opzione del menu: Post→New Usenet Message o Post→New Email Message
 Scorciatoia da tastiera: P, Ctrl+M

8. Connettervi ed inviare i messaggi in coda.  (Questo pulsante può
essere aggiunto alla barra degli strumenti come descritto a pag. 179.)

Opzione del menu: Online→Post Usenet and Email Messages

Scorciatoia da tastiera: Alt+O+P

9. Disconnettervi.

Configurazione per attività Online ed Offline

Le impostazioni che influenzano il comportamento di Agent online ed offline
sono raccolte nella scheda Options→User and System Profile→Online.

Per maggiori
dettagli,
vedete a pag.
114.



Capitolo 3

50

Se volete lavorare soprattutto in Modo Offline, premete il pulsante Use
Offline Defaults. Questo configura le altre impostazioni della finestra di
dialogo per un tipico utilizzo offline. Se invece pensate di lavorare soprattutto
in Modo Online, premete il pulsante Use Online Defaults. Le altre
impostazioni verranno così configurate per il lavoro online.

Abbiamo posto grande attenzione a definire correttamente le impostazioni di
default, in modo che non dobbiate più preoccuparvi di alcuna di queste. In
ogni caso potete modificare ogni impostazione per adattarla alle vostre
esigenze.

Qui di seguito trovate la descrizione delle quattro opzioni chiave di questa
finestra di dialogo che regolano il comportamento di Agent online ed offline.

Nota: fate riferimento all’Help in linea di Agent per le opzioni non descritte
nella tabella.

Scegliete questa opzione... ...perché Agent faccia questo.

Go offline automatically
after...

Selezionate questa opzione se volete che Agent si
disconnetta dal news server dopo il numero di secondi di
inattività specificato. Se invece la deselezionate, Agent
non si scollegherà dal news server finché non chiuderete
il programma o lo disconnetterete manualmente
disabilitando il comando Online nel menu Online.

Se intendete leggere i messaggi online, potreste volere
che Agent vada offline dopo qualche minuto di inattività.
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Questo vi darebbe il tempo per leggere i messaggi senza
lasciare Agent online troppo a lungo.

Se pensate di leggere i messaggi offline, probabilmente
vorrete che Agent vada offline immediatamente (0 sec di
inattività).

Load Winsock on Program
Startup

Selezionate questa opzione perché Agent carichi
winsock.dll all’avvio del programma e lo lasci caricato fino
alla chiusura. Nota: Selezionate sempre questa casella
se state usando una Connessione Telefonica (DUN) o un
Server di Accesso Remoto (RAS). (Vedete le informazioni
tecniche qui sotto.)

Viewing Unretrieved
Messages When Offline

Selezionate quello che volete che Agent faccia quando
siete offline e provate a vedere un messaggio di cui non
avete recuperato il corpo. Se volete operare in Modo
Online, dovreste scegliere Go online and Retrieve the
message's body. Se volete operare in Modo Offline,
dovreste scegliere Mark the message for later retrieval .

Informazioni tecniche su “Load Winsock on Startup.”

La DLL winsock è un file di sistema che consente l’accesso alla rete ad
Agent e agli altri programmi client per internet. Ogni client che utilizzi la DLL
deve dapprima caricarla in memoria e quindi “scaricarla” al termine dell’uso.
Se più di un programma carica contemporaneamente la DLL, essa rimane in
memoria finché l’ultimo programma non la scarica.

Se avete una connessione telefonica ad internet, la DLL winsock controlla
anche quando il vostro sistema si connette e si disconnette dalla linea. La
gran parte delle DLL winsock non si connette finché un programma non tenta
di accedere ad un altro nodo della rete (per esempio, quando Agent tenta di
collegarsi al news server). In questo modo, anche se un programma carica
immediatamente all’avvio la DLL, essa non si connetterà alla linea telefonica
fino a che il programma non provi realmente ad eseguire un’operazione
online.

Il momento preciso in cui la DLL si disconnette dipende dal tipo di DLL. La
maggior parte delle DLL a 16 bit non interrompe la connessione finché
l’ultimo programma non la scarica dalla memoria. Così, anche se tutti le
operazioni online sono concluse, queste DLL manterranno il collegamento
attivo fino a che l’ultimo dei programmi non le abbia scaricate dalla memoria.
Al contrario, la DLL a 32 bit della Microsoft (utilizzata in Windows 95 e NT
per la connessione telefonica DUN) chiude la connessione non appena
l’ultima operazione online è terminata, anche se la DLL è ancora caricata in
memoria.
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La maggioranza dei programmi client carica la DLL winsock all’avvio e la
scarica solo alla chiusura. Ciò funziona bene per i programmi a 32 bit che
usano la DLL Microsoft. Come appare però chiaro dalle precedenti
spiegazioni, questo non è molto funzionale per i programmi a 16 bit, poiché
per queste DLL la condizione necessaria per interrompere il collegamento è
che tutti client vengano chiusi, scaricando così la DLL dalla memoria.

Agent, al contrario, può dinamicamente caricare e scaricare la DLL all’atto di
portarsi online ed offline. Questo fa sì che la DLL si connetta alla linea
automaticamente ogni volta che Agent va online e, soprattutto, che
interrompa la connessione quando Agent va offline.

L’opzione "load winsock on startup" controlla il momento in cui Agent
dovrebbe caricare e scaricare la DLL. Quando è selezionata, la DLL viene
caricata all’avvio del programma e mantenuta in memoria fino alla chiusura.

Quando l’opzione invece non è selezionata, Agent carica la DLL solo prima
di portarsi online e la scarica subito dopo essersi portato offline. Per le DLL a
16 bit che non interrompono il collegamento finché non vengono scaricate,
dovreste lasciare l’opzione deselezionata, in modo che, andando online ed
offline, la DLL venga caricata e scaricata dinamicamente. Potreste anche
dover deselezionare quest’opzione per certe DLL a 32 bit che operano come
quelle a 16.

Con le DLL Microsoft a 32 bit per Windows 95 Windows NT, selezionate
questa opzione, poiché non è necessario caricare e scaricare
dinamicamente la DLL per costringerlo a connettervi o disconnettervi dalla
linea telefonica.

Impostare la connessione

Come descritto qui sopra, per i sistemi a 32 bit Agent sfrutta a pieno le
caratteristiche della connessione telefonica (DUN) di Windows, rendendo
molto più comodo il portarsi online ed offline. La connessione telefonica DUN
comunica automaticamente ad Agent di collegarsi al vostro provider e di
stabilire una connessione di rete.

_____________________________________________________________

OO Parlando di connessione automatica in Windows 95 ci si riferisce alla
Connessione Telefonica (DUN), in Windows NT al Servizio di Accesso
Remoto (RAS).

_____________________________________________________________
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Grazie all’incluso supporto per DUN, Agent può automaticamente connettersi
per andare online ed automaticamente disconnettersi dopo essersi portato
offline. Questo supporto consente ad Agent di integrarsi ottimamente con la
connessione automatica di Windows 95 e Windows NT, rendendo molto più
semplice il portarsi online ed offline.

Per definire le impostazioni del DUN:

Selezionate Options→User and System Profile→Dial-Up ed apparirà la
seguente finestra di dialogo.

Completate le impostazioni della scheda Dial-Up tab come segue:

1. Open dial-up connection before going online – Se selezionate questa
opzione, Agent stabilirà la connessione specificata ogni volta che si
porterà online.

2. Prompt before connecting – Se selezionate quest’opzione, Agent,
prima di connettersi mostrerà la seguente finestra di dialogo. Se non la
selezionate si connetterà direttamente.

Nota: potreste voler selezionare quest’opzione per un motivo di
sicurezza. In questo modo, infatti, potete digitare la password ogni volta
che vi connettete, invece che farlo fare automaticamente ad Agent.
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Potete utilizzare questa finestra di dialogo per cambiare connessione,
username, password e/o numero di telefono. Se selezionate la casella
Save Password, Agent salverà la password e la immetterà
automaticamente ogni volta che vi connetterete. Per dare inizio al
collegamento premete Yes. Per non connettervi ma andare comunque
online premete No, per non connettervi e non andare online premete
Cancel.

3. If another connection is already open, use it instead – Selezionate
quest’opzione per far sì che Agent usi una connessione aperta con il
vostro server, se già ne avete una. Ciò è utile per gli utenti che
dispongono di più di un ISP. In questo modo Agent utilizzerà la
connessione già aperta piuttosto che tentare di stabilire la connessione
predefinita, che potrebbe essere diversa.

4. Connection – Selezionate dall’elenco la connessione che volete
utilizzare. L’elenco contiene tutte le connessioni DUN al momento
definite.

5. Properties – Premete questo pulsante per modificare le proprietà della
connessione selezionata. Verrà visualizzata la finestra di dialogo
standard delle proprietà della connessione DUN. (Non disponibile in
Windows NT).

6. New connection... - Premete questo pulsante per aprire la finestra di
dialogo standard della connessione telefonica DUN, nella quale potrete
introdurre una nuova connessione. (Non disponibile in Windows NT.)

7. User Name/Password – Immettete lo username e la password da
utilizzare per la connessione. Se volete che Agent vi chieda la password
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ad ogni connessione, lasciate vuoto il campo Password e selezionate la
casella Prompt before connecting.

Windows 95 – Lo username e la password di ogni connessione vengono
memorizzate separatamente nel database del DUN. Cambiando i dati
qui, cambieranno quelli del DUN.

Windows NT – Non c’è possibilità di accedere allo username e alla
password del DUN. Per questo motivo, Agent memorizza un unico
username ed un’unica password per tutte le connessioni.

8. Close dial-up connection after going offline – Se quest’opzione è
selezionata, Agent interromperà la connessione dopo essersi portato
offline, ma solo se questa era stata da lui aperta. Se Agent non aveva
aperto la connessione, Agent non la chiuderà.

9. Title of Connection Status Window – Quest’opzione è visibile soltanto
se utilizzate Windows 95 o Windows NT 3.5. Usatela se avete una
versione non inglese di 95 o NT 3.5. Quando il DUN di Windows 95 (o il
RAS di NT 3.5) completa una connessione, viene visualizzata una
finestra indicante lo stato della connessione. Quando Agent è configurato
per aprire automaticamente una connessione DUN, dopo che questa è
stata realizzata, Agent cerca la suddetta finestra e la minimizza. Per
default, Agent cerca una finestra il cui titolo inizia con "Connected to". Se
utilizzate una versione non inglese di Windows 95 o NT 3.5, potete
inserire qui il titolo corretto della finestra.

10. Start Dial-Up monitor on first connection attempt – Quest’opzione è
visibile solo se utilizzate Windows NT 4.0. In Windows NT 4.0, Agent
lancia il monitor di connessione telefonica (Dial-Up Networking Monitor)
al primo tentativo di collegamento. Agent però non chiude il monitor al
termine della connessione, nè lo riavvia nei collegamenti successivi, per
cui volendo lo dovrete chiudere manualmente. Deselezionate questa
casella se non volete che Agent lanci il monitor.





57

CAPITOLO 4

Tutto sui Messaggi
Adesso che avete iniziato ad usare regolarmente Agent, noterete subito che i messaggi dei
gruppi sottoscritti cominciano ad accumularsi. Ad un certo punto vi troverete costretti a dire:
"Come posso teneretraccia di tutti?". Le numerose opzioni di Agent aiutano a gestirli e
visualizzarli. Questo capitolo serve per mettere a fuoco problemi tipici dei messaggi ed è
suddiviso nelle seguenti aree:

1 Organizzare i Messaggi

1 Scaricare Messaggi di News

1 Scaricare Messaggi di Email

1 Filtri per i Messaggi

1 Mostrare i Messaggi

1 Trovare i Messaggi

1 Conservare i Messaggi

1 Stampare i Messaggi

Organizzare i Messaggi
A cosa somiglierebbe il nostro ufficio se non ci fossero cartelle per i
documenti? Caos è la parola che viene in mente. Come ogni buon sistema
d’archiviazione per ufficio, Agent mette a disposizione delle cartelle
elettroniche, per poter organizzare meglio i messaggi.

Archiviare i messaggi in cartelle

Organizzare i vostri messaggi in cartelle è uno dei compiti più semplici ed
intuitivi di Agent.

Per creare una cartella:

1. Selezionate Group→New Folder.

2. Digitate un nome per la cartella e premete OK.
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La nuova cartella apparirà nel pannello Groups and Folders  dopo i
newsgroup.

Per vedere le cartelle:

Dal menu Group→Show Groups and Folders  scegliete il tipo di
visualizzazione desiderato. Per le cartelle sono valide tre delle quattro scelte
possibili:

• All Groups and Folders

• Subscribed Groups and Folders

• Folders

Una segno di spunta indica la vista corrente.

Opzioni di archiviazione utilizzabili:

• Il metodo "drag and drop". [Trascinamento]

• Uso del menu Copy to Folder o Move to Folder.

• Impostare Agent per archiviare automaticamente le email in arrivo.

Nota: Non si possono archiviare messaggi senza corpo.

Per trascinare un messaggio in una cartella:

1. Visualizzate tutti e tre i pannelli nella schermata principale (controllate
cioè che l’opzione Navigate→Zoom Window non sia selezionata).

2. Evidenziate il messaggio nel pannello Message List. Potete selezionare
più messaggi, trascinandoli contemporaneamente.

3. Fate clic in un punto qualsiasi del messaggio evidenziato e trascinate il
messaggio nella cartella scelta, tenendo schiacciato il tasto del mouse.

Nota: Agent per default sposterà il messaggio quando lo trascinate. Se
volete invece copiarlo, premete e tenete premuto CTRL. Vedrete nella
cartella, mentre lo trascinate, un segno "+", segno che indica che state
copiando e non spostando.

4. Quando il cursore è proprio sopra la cartella scelta, rilasciate il pulsante
del mouse ed il messaggio sarà inserito in quella cartella.

Per copiare o spostare un messaggio in una cartella:

vedi " Archiviare
automaticamente
la posta in arrivo "
a pag. 70
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Evidenziate il messaggio (o i messaggi) da archiviare e, per aprire i
sottomenu Copy to Folder o Move to Folder, scegliete uno di questi modi
equivalenti:

Opzioni del menu: Selezionate Message→Copy to Folder o
Message→Move to Folder -> <nome della cartella>.

Menu contestuale: Per aprire il menu, fate clic destro sull’intestazione o
sul corpo del messaggio e selezionate Copy to
Folder or Move to Folder -> <nome della cartella >.

Scorciatoia da tastiera: Alt+M+C apre il sottomenu Copy to Folder.
Alt+M+V apre il sottomenu Move to Folder.

Se non vedete la cartella di destinazione voluta, potete selezionate All
Folders nella parte bassa del sottomenu. Così facendo, viene mostrata una
finestra di dialogo che elenca le vostre cartelle.

Per aggiungere una di queste cartelle al sottomenu, premete il pulsante Manage
Menu. Verrà mostrata la finestra di dialogo Manage Folder Menus , dove potrete
aggiungere la cartella dall’elenco Folders  all’elenco Menu (per aiuto premete il
pulsante Help). Premendo OK, quella cartella sarà aggiunta ai sottomenu Copy
to Folder e Move to Folder. Si possono aggiungere al sottomenu fino a 9 cartelle.
Se vi trovate a spostare frequentemente messaggi nella stessa cartella, potete
aggiungere un pulsante alla barra degli strumenti o copiare il messaggio
evidenziato a quella cartella usando un singolo tasto (vedi pag 179.)
____________________________________________________________

Per dettagli
su come
creare
pulsanti
sulla barra
degli
stumenti,
vedi pag.
179
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OO In alternativa, per aggiungere le cartelle usate con più frequenza al
sottomenu Copy to Folder e Move to Folder, selezionate
Options→Menus and Toolbars→Folder Menus. Notate che il
Folder Menus coincide con il Manage Folder Menus.

_____________________________________________________________

Archiviare i messaggi

Con Agent, oltre che conservare messaggi in cartelle, potete salvare
messaggi su disco e conservarli come parte del sistema di archiviazione di
Windows.

Per salvare uno o più messaggi come file di testo:

Evidenziate i messaggi che volete salvare nel pannello Message List e
selezionate File→ Save Messages As (o premete Alt+F+A): in questo modo
verrà mostrata la finestra di dialogo Save Messages As.

___________________________________________________________
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OO Agent salva soltanto i messaggi il cui corpo è già stato scaricato. Se
selezionate un thread non espanso, Agent salva tutti i messaggi nel
thread.

_____________________________________________________________

Questa finestra di dialogo ha gli stessi campi di una comune finestra di
dialogo “salva con nome”, eccettuate le opzioni che seguono, uniche per
Agent:

1. Append to existing file – Selezionate questa casella per aggiungere i
messaggi da salvare ad un file esistente, già salvato. Se voi non
selezionate questa opzione e salvate i messaggi con lo stesso nome di
file esistente, Agent cancellerà il contenuto preesistente del file.

2. Save raw (unformatted) message – Selezionate la casella se volete
salvare solo il messaggio grezzo (senza formattazione). Ciò significa che
salverete i dettagli dell’header (cioè Path, From, Subject, Date,  ecc.) ed il
testo del messaggio. Inoltre ogni allegato al messaggio verrà salvato
come una serie di linee di caratteri codificati.

3. File Format - Selezionate la formattazione dei messaggi da salvare; qui
di seguito le opzioni:

Scegliete questa
opzione...

e Agent….

Unix message file salva i messaggi nel formato standard Unix. Ciò permette
di reimportare in Agent i messaggi

Precede each
message with...

Aggiunge il testo specificato all’inizio di ogni messaggio
salvato.

No separator
between message

non inserisce alcun testo addizionale tra i messaggi
salvati

4. Header Fields to Include - Selezionate i campi del messaggio che
volete siano inclusi nel file salvato. Qui di seguito le opzioni:

Scegliete questa
opzione...

e Agent….
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All fields salva tutte le informazioni dell’header assieme al corpo del
messaggio.

Selected fields salva solo gli elementi dell’header selezionati (ad esempio
To, From, Newsgroups, Subject, Date, ecc.) insieme al
corpo del messaggio. Potete inserire tutti i campi che
volete.

No fields (Body only) salva solo il corpo dei messaggi senza alcuna informazione
sugli header.

_____________________________________________________________

OO Se volete reimportare dei messaggi in Agent, assicuratevi di usare
queste tre opzioni nell’esportazione: Save raw message; Unix
message file; All fields.

_____________________________________________________________

Scaricare Messaggi News
Nel Capitolo 2 avete imparato a scaricare un campione dei messaggi di un
dato gruppo per vedere quali gruppi vi interessassero. Questa sezione vi
darà altri dettagli sul recupero di messaggi news e spiegherà alcuni comandi
che vi fornisce Agent per gestire la vostra lista di messaggi.

Scaricare gli Header dei messaggi nei Newsgroup

Il menu Online e la barra degli strumenti offrono le opzioni seguenti per scaricare gli
header dei messaggi.

• Get New Headers in Subscribed Groups

• Get New Headers in Selected Groups

• Get All Headers in Selected Group

• Sample Headers From Selected Groups

Scegliete ciò che vi soddisfa, come segue:

Get New Headers in Subscribed Groups recupera i nuovi header nei
gruppi sottoscritti, ossia gli header che non erano ancora disponibili l’ultima
volta che avete effettuato la stessa operazione in quegli stessi gruppi.

Per aggiungere
pulsanti alla
barra degli
strumenti vedi
pag. 179.
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Get New Headers in Selected Groups recupera i nuovi header nei gruppi
selezionati, ossia gli header che non erano ancora disponibili l’ultima volta
che avete effettuato la stessa operazione in quegli stessi gruppi.

Get All Headers in Selected Groups recupera tutti gli header dai gruppi
selezionati, inclusi header eliminati nelle precedenti sessioni.

Sample Headers From Selected Groups - Agent recupera, nel gruppo
selezionato, un numero limitato degli header più recenti. Potete scegliere tra
un numero specificato di header [Maximum number of messages to retrieve]
ed un numero specificato di giorni [Number of days to retrieve].

Nota: quando usate l’opzione "sample headers” recuperate gli header più
recenti e quindi, dopo aver scaricato un campione, nessun nuovo header
sarà recuperato né con Online→Get New Headers in Subscribed Groups né
con Online→Get New Headers in Selected Groups.

Se volete scaricare messaggi antecedenti a quelli campionati, dovete
ingrandire l’estensione del campione e ripetere l’operazione, oppure usare
l’opzione Online→Get All Headers in Selected Groups .

Scaricare i corpi dei messaggi

Agent dispone di parecchi metodi per scaricare i corpi dei messaggi che vi
interessano. Due di questi sono disponibili dal menu Online o dalla barra
degli strumenti.

• Get Selected Message Bodies 

• Get Marked Message Bodies 

Ecco come funzionano:

Get Selected Message Bodies recupera il corpo di uno o più messaggi che
avete selezionato nel pannello Message List.

Get Marked Message Bodies scarica i corpi dei messaggi che avete
marcato per il recupero. Ciò è particolarmente utile usando Agent in modalità
offline. Un esempio di sessione in modalità offline si trova al capitolo 3.

Potete inoltre scaricare i corpi di tutti i nuovi messaggi quando recuperate gli
header. Usate Group→Properties→Retrieve e selezionate la casella Retrieve
bodies for all new messages.
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Il “Catching Up” nei gruppi

Se non avete usato Agent per parecchio tempo e volete leggere i messaggi
correnti senza preoccuparvi di leggere i messaggi inviati in vostra assenza,
l’opzione “catch up” di Agent fa per voi. Agent mostrerà che avete scaricato
tutti i messaggi nel gruppo selezionato fino al momento di “catch up”, anche
se non avete scaricato o letto alcuno di questi messaggi.

Per fare il catch up con i messaggi di un gruppo:

Selezionate Online→Catch Up With Selected Groups . Questa opzione
chiede al server di trovare il numero di messaggio più alto, ma non scarica
alcun header. Così la volta successiva che prenderete nuovi header
riceverete solo messaggi spediti dopo che avete fatto il catch up.
_____________________________________________________________

OO Potete anche fare il catch up campionando un numero limitato degli
ultimi messaggi. (Selezionate Online→Sample Headers .)

_____________________________________________________________

Seguire i Thread

Alcuni thread di discussione possono essere molto interessanti e volete
essere sicuri che Agent ne scarichi sempre i testi degli ultimi messaggi.
Potete farlo con l’opzione Watch Threads.
Per seguire i thread:

Ponete il cursore sul thread che volete seguire e usate uno dei sistemi
equivalenti che seguono:

Pulsante della barra degli strumenti :
Opzione da Menu: Message→Watch Thread

Scorciatoia da tastiera: W

L’icona Watch Thread  precederà il messaggio e ogni relativa risposta.
Quando scaricherete nuovi header, Agent automaticamente scaricherà i testi
di tutte le risposte al thread da seguire.

Ignorare i Thread

L’opzione Ignore Thread ha l’effetto opposto di Watch Thread. Per ogni
thread che non volete seguire potete usare "Ignore Thread" per dire ad
Agent di non scaricare mai nuovi messaggi per il thread selezionato. Ciò
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ridurrà il numero di nuovi messaggi non letti presentati ogni volta che
ricevete nuovi header di messaggi.

Per ignorare i thread:

Ponete il cursore sul thread che volete ignorare e usate uno dei sistemi
equivalenti che seguono:

Pulsante della barra degli strumenti :
Opzione da Menu: Message→Ignore Thread

Scorciatoia da tastiera: I

L’icona Ignore Thread  precederà allora quel messaggio e ogni relativa
risposta. Quando scaricherete nuovi header, Agent automaticamente
considererà come letti questi messaggi, anche quelli scaricati in sessioni
successive.

Importante! Accertatevi di tenere almeno un header nei thread seguiti o
ignorati perché la funzione resti attiva. In alternativa, accertatevi di aver
posto le proprietà per l’eliminazione dei vecchi messaggi [purge] nelle
schede Group→Properties→What to Purge e When to Purge in modo che
questo header rimanga fintanto che il thread è attivo.

Gestire il Crosspost
Molti fanatici di Usenet inviano lo stesso messaggio a numerosi newsgroup.
Questo uso, noto come "crosspost", è vantaggioso per chi invia, in quanto
con il crosspost si raggiunge una audience maggiore rispetto all’invio ad un
singolo gruppo. Per chi riceve, invece, il crosspost può essere fastidioso.
Scaricando i nuovi header, vi potete ritrovare a leggere lo stesso messaggio
in parecchi gruppi sottoscritti. Per fortuna con Agent potete gestire il
crosspost ed evitare il problema.

Per gestire Messaggi in crosspost:
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Aprite la scheda Group→Properties→Crossposts.

In questa scheda potete abilitare il controllo del crosspost (enable crosspost
checking) e scegliere l’opzione migliore per mettere a punto il funzionamento
di Agent. Seguono le descrizioni delle opzioni:

• Enable crosspost checking – Selezionate questa casella per attivare il
controllo del crosspost in Agent. Ciò viene applicato a tutti i gruppi.

• If a message header has already been retrieved in one group... [se
l’header di un messaggio è già stato scaricato in un gruppo…]

Retrieve the header normally [scarica normalmente l’header] –Disabilita il
controllo di crosspost in modo globale, ma Agent continuerà a mantenere
una lista di header utilizzati per poter effettuare il controllo.

Mark the header read [Marca l’header come letto] - Agent marca come
letto in tutti i gruppi l’header del messaggio in crosspost, tranne che nel
primo, dove viene invece scaricato.

Skip the header (do not retrieve it) [salta l’header (non scaricarlo)]- Agent
salta il messaggio in tutti i gruppi, tranne che nel primo, dove è scaricato.
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Esempio:

Se...

scaricate gli header nei gruppi a,b,c,d,e, e un messaggio è stato inviato
ai gruppi b,d,e...

allora...

Agent scaricherà l’header nel solo gruppo b, perché questo è il primo nel
quale sarebbe stato scaricato

• Look for crossposted messages only when retrieving NEW headers
[Cerca i messaggi in crosspost solo quando scarichi NUOVI header]
Selezionando questa casella, Agent controlla il crosspost solo per i nuovi
header. Se non è selezionata, Agent controlla il crosspost ogniqualvolta
scaricate header, come nel prelevare un campione dei messaggi [sample
header] o nello scaricarli tutti.

• Detect crossposted messages by – Questa opzione gestisce i criteri
usati da Agent per controllare i messaggi in crosspost in tutti i gruppi. Le
due scelte sono Subject, author, date, and lines oppure Message ID. In
generale la prima permette un miglior rilevamento.

• Clear cache used to detect crossposted messages - Fai clic sul
pulsante per rimuovere la lista degli header più recenti. Agent conserva
questa lista come base per il rilevamento del crosspost. (Questi dati sono
nel file xpost.dat situato nella cartella agent\data.)

Scaricare Messaggi Email
In un capitolo precedente avete imparato le basi per controllare la presenza
di email durante una sessione tipica di Agent. Questa sezione fornirà dettagli
su come ottimizzare Agent per usarlo come programma di posta elettronica.

Controllo della posta

Usate la scheda Options→Inbound Email→Checking Mail per disporre le
vostre preferenze nel controllo della posta.
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Opzioni Receiving Email with POP: Queste opzioni si applicano solo ai
POP server. Esse indicano ad Agent quando verificare la presenza di posta
o cosa fare dei messaggi che trova. La seguente tabella descrive il risultato
per ciascuna opzione:

Selezionate questa opzione... …e Agent….

Automatically check for
email every...

controlla la presenza di posta periodicamente,
in automatico. Specificate quanti minuti
debbono passare tra un controllo e l’altro.

Nota: Agent deve essere attivo per controllare
la posta

Check only when online Controlla la presenza di posta solo se siete
già in linea con il vostro provider.

Selezionate questa opzione... …e Agent….



Tutto sui messaggi

69

Unload winsock (hang
up) between checks

Oppure

Leave winsock loaded
between checks

Molti driver winsock disconnettono
automaticamente il modem quando nessun
programma usa più il modem. Se il vostro
driver winsock agisce così, potete usare la
prima opzione per far sì che Agent disattivi il
driver winsock fra un controllo della posta ed
un altro, provocando quindi la disconnessione
del modem, oppure la seconda per far si che il
driver resti attivo e il modem connesso.

Leave messages on
server

Nota: Questa opzione è utile
quando scaricate messaggi
con più postazioni dallo stesso
account per email.

Vedi pag. 93 per ottimizzare
Agent nell’uso di due
postazioni.

Lascia in deposito i messaggi sul server dopo
averli scaricati. In genere Agent li cancella
dopo il recupero.

Nota: una volta che il messaggio è stato
scaricato e lasciato sul server, Agent non lo
scarica nuovamente. Se quindi disattivate la
casella, la volta successiva che controllerete la
posta Agent cancellerà dal server tutti i vecchi
messaggi.

Until retrieved at both of
my sites

L’opzione è disabilitata a meno che abbiate
selezionato l’opzione "Leave messages on
server", descritta sopra. Selezionate questa
casella se scaricate messaggi in due
postazioni differenti e volete che Agent li lasci
sul server finché non li avete scaricati in
entrambe le postazioni.

If a message has already
been retrieved, mark it
read

Questa opzione aiuta chi scarica i messaggi in
due postazioni differenti. Quando selezionate
questa casella, se il server indica che un
messaggio è già stato scaricato
(presumibilmente nell’altro vostro sito), Agent
marcherà il messaggio come già letto.

Skip message longer
than

Maximum lines to sample

Non scarica i messaggi più lunghi del massimo
numero di linee specificato.
Se Agent incontra un messaggio più lungo del
valore specificato, scaricherà il numero di linee
specificato in “Maximum lines to sample”.

Se questa casella è selezionata, Agent lascerà
il messaggio dal server e non lo scaricherà di
nuovo. Deselezionate la casella per far sì che
Agent lo scarichi la volta successiva.
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Quando arriva nuova posta

Usa la scheda Options→Inbound Email→Alerts per dire ad Agent come
avvertirti dell’arrivo di nuove email.

Selezionate questa opzione... …e Agent….

Display messaggio box Fa comparire un messaggio quando arriva
nuova posta

Play sound Produce un suono quando si riceve una nuova
email. Se il vostro computer è predisposto a
suonare file .wav potete specificare quale
suonare. Se selezionate Play sound ma lasciate
vuoto WAV file, Agent suonerà il suono Email
Receive definito nel modulo Suoni del vostro
Pannello di Controllo.

Only if new Messages were
marked unread

Selezionate questa casella se volete che Agent
faccia bip o suoni il file WAV specificato solo se
i nuovi messaggi scaricati sono marcati come
non letti. Questo è utile se avete creato un filtro
che marchi come letti alcuni messaggi quando
sono scaricati. In tali casi potete non volere che
Agent faccia bip o suoni un file WAW per
avvertirvi della nuova posta.

Quando ricevete posta, la barra di stato mostra il numero dei messaggi non
letti, di quelli marcati letti, di quelli cancellati. Agent mostrerà i risultati del
controllo email più recente così come il totale accumulato da quando avete
letto l’ultima email marcata come non letta. A che vi interessa conoscere il
totale? Se volete che Agent scarichi automaticamente la posta ogni <n>
minuti, potreste non controllare la posta per parecchi cicli. Il totale considera
tutta la posta ricevuta dall’ultima volta che l’avete letta. Il totale verrà
riazzerato la prima volta che leggerete un messaggio email non letto.

.Ogni volta che ricevete un’email, l’icona di programma di Agent cambia per
segnalarvelo,. Tuttavia Agent non mostrerà questa icona con l’indicazione di
nuova posta se nessuna nuova email è marcata come non letta, cioè se tutta
la posta scaricata è marcata letta o cancellata

Archiviare automaticamente la posta in arrivo

Durante la prima configurazione per ricevere email, avete definito una
cartella dove le email sarebbero state automaticamente archiviate. Come
riceverete più lettere, vorrete creare più cartelle e far si che Agent metta i



Tutto sui messaggi

71

messaggi nella cartella più appropriata. La prossima sezione mostrerà come
farlo usando la possibilità, semplice ma potente, del filtraggio.

Per default, la posta non indirizzata da un filtro viene archiviata nella cartella
che avete creato durante la prima configurazione della posta. Se volete
cambiarla, usate la scheda Options→Inbound Email→Folder e selezionate
una cartella esistente dalla lista o createne una nuova facendo clic sul
pulsante New Folder.

Filtri per i Messaggi
Agent fornisce un insieme potente e flessibile di strumenti per consentirvi di
ricevere solo i messaggi che desiderate, liberandovi dal fastidio dei messaggi
indesiderati, pur ricevendo tutti i dettagli di quelli di vostro interesse.
L’impiego di filtri per gli articoli nei newsgroup può essere estremamente
importante se scaricate regolarmente gli header da gruppi molto attivi, alcuni
dei quali possono generare centinaia di messaggi al giorno. Senza un
sistema di filtri così ampio, la vostra lista dei messaggi potrebbe diventare
rapidamente ingestibile. Analogamente, l’uso di filtri per i messaggi email vi
permette di evitare le email pubblicitarie indesiderate (“spam”), mentre
scaricate e ordinate automaticamente i messaggi che invece volete leggere.

Creare un filtro per i messaggi

I filtri per i messaggi Usenet ed email consistono dei seguenti componenti:

• Un’espressione di filtro, che specifica i criteri che Agent dovrà usare
quando filtra i messaggi. Per gli utenti meno esigenti, Agent fornirà
automaticamente le espressioni quando si creano filtri basati su
messaggi esistenti. Per gli utenti più esperti, l’expression language di
Agent è potente e versatile e garantisce un pieno controllo nella
definizione dei criteri di filtro.

• Una delle varie azioni disponibili di “Kill” (non mostrare il messaggio) o
“Watch” (mostrarlo).

• Una priorità compresa tra 0 (minima) e 1000 (massima). I filtri sono
valutati in ordine di priorità. Se un messaggio rientra nei criteri di più filtri,
essi vengono valutati in ordine di priorità e viene eseguita l’azione del
filtro a priorità più alta.

• Una data di scadenza (opzionale), espressa come numero di giorni di
durata del filtro. Agent elimina automaticamente i filtri scaduti, aiutandovi
a gestirli tenendone sotto controllo la quantità e l’efficacia.
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• Un selettore abilita/disabilita. Questo consente di disabilitare
temporaneamente un filtro senza cancellarlo. Si può anche impiegare
l’opzione Filters nella finestra di dialogo Group Properties per disabilitare
temporaneamente tutti i filtri per i gruppi selezionati.

Si possono impostare filtri a partire da messaggi preesistenti o anche crearli
ex novo.

Come creare un filtro basato su un messaggio:

1. Selezionate il messaggio di news o email che sarà la base del filtro.

2. Aprite il menu a tendina Message -> Filters

3. Selezionate “Add Kill Filter ...” o “Add Watch Filter ...”, a seconda del tipo
di filtro che desiderate creare.

4. Completate le impostazioni nella finestra di dialogo Add Filter (vedi la
sezione successiva). Notate che Agent riconosce se si sta creando un
filtro a partire da un messaggio Usenet o da una email, quindi apre la
relativa finestra di dialogo.

Come creare un filtro partendo da zero:

1. Se il filtro deve essere applicato ad un gruppo specifico, controllate che
quel gruppo sia evidenziato.

2. Selezionate Window→Open Email Filters o Window→Open Usenet
Filters.

3. Aprite la finestra di dialogo Add Filter in uno dei seguenti modi, tutti
equivalenti:

Pulsanti della barra degli strumenti:

 per kill filters o  per watch filters.

Opzioni dei Menu: Filter→Add Kill Filter or Filter→Add Watch Filter

Scorciatoia da tastiera: Ctrl+K per kill filters o Ctrl+W per watch filters.

4. Completate le impostazioni nella finestra di dialogo Add Filter (vedi
sezione successiva).

La finestra di dialogo Add Filter

A seconda del tipo di filtro che si vuole creare (Usenet o email), si apriranno
le relative finestre di dialogo. Va notato che queste sono piuttosto simili, ma
presentano alcune importanti differenze. Vediamo i dettagli dei due tipi.
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La finestra di dialogo Add Usenet Filter

Se si sta creando un kill filter, apparirà l’impostazione predefinita nella
sezione Kill Action. Nell’esempio qui sopra, è riportata l’impostazione
predefinita nella sezione Watch Action. In pratica, quando si definiscono i
filtri, la sola differenza tra un watch ed un kill filter è data dall’aspetto iniziale
delle opzioni della finestra di dialogo. Si può incominciare con il creare un
watch filter e poi mutarlo in un kill filter e viceversa.

Nota: per definire le impostazioni di default per watch e kill filters in Usenet,
si impiega l’opzione Group→Properties→Filters .

Vediamo le opzioni di questa finestra di dialogo:

1. Filter Expression – Inserire l’espressione che dice ad Agent cosa
cercare per decidere se un messaggio rientra nei criteri del filtro. Se si
crea un filtro da un messaggio news preesistente, Agent inserisce
automaticamente il subject del messaggio prescelto (per uno watch filter)
o l’autore (per un kill filter). Se si vuole cambiare la filter expression, si
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può sia immettere manualmente il subject o l’autore in base al quale si
desidera filtrare, sia impiegare i seguenti pulsanti affinché Agent
inserisca automaticamente il subject o l’autore del messaggio
selezionato.

a. Paste Subject – premere questo pulsante per inserire il subject del
messaggio selezionato.

b. Paste Author – premere questo pulsante per creare un filtro basato
sull’autore. Sotto questo pulsante c’è una lista dalla quale si può
scegliere esattamente come verrà inserita l’informazione relativa
all’autore. Le opzioni possibili sono:

• Name only (per esempio author: John Smith)
• Address only, (per esempio: author: jsmith@anyco.com)
• Entire field (per esempio: author: jsmith@anyco.com John

Smith)

Nota: i pulsanti Paste Subject e Paste Author sono attivi solamente
se si crea un filtro da un messaggio selezionato. Se si costruisce un
filtro dal nulla, questi pulsanti non appariranno. Vedere la sezione
“Filter Expressions”, in questo capitolo, per maggiori dettagli sulla
creazione di espressioni corrette.

c. Lower Case – premere questo pulsante per convertire in carattere
minuscolo tutto il testo nel campo Search For. Questo garantisce che
Agent filtrerà ad ogni occorrenza del subject o dell’author in modo
case-insensitive, cioè indipendentemente dal fatto che gli headers
presentino caratteri maiuscoli, minuscoli o misti.

2. Kill action – Scegliere la Kill action di default per i filtri. Le opzioni sono:

a. Delete - Agent non scaricherà affatto l’header.

b. Mark read - Agent scaricherà header, ma lo marcherà come già letto.

c. Ignore thread - Agent scaricherà l’header, ma marcherà il thread
come Ignore  ed il messaggio come già letto.

3. Watch action – Scegliere la Watch action di default per i filtri. Le opzioni
sono:

a. Retrieve body immediately - Agent scaricherà immediatamente il
corpo del messaggio .

b. Mark for later retrieval – Agent segnerà il messaggio per scaricarlo in
seguito .
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c. Watch thread - Agent terrà d’occhio  tutto il thread e segnerà il
messaggio per scaricarlo successivamente.

4. Keep – Selezionare questa opzione se si vuole che Agent conservi
permanentemente (keep)  tutti i messaggi scaricati quando l’azione di
filtro è diversa da delete.

5. Scope - Selezionare Global se si vuole applicare il filtro a tutti i gruppi, o
scegliere Group: <newsgroup> se si vuole che il filtro si applichi al solo
gruppo selezionato.

6. Priority – Inserire la priorità del filtro, tra 0 (minima) e 1000 (massima).
Se un messaggio rientra nei criteri di più filtri, verrà applicato quello con
la priorità maggiore.

7. Disable filter – Selezionare questa opzione per disabilitare
temporaneamente il filtro.

8. Expire this filter after – Selezionare questa opzione se si vuole che il
filtro sia automaticamente cancellato dopo un certo numero di giorni dalla
sua creazione (inserire il numero) o dall’ultima volta in cui è stato usato
(inserire il numero di giorni e selezionare l’opzione Of Inactivity)

9. Apply filters to group immediately – Selezionare questa opzione per
applicare tutti i filtri al gruppo indicato, non appena si chiude la finestra di
dialogo. Scegliere “This message only” per restringere al messaggio
corrente l’applicazione del filtro. (Questa opzione compare solo se si sta
creando il filtro a partire da un messaggio preesistente)
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La finestra di dialogo Add Email Filter

Come abbiamo già visto, questa finestra è molto simile a quella “Add Usenet
Filter”. Comunque, potete usare questa finestra di dialogo per far sì che
Agent inserisca automaticamente i messaggi email nei folder appropriati e li
rimuova dal server POP.

Nota: per definire le impostazioni di default per filtri watch e kill sulla email,
usate le opzioni Options→Inbound Email→Watch and Options→Inbound
Email→Kill.

Vediamo le opzioni per l’uso di questa finestra di dialogo:

1. Filter Expression – Immettere l’espressione che dice ad Agent che cosa
cercare per stabilire se un messaggio rientra nel filtro. Se si sta creando
un filtro a partire da un messaggio email preesistente, Agent inserisce il
campo Any-Sender [ogni mittente] seguito dall’autore del messaggio
selezionato. Nota: si può inserire qualunque nome di campo, come pure i
termini speciali "any-sender" e "any-recipient". Se si vuole modificare la
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filter expression, si può digitare il cambiamento (vedere la sezione
“L'Expression Language di Agent”, a pag. 79 per i dettagli), oppure si
possono impiegare i seguenti pulsanti affinché Agent inserisca
automaticamente il campo desiderato, nel formato adatto, dal messaggio
corrente.

a. Paste Field – Premere questo pulsante per aprire la finestra di
dialogo Paste Field. Da questa, selezionare il campo che si vuole
incollare nel box “Filter Expression”.

Nota: il pulsante Paste Field è attivo solo se si crea un filtro a partire
da un messaggio selezionato. Se lo si crea ex novo, il pulsante non
comparirà. Vedere la sezione “Filter Expressions”, in questo capitolo,
per dettagli sulla creazione di filter expressions corrette.

b. Lower Case – premere questo pulsante per convertire in carattere
minuscolo tutto il testo nel campo Search For . Questo garantisce
che Agent filtrerà ogni occorrenza del subject o dell’author in modo
case-insensitive, cioè indipendentemente dal fatto che gli headers
presentino caratteri maiuscoli, minuscoli o misti

c. Kill action – scegliere la Kill action di default per i filtri. Le opzioni
sono:

a. Delete – Agent cancellerà il messaggio, senza inserirlo in una
cartella.

b. Mark read - Agent inserirà il messaggio nel folder specificato,
segnandolo come già letto.

c. Ignore thread - Agent inserisce il messaggio nella cartella
specificata, segna come Ignore  il suo thread e marca il
messaggio come già letto.

3. Watch action – Selezionare la Watch action di default per i filtri. Le
opzioni sono:

a. Retrieve – Agent scaricherà il messaggio, lo inserirà nel folder
specificato e lo marcherà come non letto.

b. Watch thread - Agent inserirà il messaggio nella cartella specificata,
terrà d’occhio  tutto il thread e marcherà il messaggio come non
letto.
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4. Keep -. Selezionare questa opzione se si vuole che Agent conservi
permanentemente (keep)  tutti i messaggi scaricati quando la filter
action è diversa da delete.

5. File in Folder – Scegliere il folder in cui si vogliono archiviare i messaggi
che rientrano in questo filtro. Se non si intende usare una cartella già
esistente, ma crearne una nuova, cliccare su New Folder.

6. Do not leave on server – Se è stata selezionata l’opzione globale Leave
on server nella scheda Checking Mail della finestra di dialogo Inbound
Email (menu Options), selezionando questa casella si può far eccezione
all’opzione globale per quanto riguarda il filtro che si sta creando. Questo
è utile per particolari messaggi che si vogliono sempre rimuovere dal
server e anche per chi riceve email in due postazioni, ad esempio a casa
e sul lavoro.

7. Priority - Inserire la priorità del filtro, tra 0 (minima) e 1000 (massima).
Se un messaggio rientra nei criteri di più filtri, verrà applicato quello con
la priorità maggiore.

8. Disable filter - Selezionare questa opzione per disabilitare
temporaneamente il filtro.

9. Expire this filter after - Selezionare questa opzione se si vuole che il
filtro sia automaticamente cancellato dopo un certo numero di giorni dalla
sua creazione (inserire il numero) o dall’ultima volta in cui è stato usato
(inserire il numero di giorni e selezionare l’opzione Of Inactivity

10. Apply filters to folder immediately – Selezionare questa opzione per
applicare tutti i filtri al gruppo indicato, non appena si chiude la finestra di
dialogo. Scegliere “This message only” per restringere al messaggio
corrente l’applicazione del filtro. (Questa opzione compare solo se si sta
creando il filtro a partire da un messaggio preesistente)

Gestire la lista dei filtri

Quando si incomincia a creare filtri per i messaggi news ed email, con ogni
probabilità si vorranno rivedere i filtri che si sono impostati, forse si vorranno
modificare o cancellare, se non sono stati impostati per avere una
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cancellazione automatica. Queste azioni si possono svolgere dalle finestre
Usenet Filters ed Email Filters.

Per vedere i filtri esistenti:

1. Selezionare Window→Open Usenet Filters or Window→Open Email
Filters.

2. Scegliere il modo in cui si vogliono vedere i filtri. Per fare questo, aprire
la finestra di dialogo Select View, che può essere aperta scegliendo
Filter→Select View o cliccando la barra del titolo della finestra. Notare
che i criteri correnti per la visualizzazione sono mostrati nella header bar.

Aggiungere, cambiare o modificare i filtri:

Dalle finestre Usenet Filter o Email Filter sono disponibili le seguenti opzioni,
dal menu Filter o da un pulsante sulla barra degli strumenti.

Add a New Filter – per creare a mano, da zero, un nuovo filtro, come detto a
pagina 68.

Add a Copy of a Filter - apparirà la finestra di dialogo Add Filter da cui si
potranno effettuare variazioni ad un filtro esistete e salvarle come un filtro
nuovo.

Edit a Filter – apparirà la finestra di dialogo Edit Filter, dove si potranno
svolgere i cambiamenti desiderati, per poi salvare il filtro con le modifiche.

Delete a Filter – per cancellare un filtro. Selezionare Filter→Confirm Deletes
farà sì che Agent chieda conferma quando si cerca di cancellare un filtro.

L’Expression Language di Agent

Quando si creano filtri per Usenet ed email, o quando si esegue una Global
Search, è possibile impiegare l’expression language di Agent per specificare
i criteri di ricerca e riconoscimento. Molte volte sarà sufficiente l’uso dei
comodi pulsanti “Paste ...” sulle finestre di dialogo Filter o Global Search. In
altri casi, però, si potrà definire un’espressione molto specifica in modo che
Agent sappia precisamente che cosa si sta cercando.

Nota: Forse vorrete passare alla sezione Esempi di Filtri Usenet (p. 84) o
Altri Esempi di Filtri (p. 92), per vedere che cosa si può fare con l’expression
language di Agent. Poi potrete tornare a questa sezione per maggiori dettagli
sulla costruzione di filtri ed espressioni di ricerca.

Le expression consistono delle seguenti componenti:
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• Uno o più termini (combinazioni di parole in base alle quali eseguire il
filtro o la ricerca)

• Operatori opzionali (parole con significato speciale impiegate per
combinare i termini)

• Qualificatori opzionali (simboli usati per limitare la portata di filtri e
ricerche)

L’expression language di Agent è versatile. Si possono creare espressioni
“word-based” (per avere le massime prestazioni), ma si possono anche
usare le "regular expression" (una forma di espressione più sofisticata,
sviluppata dagli utenti UNIX), meno dirette ma assai più potenti

Parole, frasi e Case sensitivity (sensibilità alle maiuscole/minuscole)

L’espressione più semplice è una singola parola. Si possono combinare più
parole per costruire frasi. Inoltre, si possono impiegare operatori logici quali
AND e OR per combinare le frasi in espressioni booleane complesse.
Controllando una frase, Agent ignora tutti gli spazi e la punteggiatura sia
nell’espressione di filtro sia nel messaggio che sta verificando. La
punteggiatura e gli spazi sono trattati come spazi singoli. Quindi, le seguenti
espressioni risultano identiche:

Mark F. Sidell <m.sidell@forteinc.com>

Mark F Sidell m sidell forteinc com

Mark-F-Sidell-m-sidell-forteinc-com

Quando le parole nella filter expression sono scritte tutte in caratteri
minuscoli, il controllo è non differenzia minuscole e maiuscole. E’ però
possibile avere un controllo preciso, case-sensitive, inserendo una o più
maiuscole. Per esempio:

subject: shell

riporterà shell, Shell, sHell, or ShELl presenti nei subject.

Per realizzare un controllo case-sensitive, impiegare una o più maiuscole,
come:

subject: Shell

Questo riporterà solamente Shell.

Operatori nelle Espressioni

I tre operatori impiegati per combinare i termini di un’espressione sono “and”,
“or” e “not”, che hanno i seguenti significati speciali:
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and Agent deve trovare tutte le frasi separate da “and” per rientrare nei
criteri dell’espressione. Al posto di “and” si può usare il carattere &. Ad
esempio:

 subject: green apples and oranges

corrisponde ai subject che contengono sia la frase "green apples" sia
la parola "oranges.

or Agent deve trovare almeno una delle parole separate da “or” per
rientrare nei criteri dell’espressione. Si può equivalentemente
impiegare il carattere “|”. Ad esempio:

subject: apples or juicy oranges

corrisponde ai subject che contengono la parola "apples" oppure la
frase "juicy oranges”.

not Agent non deve trovare alcuna delle frasi o parole specificate. (Il
carattere “!” può essere usato invece di “or”). Per esempio,
l’espressione

 subject: apple and not pies

trova tutti i subject che contengono la parola apple, ma non
contengono la parola pies.

Si può far sì che Agent tratti gli operatori logici come testo normale ponendoli
tra virgolette ("and", "or", "not"). Ciò risulta utile quando, ad esempio, la
parola “and” è parte integrante del subject in un filtro che si sta creando. Se
ad esempio vogliamo che il filtro sia relativo alla frase “this and (that)”, si può
impiegare una delle seguenti espressioni:

this "and" that

"this and (that)"

this "and" "(" that ")"

Nota: Quando si impiega uno dei pulsanti Paste Field, vengono
automaticamente messe le virgolette intorno a quegli operatori che fanno
parte del campo selezionato.

Se più operatori sono inclusi in un’espressione, Agent li valuta nell’ordine che
segue, in priorità decrescente:

not

and

or
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Si può modificare l’ordine di precedenza con l’impiego di parentesi tonde
(…).

Ad esempio:

subject: pink or rose and not author: tsmith

dice ad Agent di filtrare i messaggi il cui subject contiene la parola pink, o
quelli che contengono la parola rose in qualunque campo e il cui campo
“author” non contiene la parola tsmith.

Ma:

subject: (pink or rose) and not author: tsmith

significa: filtrare i messaggi il cui titolo contiene la parola pink o la parola
rose, e il campo “author” non contiene la parola tsmith.

Oltre a "and", "or" e "not", possono essere impiegati nelle filter expressions i
seguenti operatori:

* L’asterisco è un carattere “wild card”: quando viene fatto seguire ad una
stringa di caratteri indica ogni parola che incominci con quella stringa. Ad
esempio, l’espressione com* sarà soddisfatta da “command”, “comment”
ed ogni altra parola che incominci con “com”.

[l,h]  Due numeri tra parentesi quadre, separati da una virgola, indicano un
insieme di righe del messaggio, estremi compresi. L’asterisco può
essere inserito come wild card al posto di uno dei due limiti. Per
esempio, [*,10] si riferisce a tutti i messaggi lunghi al massimo 10 righe,
mentre [15,*] indica i messaggi che ne hanno almeno 15.

% Il segno di percentuale indica che il termine seguente va considerato
tenendo conto di maiuscole e minuscole.

= Il simbolo di uguale davanti ad un termine in un’espressione segnala ad
Agent di trovare un’occorrenza esatta di tale termine. Quando l’operatore
= è applicato a un campo subject, Agent rimuove ogni prefisso di
risposta "Re: " prima di effettuare il controllo. Ad esempio, il filtro

subject: =testing

seleziona sia "testing" sia "Re: testing". Non seleziona, però, "more
testing", poiché l’operatore = richiede una precisa uguaglianza dell’intero
campo. Se si vuole far sì che Agent ricerchi una corrispondenza esatta
ma consideri anche le risposte, cioè il prefisso Re:, si può operare come
segue:

subject: re and =apple
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Il filtro si riferirà solamente a quei subject che contengono esattamente
apple ed inoltre contengono re.

Expression Qualifiers

In generale, Agent esegue una ricerca quanto più ampia possibile, ma
questa ampiezza dipende dal tipo di ricerca (Usenet, email o Global Search)
Si possono anche usare i qualificatori di espressione per limitare la ricerca
ad alcuni campi.

Se una espressione di ricerca non contiene qualificatori, vengono ricercati i
seguenti elementi:

Usenet Filters: i soli campi Subject ed Author (e non il corpo del messaggio)

Email Filters: tutti i campi dell’header (e non il corpo del messaggio)

Global Search: tutti i campi dell’header ed il corpo del messaggio

Per limitare la ricerca ad uno specifico campo del messaggio, impiegate i
prefissi qualificatori, costituiti dal nome del campo in cui cercare, seguito dai
due punti (:). Ad esempio

subject: testing

cerca solo nel subject la parola "testing", mentre

subject: testing and from: tom gold

cerca nel solo subject la parola "testing" e nel solo campo from la frase "tom
gold". In questo modo, la ricerca riporterà solo quei messaggi il cui titolo
contiene la parola “testing” mentre il campo “from” contiene “tom gold”.

Le espressioni di ricerca per Usenet, email e Global Search permettono
l’impiego di qualificatori differenti.

I filtri Usenet possono contenere i qualificatori “subject:”, “author:” e “from:”.

I filtri Email possono utilizzare il nome di qualunque campo dell’header come
qualificatore. Ad esempio, puoi individuare tutti i messaggi inviati con Agent
con l’espressione:

x-mailer: forte agent

Inoltre, i filtri email possono contenere i seguenti qualificatori speciali:

any-sender: controlla tutti questi campi: From, Apparently-From, Sender,
Reply-To, or X-Sender.
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any-recipient: controlla tutti i seguenti campi: To, Apparently-To, Cc, or
Bcc.

Le Global Search expressions consentono l’uso di tutti i qualificatori possibili
per le email e dei seguenti qualificatori aggiuntivi:

body: controlla le sezioni di testo nel corpo del messaggio. In altre
parole, controlla tutto il testo che si può normalmente leggere nel
messaggio se non si sta osservando la versione “raw”, non formattata.

raw-body: controlla l’intero corpo del messaggio, incluse le parti
contenenti attachment binari ed immagini.

Esempi di filtri Usenet

Prima di procedere con i dettagli sulla costruzione delle espressioni, gli
esempi seguenti dovrebbero farvi vedere come è facile creare potenti filtri.
Questi esempi illustrano filtri per i messaggi Usenet, ma ricordate che il
meccanismo è lo stesso per i messaggi email.

Scenario: Sei un appassionato di aviazione e vuoi sapere qualcosa circa i “blimps”
[dirigibili senza struttura rigida]. Hai sottoscritto il gruppo alt.aviation.methods  e vuoi
creare uno Usenet Filter che faccia scaricare da Agent tutti i messaggi sui dirigibili in quel
gruppo.

1. Un semplice watch filter ed una wild card – Selezionate il titolo di un
messaggio sui dirigibili (ad esempio, "How Does a Blimp Fly?").
Richiamate la finestra di dialogo Add Usenet Filter e completatela così:

Filter Expression: subject: blimp*

Watch Action: Retrieve Body immediately

Importante! Accertatevi di aver inserito il formato generico blimp (tutto
minuscolo). I filtri sono case-sensitive, quindi inserendo Blimp si
troverebbero solo gli headers contenenti Blimp (con l’iniziale maiuscola),
mentre il formato generico blimp trova tutte le occorrenze della parola,
indipendentemente dalle maiuscole (ad esempio, blimp, Blimp, BLIMP,
or BLimP).

Per poter individuare anche il plurale, dovete aggiungere all’espressione
"*", la wild card. Così, subject: blimp* scaricherà tutti gli header
contenenti il singolare o il plurale, maiuscoli o minuscoli (esempio:
blimps, Blimps, BLIMPS, or BlimpS), e, ovviamente, ogni altra parola
costituita da blimp seguito da altri caratteri. Nota: se inserite solo
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blimps, troverete solo la forma plurale – in qualsiasi combinazione di
maiuscole e minuscole.

2. Un filtro che limiti anche la dimensione dei messaggi – Se, oltre ai
criteri di ricerca dell’esempio 1, desiderate vedere solamente i messaggi
sui dirigibili non più lunghi di 100 righe, dovete modificare la filter
expression usando l’operatore “and” ed un parametro per la quantità di
righe, come questo:

subject: blimp* and [*,100]

3. Un filtro che escluda mittenti indesiderati – Diciamo che vogliate
anche evitare la lettura dei messaggi inviati da un mittente fastidioso di
nome Rocco. Potete modificare la filter expression impiegando gli
operatori “and” e “not” nel campo author:

subject: blimp* and [*,100] and not author: rocco

3. Un filtro che aggiunga un secondo argomento – Se vuoi anche
imparare qualcosa sugli airships [dirigibili con struttura rigida], sempre
con i criteri precedenti, potrai modificare l’espressione con l’operatore
“or” e le parentesi, che indicano l’ordine di precedenza:

subject: (blimp* or airship*) and [*,100] and not author:
rocco

5. Un filtro che riduca il “rumore di fondo” – in aggiunta ai criteri
precedenti, puoi dire ad Agent di non scaricare altri messaggi, creando
un kill filter con un livello di priorità inferiore. Le impostazioni del nuovo
filtro dovranno essere come le seguenti:

Filter Expression: subject: * (verranno valutati tutti gli headers)
Kill Action: Delete
Scope: Group: alt.aviation.methods
Priority: 100 (Impostate un valore minore di quello dello watch

filter. In questo modo, Agent scarica prima i messaggi
sui dirigibili, perché lo watch filter ha priorità più elevata,
poi il kill filter dice ad Agent di lasciar perdere tutto il
resto)

Provate a crearvi un paio di filtri da soli. Potete impiegare queste espressioni
come modelli, o potete essere più avventurosi e creare qualcosa di
completamente differente basato sui principi appena appresi.
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Regular Expressions

Gli esempi precedenti illustrano le cosiddette word-based expression.
Queste sono potenti e di facile uso, ma a volte non consentono di ottenere il
preciso comportamento che si desidera. In questo caso, potete impiegare le
cosiddette regular expression.

Usate le Regular Expression solo se necessario.

A causa del grande impegno computazionale richiesto dalle regular
expression, esse vanno impiegate solo quando è veramente necessario,
specialmente nei filtri per Usenet ed email, nei quali il tempo richiesto per la
valutazione dei filtri può influenzare fortemente la prestazione on-line. Se
dovete solo filtrare secondo delle parole, è assai più rapido l’impiego della
sintassi word-based. Ad esempio, il seguente filtro word-based:

subject: this is a test

è assai più veloce di questo filtro a regular expression:

subject: { this is a test }

In generale, troverete necessario l’uso delle regular expression solo per:

• Trovare segni di punteggiatura che normalmente non vengono trattati
come “parole”.

• Trovare testo che appare all’interno di parole.

Come includere Regular Expressions nelle Filter Expressions

Ogni volta che una sequenza di parole da ricercare può apparire in una
espressione, potete includere una regular expression racchiusa tra graffe {..}.
Ecco un esempio di regular expression, combinata con una sequenza di
parole che va trovata:

subject: (this is a test and {[0-9]+})

Questo esempio trova tutti i subject contenenti “this is a test” E una regular
expression che consiste in una qualunque sequenza di una o piu’ cifre.

Regole per scrivere Regular Expressions

Atomi

La regular expression più semplice si chiama "atomo". Un atomo può essere
una qualunque tra le seguenti:



Tutto sui messaggi

87

• Qualunque carattere che non abbia altri significati speciali. Ad esempio,
la lettera “a” e’ un atomo che verifica la presenza di “a” o “A” nel campo
che viene testato..

• Il carattere . (punto). Un punto controlla ogni carattere.

• L’accento circonflesso, o segno di “carato” (^), che fa riferimento all’inizio
del campo che si sta controllando.

• Il simbolo del dollaro ($) che si riferisce alla fine del campo.

• La sbarra diagonale rovesciata, o backslash (\), seguita da un qualunque
carattere, può essere usata per “citare” caratteri che avrebbero invece
significati speciali. Ad esempio, per trovare il carattere “.”, dovrete
scrivere “\.”. Senza la sbarra, il punto avrebbe la sua funzione speciale di
indicare qualunque carattere; così, invece, si parla proprio del carattere
“.”.

• Una regular expression più complessa, racchiusa tra parentesi (...).

• Una gamma, o "range", di caratteri, racchiusi tra parentesi quadre [...].
Questa è definita secondo le seguenti regole:

a. Un range può essere una semplice lista di caratteri. Ad esempio, il
range [qwerty] si riferisce ad ogni singola occorrenza dei caratteri
q,w,e,r,t oppure y.

b. Un range può essere l’insieme dei caratteri compresi tra due,
nell’ordinamento standard (alfabetico, numerico), specificato come
minimo-massimo. Ad esempio, il range [0-9] verifica ogni singola
occorrenza di una cifra (0, 1 etc.).

c. Range più complessi possono essere costruiti considerando le due
regole precedenti. Per esempio, il range [a-z0-9] fa riferimento a
qualsiasi lettera o cifra. (Ricordate che le regular expression di Agent
sono normalmente case-insensitive, cioè non differenziano
minuscole e maiuscole, quindi non dovete inserire anche A-Z nel
range)

d. Se un range incomincia con il carattere ^, ciò indica che tale range si
riferisce a tutti i caratteri che non fanno parte del range specificato (il
complementare, in termini di insiemi). Ad esempio, il range [^a-z0-9]
è verificato da qualunque carattere che non sia una lettera né una
cifra.

e. Per inserire i caratteri ^, [, ], -, in un range come tali, e non come
simboli speciali, dovete farli precedere dal simbolo backslash \. Per
esempio, il range [^\^\]] descrive ogni carattere che non sia un ^ o un
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] (Nota: la prima parentesi quadra, aperta, denota l’inizio del range; il
primo ^ è il segno di “complementare” come spiegato sopra; poi, il
backslash indica che il successivo ^ va interpretato come segno
grafico e non come operatore, e cosi’ pure il secondo backslash fa
considerare come carattere da ricercare e non come operatore la
successiva quadra chiusa. Infine, l’ultima quadra chiusa va a
terminare l’espressione di range)

Controllare l’estensione di un atomo

Potete modificare un atomo facendolo seguire da operatori speciali che
definiscono l’estensione del controllo operato dall’atomo. Questi operatori
sono:

* L’asterisco fa riferimento a “zero o più” occorrenze dell’atomo. Ad
esempio, l’espressione {a*} è verificata anche dall’assenza della lettera
a, oltre che da una o più sue occorrenze.

+ Il segno “più” si riferisce ad una sequenza di una o più occorrenze
dell’atomo. Per esempio, l’espressione {[0-9]+} è verificata quando ci
sono una o più cifre.

? Il punto interrogativo rileva la presenza di nessuna o una occorrenza
dell’atomo.

Esempio:

{ab(c)*} è verificato dalla lettera "a", seguita dalla lettera "b", seguita da
zero o più occorrenze della lettera "c". Ciò significa che rientrano in
questa espressione: "ab", "abc", "abcc", etc.

mentre

{(abc)*} è soddisfatto da zero o più occorrenze della sequenza "abc".
Quindi vi rientra sia il nulla, sia "abc", "abcabc", "abcabcabc", etc.

Concatenare gli atomi

Potete concatenare atomi per descrivere sequenze di filtro più complesse.
Vediamo alcuni esempi:

{forte} descrive la precisa sequenza di lettere "f", "o", "r", "t", "e".

{a?b} descrive zero o una occorrenze della lettera “a”, seguite da una
sola lettera “b”, ovvero comprende “b” e “ab”.

{[0-9]+/[0-9]+} descrive una o più cifre, seguite dal carattere "/", seguito
da un’altra sequenza di una o più cifre.
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{foo(bar)*} descrive la sequenza "foo", seguita da zero o più occorrenze
della sequenza "bar". In questo modo, descrive "foo", "foobar",
"foobarbar", "foobarbarbar", etc.

{^foo.*bar} descrive la sequenza "foo", seguita da una sequenza di zero
o più occorrenze di un qualunque carattere, seguita dalla sequenza
"bar". Inoltre, il simbolo ^ richiede che le sequenze vengano trovate
all’inizio del campo in questione.

Ricerche Alternative

Potete specificare ricerche alternative combinando sequenze di atomi con
l’operatore |, che ha quindi funzioni di “o” logico. Ad esempio:

{a|b} è verificato dalla lettera “a” come pure dalla “b”.

{foo|bar} è verificato sia da "foo" sia da "bar".

Operatori di filtro applicati alle Regular Expression

Potete applicare gli operatori di filtro = (verifica nell’intero campo) e % (case-
sensitive) alle regular expression nello stesso modo in cui li usate con le
normali espressioni word based.

Se una regular expression è preceduta da =, Agent deve controllare l’intero
campo. Ad esempio, il filtro:

subject: ={begin.*end}

è verificato da ogni subject che incomincia con i caratteri "begin", finisce con
"end" e contiene qualsiasi carattere nel mezzo.

Come per le espressioni word-based, prima di applicare l’operatore = al
campo subject, Agent elimina il prefisso di risposta Re:

L’operatore % rende case-sensitive l’intera regular expression, che è
altrimenti sempre case-insensitive, in Agent. Ad esempio, il filtro:

subject: %{[A-Z]+}

filtra subject contenenti una serie di una o più LETTERE MAIUSCOLE.

Invece, il filtro

subject: {[a-z]+}

filtra subject contenenti una serie di una o più lettere, in qualsiasi
combinazione di MAIUSCOLE o minuscole.
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Esempio: come liberarsi della posta indesiderata con un filtro

Siete subissati di messaggi commerciali indesiderati (unsolicited commercial
email, UCE) e altro materiale fastidioso? Questo tipo di messaggi,
comunemente chiamati "spam", sono un grosso disturbo per molti utenti.
Ecco una procedura che potete utilizzare per controllare il flusso di posta
indesiderata.

1. Creare tre folder, in questo modo:

• Create un folder per l’email che sapete di voler ricevere. Potete
chiamarlo "inbox", Posta in Arrivo. (Ovviamente potrete creare più
cartelle, per catalogare meglio i messaggi che vorrete conservare)

• Un altro folder per l’UCE/spam. Potrete chiamarlo "trash"
[spazzatura]. (Potete anche configurare i filtri affinché cancellino
immediatamente lo spam ricevuto. Il solo problema che ne
deriverebbe è il rischio di cancellare qualche messaggio che invece
avreste voluto leggere)

• Create un terzo folder per la posta non ancora classificata in uno dei
precedenti. Potreste chiamarlo "uncategorized" [non catalogata] o “to
be sorted", [da ordinare].

2. Quindi, configurate i filtri di email di Agent in modo che utilizzino le tre
cartelle di cui sopra:

• In Options→Inbound Email→Folder , selezionate il folder
“uncategorized" come cartella predefinita. In questo modo, tutta la
posta che non viene filtrata verrà inserita in questo folder.

• Nell’opzione Kill, settare File in Folder: alla vostra cartella "trash".
Probabilmente troverete che le altre opzioni sono già regolate nel
modo necessario.

• Nell’opzione Watch, settare File in Folder: alla vostra cartella "inbox".

3. Quando ricevete la posta, tutti i nuovi messaggi verranno inseriti nel
folder "uncategorized". Dopo aver ricevuto una certa quantità di
messaggi, osservateli per decidere come vorrete trattare in seguito i
messaggi da quei mittenti.

4. Per i messaggi spam, premete Ctrl+K per creare un kill filter usando la
finestra di dialogo Add Email Filter. Le opzioni predefinite creeranno un
filtro che sposterà nel folder “trash” tutti i successivi messaggi di quel
mittente.
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Per default, il kill filter controllerà l’indirizzo email completo del mittente.
In genere questo sarà ciò che desiderate, ma potreste voler modificare il
filtro per escludere qualsiasi messaggio proveniente da quel dominio. Ad
esempio, se ricevete un messaggio da "great-offer@savetrees.com",
potrete scegliere di mettere nel folder “trash” tutti i successivi messaggi
di qualunque indirizzo del dominio “savetrees.com”. Per modificare il filtro
in modo che verifichi solamente il dominio, cliccate sul pulsante “Paste
Field”, selezionate "Any-Sender (Domain only)" (ogni mittente, solo
dominio) e date l’OK. (Ovviamente, potreste ottenere lo stesso risultato
cambiando manualmente l’espressione; l’impiego del pulsante Paste
Field è soltanto più rapido.)

Notate che assai spesso lo spam non è direttamente indirizzato a voi,
cioè non ha il vostro indirizzo nel campo "To:". Un metodo pratico per
eliminare questo genere di spam è la creazione di un kill filter per tutti i
messaggi che NON contengono il vostro vero indirizzo. Ecco un esempio
per l’utente Jane Doe:

not any-recipient:janedoe@abc.com

Questo sarà efficace contro la maggior parte dello spam. Comunque,
potreste scoprire che il vostro sistema di posta inserisce un campo
Apparently-To nei messaggi che mancano di un campo To: o Cc: . Il filtro
"any-recipient" controlla anche il campo Apparently-To. Se preferite un
filtro che invece non lo controlli, potete provare così:

not to: janedoe@abc.com and not cc: janedoe@abc.com

5. Per i mittenti che conoscete e da cui volete ricevere messaggi in futuro,
premete Ctrl+W per creare uno watch filter che contenga quegli indirizzi;
ad esempio:

from: (tsmith@acme.com or hank.lloyd@zsu.edu)

6. Quando create un filtro di qualunque tipo, kill o watch, potete selezionare
l’opzione Apply filters to folder immediately per far sì che Agent applichi
immediatamente i filtri a tutti i messaggi. Se invece non siete certi di
voler filtrare tutti i messaggi per spostarli nelle varie cartelle, potete
selezionare This message only [solo questo messaggio].

Via via che definite nuovi filtri, noterete che Agent migliorerà nell’ordinare
automaticamente la vostra posta e ci saranno sempre meno messaggi
"uncategorized" da valutare.
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Altri esempi di filtri

La gente crea filtri per le ragioni più disparate. Seguono vari esempi di
espressioni a cui potrete fare riferimento nel creare i vostri filtri.

Per individuare ed eliminare messaggi indesiderati

Con ogni probabilità, riceverete messaggi indesiderati di ogni tipo, da quelli
che propongono facili arricchimenti a quelli offensivi per la vostra morale;
vediamo un po’ di esempi di espressioni utili per filtrare questi messaggi:

Per ottenere migliori prestazioni, potrete combinare in un solo filtro diversi tipi
di messaggi che volete eliminare: a mano a mano che trovate altre parole
che caratterizzano spam di vario genere, potrete sempre aggiungerle
all’espressione. Notate che nell’esempio seguente le barre verticali
equivalgono all’operatore logico “or”:

subject: ($ | $$ | $$$* | $money* | sex* | porn*| xxx*)

2. Per evitare che Agent scarichi headers che incominciano con caratteri
come $, <, -, etc. (tipici dello spam), usate un filtro come questo:

subject: {^[^a-z"]}

Ricordate che le regular expressions in Agent sono case-insensitive a
meno che siano precedute dall’operatore %. Questa espressione
consente i subjects che incominciano con lettere maiuscole o minuscole
o con le virgolette.

Vediamo come funziona: il primo “^” significa, “controlla se la stringa è
all’inizio di una riga” . Il secondo "^", quello dentro le parentesi quadre "[
]", significa "non questi caratteri", cioè "filtra tutti i caratteri che non siano
lettere maiuscole, minuscole o virgolette”.

Filtrare una determinata parola

1. Per individuare qualunque parola che finisca con "right", seguito da uno
spazio o dalla fine del campo, potete impiegare la seguente espressione:

{right( |$)}

Essa corrisponderà a birthright, o forthright, o semplicemente right, ma
non righteous.

2. Per individuare right in ogni parte del subject, potete usare la seguente
espressione:

{right}

Questo filtrerà righteous o forthright o semplicemente right.



Tutto sui messaggi

93

Eliminare gli articoli con corpo molto piccolo o assente:

[1,2]

Notate che il minimo viene posto a 1, anziché a 0. Questo perché alcuni
news server non aggiungono il numero di linee ai messaggi, e danno quindi
un valore zero a tutti.

Filtrare gli headers TUTTI MAIUSCOLI

Create un filtro che corrisponda ai titoli scritti in sole maiuscole. Usatelo per
cancellare tutti i messaggi corrispondenti o porli nel folder “trash”.

subject: =%{[^a-z]+}

Ricordate che le regular expressions in Agent sono case-insensitive se non
sono precedute dall’operatore %. Questo è necessario per poter escludere i
messaggi il cui titolo ha solo lettere maiuscole e nessuna minuscola, o non
presenta affatto lettere dell’alfabeto.

Ecco il funzionamento dell’espressione:

Il segno di uguale "=" significa "deve corrispondere all’intero campo". In altri
termini, il campo deve essere composto di soli caratteri che non siano lettere
minuscole. L’espressione “[^a-z]” significa "individua ogni carattere che non
sia una lettera minuscola”. Infine, il segno più “+” significa "nel campo deve
essere presente uno o più dei precedenti caratteri”.

Esempio conclusivo: ottimizzare Agent per l’uso in due postazioni.

Questo esempio vi mostra come potrete combinare le preferenze per l’email
(vedi pag. 67) con i filtri, per regolare al meglio l’impiego di Agent a casa e
sul lavoro.

Poniamo che abbiate una sola casella di posta elettronica e che impiegate
Agent per leggerla, sia a casa sia in ufficio. Dal momento che avete un solo
indirizzo, riceverete sia la posta privata sia quella professionale nella
medesima casella, e potrete ricevere i due tipi di posta in una qualunque
delle due situazioni, ogni giorno della settimana. Ovviamente, vi piacerebbe
ricevere le email lavorative in ufficio e quelle personali a casa. Innanzitutto,
selezionate le opzioni Leave messages on server [lascia i messaggi sul
server] e Until retrieved at both of my sites [finché non vengono scaricate in
entrambe le mie postazioni]: queste opzioni si trovano in Options→Inbound
Email→Checking Mail. In questo modo riceverete tutti i messaggi sia a casa
sia in ufficio ed Agent li cancellerà dal server solo dopo che saranno stati
ricevuti in tutte e due le situazioni.
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Ora dovete dire ad Agent di scaricare selettivamente alcuni tipi di messaggi
in una situazione e non nell’altra. Ad esempio, diciamo che riceviate una
newsletter di argomento professionale e che non siate interessati a riceverla
anche a casa. Sulla copia di Agent che avete in ufficio, create un watch filter
per la posta che scarica il messaggio, lo inserisce in un folder a vostra scelta
e poi lo rimuove dal server. (Potete farlo selezionando l’opzione "Do not
leave on server" quando create il filtro). Sulla copia di Agent che usate a
casa, create un kill filter per questo stesso messaggio (impiegando i campi
appropriati per individuarlo), e scegliete "delete" come kill action. Accertatevi
di non scegliere l’opzione Do not leave on server (non lasciare sul server).
Se la scegliete, non vedrete mai in ufficio i messaggi già visti a casa. Seguite
gli stessi passi per le altre email personali o lavorative, fino ad ottenere
l’equilibrio che desiderate tra ciò che ricevete sul lavoro e ciò che ricevete a
casa.

Visualizzare i Messaggi
Se c’è una certezza nella vita, questa consiste nel fatto che ciascuno ha il
suo personale modo di vedere le cose. Ciò che va bene per qualcuno può
non essere adatto per qualcun altro. Agent si adatta a questo, ed ha
caratteristiche che vi permettono di cambiare il modo in cui i messaggi
vengono visualizzati, per soddisfare i vostri gusti e le vostre necessità..

Ordinare i messaggi

Nel pannello Message List, potete disporre i messaggi in ordine di thread,
subject, author, data, o dimensione. Potete avere ordinamento indipendente
per ciascun gruppo e, tra una sessione e l’altra, Agent ricorda l’ultimo
ordinamento che avete scelto per ogni gruppo.

Per ordinare i messaggi:

Seguono diverse possibilità, tutte equivalenti. Scegliete quella che trovate più
semplice ed immediata:

Opzione di menu: Selezionate un tipo di ordinamento nel menu Group→Sort
Messages by.

Mouse option: Nel pannello Message List, cliccate sull’etichetta di intestazione
della colonna in base alla quale ordinare i messaggi (ad esempio
Date).

_____________________________________________________________
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OO Con l’opzione di menu potete selezionare più gruppi e cartelle nel
pannello Groups, per poi scegliere un tipo di ordinamento comune a
tutti con una sola azione.
Usando il mouse, potete ordinare per thread o per dimensioni
cliccando la prima colonna a sinistra fino a che Thread o Size
appaiono sull’etichetta della colonna.

_____________________________________________________________

Agent mostra in fondo alla lista i messaggi i più recenti, se l’ordinamento è
per data, i più voluminosi se l’ordinamento è per dimensioni.

Per cambiare la direzione di ordinamento per data o dimensioni:

1. Selezionate la scheda Options→General Preferences→Message list tab
(vedi sotto).

2. Selezionate la casella Date sorts descending e/o Size sorts descending.
_____________________________________________________________

OO Dopo aver modificato le impostazioni dovrete nuovamente effettuare
l’ordinamento dei messaggi, per vedere gli effetti del cambiamento.

_____________________________________________________________

Modificare il modo in cui vengono visualizzati i thread

Oltre ad ordinare i messaggi potete scegliere il modo in cui vengono
visualizzati i thread nel pannello Message List.

To definire in che modo devono essere visualizzati i thread:

Selezionate la scheda Options→General Preferences→Message list per
esaminare quali possibilità ci sono di modificare l’aspetto dei thread.
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 Le opzioni della sezione Threading sono descritte nella tabella che segue:

Scegliete questa
opzione...

...per far fare questo ad Agent.

Enable threading
by subject

Raggruppa messaggi con lo stesso subject in un unico
thread, anche se il messaggio in follow-up non contiene un
valido riferimento al messaggio precedente.
Nota: molti frequentatori di Usenet spesso sbagliano
nell’inviare le loro repliche. Questa opzione aiuta a
ricondurre i follow-up scorretti al messaggio giusto.

Start a New
thread when a
follow-up subject
changes

Comincia un nuovo thread se il subject di un follow-up è
diverso rispetto a quello del messaggio precedente.
(quando questa opzione non è selezionata, Agent unisce i
follow-up al messaggio originale, anche se il subject è
cambiato).

Expand thread if
necessary to
highlight current
body pane

Espande i thread nella lista dei messaggi, in modo da
rendere visibile il messaggio corrente.
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message

Scegliete questa
opzione...

...per far fare questo ad Agent.

Initial thread
setting

Stabilisce il modo in cui appaiono i thread quando aprite
Agent. (ad es., tutti i thread ristretti).

When skipping to
unread follow-ups

Stabilisce lo stato del thread selezionato quando saltate al
successivo messaggio non letto. Due note aggiuntive: se
state usando una delle Viste, e la scelta corrente qui è Do
not expand, allora va in uso Expand active threads . Inoltre,
l’opzione View Next Unread Message Body nel menu
Navigate espande sempre il thread anche se si tratta del
primo messaggio.

Follow-Up
Indentation

Specifica il numero dei caratteri per il rientro dei follow-up
rispetto al messaggio precedente.

Maximum
Follow-Up Level

Specifica il numero massimo dei livelli per le risposte. I
follow-up che superano questo livello vengono incolonnati
uno sotto l’altro senza più rientro.

Reply Prefixes Questa lista comprende i prefissi che Agent dovrà
riconoscere. Agent usa i prefissi per trattare i subject e
deve identificare ”Re:” come prefisso per poterlo gestire
correttamente. Per convenzione i più usano il Re:, per
identificare una replica. A volte in altre lingue si usano
differenti prefissi al posto di “Re:”. Inserite in questo
riquadro tutti i prefissi che volete che Agent riconosca.
Potete separarli l’uno dall’altro con uno spazio o una
virgola. Infine, quando Agent cerca i prefissi, la ricerca non
è sensibile alle maiuscole, così non importa se scrivete i
prefissi in maiuscole o minuscole.

Nota: Agent dà per scontato che un prefisso di replica
finisca con “:”, i due punti, quindi non dovreste includerli
della lista dei prefissi.

Creare ed usare le Viste per la lista dei messaggi

Agent vi permette di specificare quali tipi di messaggi devono essere
visualizzati nel pannello Message List e nelle cartelle (ad esempio, i
messaggi non letti). In entrambi i casi, la scelta è globale (vale a dire che il
tipo di vista si applica a tutti i gruppi e le cartelle). Se le viste predefinite non
vi soddisfano potete crearne altre personalizzate.

Nota: a volte, determinate viste possono nascondere alcuni dei messaggi in
uno stesso thread. Ad esempio, potreste scegliere di visualizzare solo i
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messaggi non letti, ma in uno stesso thread potrebbero esserci anche
messaggi letti. Se volete visualizzare l’intero thread evidenziatelo ed usate il
comando Navigate→Show Full Thread. Si tratta di un comando temporaneo,
che mostra tutto il thread finché restate nel pannello Message List usando
questa vista.

Per selezionare velocemente le viste, usate i seguenti metodi:

• Aprite il menu Group→View Messages e selezionate una vista.
• Nel pannello Message List cliccate il binocolo sull’etichetta della seconda

colonna  apparirà la finestra di dialogo Select View, da cui potrete
scegliere la vista che preferite.

• Usate la scorciatoia da tastiera “V” per far apparire la finestra di dialogo
Select View, da cui potrete scegliere la vista che preferite.

Per creare una vista personalizzata usate uno dei seguenti metodi:

• Aprite il menu Group→View Messages e selezionate Manage Views.
• Nel pannello Groups/Folders, fate click destro su un gruppo o una

cartella, apparirà il menu contestuale. Da qui aprite View Messages e
selezionate Manage Views.
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Potete usare la finestra di dialogo finestra di dialogo Manage Views per
creare ed aggiungere viste personalizzate, ma anche per modificare o
rinominare quelle già presenti. Agent è flessibile, potete creare facilmente
nuove viste usando simple view, o crearne altre più complesse in advanced
view. Vediamo come funziona.

Per una vista semplice:

1. Selezionate Simple View. Premete il pulsante Add per visualizzare la
finestra di dialogo Add ed inserite il nome che scegliete per la vista che
intendete creare.

Nota: potete creare una scorciatoia da tastiera per la vista inserendo il
carattere “&” prima di quello che volete sia il carattere attivo per la
scorciatoia nel nome della vista. La "&" fa sì che Agent sottolinei il
carattere successivo quando il nome appare nel menu View, e attiva quel
carattere come scorciatoia.
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2. Quando premete OK nella finestra di dialogo Add View, il nome viene
aggiunto alle altre viste ed appare selezionato.

3. Ora selezionate tutti gli attributi per i messaggi che devono apparire in
quella vista e premete OK nella finestra di dialogo Manage Views.
Quando selezionerete questa vista, verranno applicati gli attributi che
avete scelto.

Per definire viste più complesse, selezionate l’opzione Advanced view.
Quando questa opzione è selezionata, appare il campo Boolean expression
dove potete inserire l’espressione che definisce precisamente cosa volete sia
mostrato in questa vista. (Vedi la figura a pagina seguente.)

Usare le espressioni booleane per ottenere viste più complesse

Più sopra, in questo stesso capitolo, abbiamo introdotto le espressioni
booleane come parole in frasi che pongono determinate condizioni logiche.
Queste frasi sono formate da due elementi: gli operatori e gli operandi.
Quando inserite un’espressione nel campo Boolean expression (vedi la
figura seguente), Agent usa quell’espressione ogni volta che recuperate i
nuovi header, controllando l’occorrenza delle condizioni poste
dall’espressione, che determinano quali messaggi possono apparire nella
Lista dei Messaggi.

Operandi nelle Expression
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Gli operandi nelle espressioni sono condizioni che possono essere verificate.
Sono:

• Read (nei messaggi letti)
• Body (nel corpo dei messaggi)
• Watch (in watch thread)

• Ignore (in ignore thread)
• Keep (nei messaggi che non vanno in alcun modo eliminati)
• Mark (nei messaggi marcati per il successivo recupero)
• Incomplete (nei messaggi multipart mancanti di una o più parti)

 Operatori nelle Expression

 La lista che segue elenca gli operatori che influenzano il funzionamento delle
espressioni, in ordine di priorità. Potete usare a piacimento la parola, oppure
il simbolo:

• not (o l’equivalente simbolo !)
• thread (o l’equivalente simbolo +)
• and (o l’equivalente simbolo &)
• or (o l’equivalente simbolo |)

• [low,high]

 Gli operatori "not", "and", and "or" sono di evidente significato, mentre
"thread" specifica che se le condizioni successive sono vere, verrà mostrato
l’intero thread in cui è incluso il messaggio che risponde alle condizioni
specificate. Inoltre, "[low,high]" vi permette di specificare i limiti inferiore e
superiore delle dimensioni, in numero di linee, dei messaggi da trovare (ad
esempio, [50,*] limita la ricerca ai messaggi di lunghezza superiore alle 50
linee).

 Esempi di expression semplici

 not read and body - Agent mostrerà tutti i messaggi con corpo e non letti.

 not read and not incomplete - Agent mostrerà tutti i messaggi non letti di
cui è disponibile ogni parte (escludendo quindi quelli incompleti).

 !read | keep - Agent mostrerà tutti i messaggi non letti, e quelli per cui è
attivata la funzione keep.

 Esempi di expression avanzate
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 Potete creare expression più complesse, usando più d’una frase. Per
stabilire delle precedenze potete circondare le istruzioni con parentesi (...),
che modificano l’ordine in cui Agent le esegue per la ricerca. Gli esempi che
seguono sono espressioni composte che usano differenti operatori ed
operandi per creare viste particolari:

 not read or thread (not read and watch) - Agent mostrerà tutti i messaggi
non letti. Inoltre, per tutti i messaggi non letti che fanno parte di thread in
watch, verrà mostrato l’intero thread.

 (thread (watch and keep)) & (not read and body) - Agent mostrerà solo i
messaggi non letti in thread che sono sia in watch che in keep (preceduti
dall’icona Keep ).

 !ignore & !read & !incomplete & [50,*] - Agent mostrerà tutti i messaggi
che non sono ignorati, che non sono letti, che non hanno attachment
incompleti, e che sono lunghi almeno 50 linee.

 Nota: quando passate da simple view ad advanced view nella finestra di
dialogo Manage Views, Agent mostra l’espressione booleana equivalente al
filtro che è stato definito in simple view. Viceversa, se tornate indietro alla
simple view, Agent tenta di mostrare un equivalente all’espressione
booleana. Dal momento che tali espressioni possono definire filtri non
disponibili in simple view, il risultante filtro semplice può non corrispondere
esattamente. In questo caso Agent mostrerà un messaggio di avviso.
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 Cambiare il modo in cui i messaggi vengono visualizzati

 Display preferences – Usate la scheda Options→Display Preferences
Messages per modificare l’aspetto del corpo dei messaggi. In particolare:

• Tab spacing (il numero di caratteri per il rientro di tabulazione)

• Quoted text markers (i caratteri riconosciuti come indicatori del testo
citato in un messaggio)

• Divisori tra sezioni nel corpo di un messaggio

• Il modo in cui vengono visualizzate le URL (colore, sottolineatura,
evidenziazione)

Word wrapping - Agent ha un opzione Word Wrap nel menu Message che vi
permette di ottimizzare il modo in cui visualizzare il contenuto dei messaggi.
Usare questa opzione è di particolare aiuto quando ricevete messaggi con
righe molto lunghe che non rientrano nello schermo. Agent Andrà a capo
automaticamente, in modo che tutto il testo sia visibile nella finestra.

Message details – Potete visualizzare o nascondere tutti gli headers di un
messaggio ricevuto (autore, subject, data, numero di linee, ecc.) Potete
anche decidere se vedere un messaggio come formattato oppure grezzo
(raw).

Changing fonts – Potete scegliere con quali font visualizzare i messaggi.
Selezionate il font usando la scheda Options→Display Preferences→Fonts.

Testo codificato in ROT13

Può capitarvi di ricevere messaggi in cui alcune parti di testo risultino del
tutto inintelligibili. Ad esempio, se incontrate qualcosa come "pur cnyyr
'fgn genqhmvbar qv Ntrag, zr fb' cebcevb ebggb", è possibile che il
testo sia stato codificato secondo un codice detto ROT13.

Per illustrare meglio questo punto, la frase “Ciao a tutti” codificata in ROT13
risulta: “ Pvnb n ghggv”. Un testo in ROT13 non può essere letto senza
prima essere decodificato. Agent supporta sia la codifica che la decodifica in
ROT13.

Ecco come fare:

Per codificare un messaggio in ROT13:

1. Selezionate il testo da codificare.

 Per maggiori
dettagli vedi
pagina185.
 
 
 

 
 
 
 
 
 Per maggiori
dettagli vedi
pagina 191.
 
 
 

 Per maggiori
dettagli vedi
pagina 192.
 
 
 Per maggiori
dettagli vedi
pagina 186.
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2. Selezionate Edit→Apply ROT13 (oppure premete CTRL+3). Agent
codificherà il testo selezionato. Una volta codificato in ROT13, il testo
dovrà essere decodificato per poter essere letto.

Per decodificare un messaggio in ROT13:

1. Selezionate il testo codificato.

2. Selezionate Edit→Apply ROT13 (oppure premete CTRL+3).

OO La decodifica di un messaggio ricevuto si limita alla visualizzazione sul
vostro monitor. Il messaggio non viene modificato, e se lo riaprite
successivamente vedrete di nuovo il testo originale, ancora codificato.

Se codificate il testo di un messaggio che state scrivendo, la codifica
verrà salvata e spedita. Chi riceve il messaggio dovrà decodificarlo per
poterlo leggere.

Trovare i Messaggi
Usando Agent, probabilmente inizierete ad accumulare un gran numero di
messaggi news ed email. Arriverà il momento in cui avrete bisogno di
ritrovare un determinato messaggio, o diversi messaggi inerenti ad un
argomento stabilito o provenienti da un certo autore. Agent è provvisto di
strumenti per aiutarvi nel caso abbiate questa esigenza.

Find / Find Next

Nel caso in cui lavoriate su un singolo gruppo o folder, usate la funzione Find
per cercare i messaggi il cui campo subject o autore contenga una
particolare stringa di testo.

Per trovare un messaggio che soddisfi una semplice stringa di testo

a. Rendete attivo il pannello Message List relativamente al gruppo o
cartella dove volete trovare il messaggio. Potete fare questo
selezionando qualsiasi messaggio nella lista.

b. Selezionate Edit→Find (o usate Ctrl+F).

c. Quando apparirà la finestra di dialogo Find Message, immettete una
parte del subject o dell’autore di cui volete effettuare la ricerca.
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d. Cliccate il pulsante Find First per trovare il primo messaggio nella lista
che contenga il testo che avete inserito. Premete Find Next per trovare il
messaggio successivo sotto quello attualmente evidenziato che
contenga il testo richiesto nel campo subject o autore. In entrambi i casi
la finestra di dialogo scomparirà e verrete posizionati sul messaggio
trovato.

e. Se il messaggio trovato non è quello che volevate, scegliete Find Next (o
premete F3) per trovare il messaggio successivo che contiene il testo
che avete inserito.

Global Search

Spesso un semplice “find” non è sufficiente. Potreste voler cercare una
stringa di testo nel corpo di un messaggio, o potreste voler cercare dei
messaggi in diversi gruppi o cartelle. In queste situazioni, è necessario usare
la funzione global search di Agent.

Per effettuare un global search sui messaggi in Agent, selezionate
Edit→Global Search (o usate Ctrl+G). Apparirà la finestra di dialogo Global
Search For Messages.
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Utilizzando questa finestra di dialogo eseguirete la ricerca in quattro semplici
passi:

1. Dire ad Agent cosa cercare.

Search For – inserite l’espressione di ricerca in questo campo. Le
espressioni di Global Search sono le stesse dei filtri Usenet e email:
cioè, sia le word-based expression o le regular expression possono
essere usate.

• Se non specificate nessun campo nell’espressione, Agent cercherà
in tutti i campi e nel corpo del messaggio.

• Se inserite il campo "body:", Agent cercherà nel corpo del messaggio
formattato (ad esempio, il testo che vedete sullo schermo quando
"Show Raw Message" nel menu Message non è selezionato).

• Se inserite il campo "raw-body:", Agent ricerca nel corpo del
messaggio completo in formato raw (escludendo gli headers).

Ecco qui un esempio: subject: testing e body: {una regular expression}
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Nota: qualsiasi nome di campo che inserite è lecito, come pure i nomi
particolari "any-sender", "any-recipient", "body", e "raw-body".

Per quel che riguarda la ricerca nel corpo dei messaggi, le regular
expression sono “line-based”. Questo significa che ogni regular
expression effettua la ricerca una linea alla volta, e non può essere
trovato testo disposto su più linee. Al contrario, le word based expression
possono cercare e trovare testo disposto su più linee. Nota: per “linea”
s’intende una parte di testo delimitata da “hard breaks”, veri ritorni a
capo, non una riga così come viene visualizzata sullo schermo.

Paste Field – questo pulsante apre la finestra di dialogo Paste Field. Da
qui si possono inserire direttamente campi tratti dal messaggio che è
selezionato nel browser.

History - questo pulsante apre la finestra di dialogo che elenca le ultime
venti espressioni di ricerca che sono state usate, pronte per essere
inserite nuovamente.

Lower Case  – questo pulsante rende tutto minuscolo il testo
dell’espressione di ricerca. Questo rende la ricerca insensibile alle
maiuscole.

2. Per specificare dove Agent dovrà effettuare la ricerca:

Search in Selected groups and folders only – selezionate questa
casella per far sì che Agent cerchi solo nei gruppi e nelle cartelle che
sono selezionate (evidenziate) nella finestra browser associata alla
ricerca. Nota: potete muovervi liberamente tra il browser e questa
finestra di dialogo. Potete quindi aprire una finestra per una determinata
global search e, senza chiuderla, tornare al browser, per selezionare via
via differenti gruppi o cartelle dove cercare.

Search in All Groups in view – selezionate questa casella per far sì
che agent cerchi in tutti i gruppi attualmente visibili nella finestra
Browser. Ad esempio, se nel browser state visualizzando i gruppi
sottoscritti, Agent cercherà in quelli.

Search in All folders in view - selezionate questa casella per far sì che
agent cerchi in tutte le cartelle attualmente visibili nella finestra Browser.

Search in Visible messages only - selezionate questa casella per far sì
che agent cerchi solo nei messaggi visualizzati, qualsiasi sia la vista che
avete selezionato nella finestra browser. Nota: gruppi e cartelle possono
avere viste differenti. Questo significa che l’opzione cercherà nei
messaggi realmente visualizzati nel gruppo o nella cartella aperti al
momento, non in particolare i messaggi che rispondono ai criteri
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specificati per la vista selezionata. Ricordate che è possibile, per vari
motivi, che alcuni messaggi vengano temporaneamente inseriti in una
particolare vista, ad esempio quando si riceve nuova posta.

Close when successful – selezionate questa casella per fare in modo
che la finestra di ricerca, se è selezionata, si chiuda automaticamente
quando la ricerca è terminata con successo. Se la casella non è
selezionata, Agent lascia la finestra aperta, in modo da poter
direttamente proseguire con altre ricerche. Questa opzione rimane
accessibile anche mentre la ricerca è in corso, nel caso cambiaste idea.

3. Indicate come volete che Agent si comporti nella ricerca di messaggi.

Find First - trova il primo messaggio corrispondente ai criteri di ricerca e
posiziona su di esso la finestra del Browser.

Find Next – trova il successivo messaggio corrispondente ai criteri di
ricerca dopo quello correntemente selezionato.

Find Next Group – trova il primo messaggio corrispondente ai criteri di
ricerca nel gruppo successivo a quello che contiene il messaggio
correntemente selezionato. Usate questo tasto per spostare rapidamente
la ricerca nel successivo gruppo o cartella.

Find All – trova tutti i messaggi corrispondenti ai criteri di ricerca in tutti i
gruppi e cartelle selezionati.

Find All in Current Group/Folder – trova tutti i messaggi corrispondenti
ai criteri di ricerca nel gruppo o cartella aperto al momento. Questo
comando ha la precedenza sulle opzioni specificate nel riquadro "Search
in ", cercando solo nel gruppo corrente. Al termine della ricerca, Agent
mostra nella finestra del Browser solamente i messaggi che ha trovato. Il
titolo sul pannello Message List diventa allora "Search Results". I risultati
della ricerca rimangono finché si cambia visualizzazione o ci si sposta in
un altro gruppo o cartella.

Stop – interrompe la ricerca in corso.

Cancel/Close  – chiude la finestra di dialogo.

4. Vedere i risultati della ricerca

Results – questa lista mostra i nomi dei gruppi o delle cartelle e i subject
di tutti i messaggi che risultano dalla ricerca; viene costantemente
aggiornata mentre la ricerca prosegue. Possono essere elencati fino a
8000 messaggi. Se i risultati sono più di 8000, Agent si ferma e presenta
un messaggio di errore.
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Jump – “salta” al messaggio selezionato nella lista dei risultati. Se c’è
ancora una ricerca attiva, la finestra di ricerca viene ridotta ad icona; se
non ci sono ricerche in atto, la finestra si chiude.

Ecco alcuni casi in cui conviene usare Jump.

• Quando si sta solo cercando qualcosa e si desidera posizionarsi sul
messaggio mantenendo aperta ed evidenziata la finestra del Global
Search.

• Quando si vuole leggere il messaggio e poi, terminata la lettura,
tornare alla lista dei risultati. Per posizionarsi sul messaggio e
portare in primo piano la finestra del Browser usare Shift+Jump.
Questo minimizzerà la finestra del Global Search.

• Quando si trova ciò che si desiderava e probabilmente si è terminata
la ricerca. In questo caso, Agent dispone automaticamente la
finestra del Browser sul messaggio trovato e chiude la finestra del
Global Search.

View All – fa sì che la finestra del Browser mostri tutti i messaggi che
soddisfano i criteri di ricerca nel gruppo che contiene il messaggio
selezionato nella lista dei risultati. Se c’è ancora una ricerca attiva, la
finestra del Global Search è ridotta ad icona. In assenza di ricerche
attive, Agent chiude questa finestra. Per mantenerla aperta, tenete
premuto il tasto SHIFT mentre cliccate su View All. CTRL+doppio click è
la scorciatoia da tastiera equivalente a View All.

Clear View  – cancella i risultati della ricerca e riporta alla visualizzazione
originale dei messaggi nella finestra del Browser. Un altro modo di fare
ciò consiste semplicemente nel riselezionare la visualizzazione del
messaggio corrente nella finestra del Browser: questo aggiorna la
visualizzazione.

Consigli per il Global Search

Ecco qualche consiglio per un uso più efficiente della finestra di dialogo
Global Search:

• Nella finestra Browser, selezionate un messaggio che abbia come titolo
ciò che desiderate cercare. Aprite Global Search (ctrl+G) e cliccate su
Paste Field per incollare il subject dell’articolo nell’espressione di ricerca.
Poi usate Find First e Find Next finché trovate un gruppo o una cartella
che contenga quel titolo. Dopo averlo trovato, Find All mostrerà tutti i
messaggi corrispondenti in quel gruppo o cartella.
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• Se nel suddetto tipo di ricerca volete cercare, ad esempio, solo tra i
messaggi non ancora letti, impostate la visualizzazione della finestra del
Browser a “unread messages” prima di effettuare la ricerca e selezionate
l’opzione Search in Visible messages only nella finestra di dialogo Global
Search.

• Se dalla ricerca risultano troppi messaggi, potete modificare
l’espressione di ricerca ed effettuare un nuovo Find All impiegando i soli
risultati della ricerca precedente. Agent cercherà solamente tra quelli.

Conservare i messaggi
Per consentirvi di leggere i messaggi con comodo offline, Agent salva sul
vostro hard disk tutte le informazioni su gruppi e messaggi. Col tempo
inevitabilmente i database dei messaggi si ingrandiranno a scapito dello
spazio libero su disco. Per questo motivo, Agent dispone di un sistema di
eliminazione automatica dei messaggi dopo un certo tempo. L’operazione è
detta “purging”.

Per ottenere questo non dovete fare nulla. Agent è configurato per eliminare i
messaggi ad un ritmo considerato ragionevole. In ogni caso potete
personalizzare la strategia di eliminazione dei messaggi o addirittura
disabilitare l’eliminazione automatica per conservare i messaggi
indefinitamente.

Il prossimo paragrafo, Strategie di eliminazione dei Messaggi, illustra le
opzioni per comunicare ad Agent quando e cosa rimuovere dal disco fisso.

Strategie di eliminazione dei Messaggi (Purge)

Potete specificare esattamente quali messaggi eliminare e quando farlo in
base a precise scadenze (per es. predisporre l’eliminazione di tutti i
messaggi più vecchi di dieci giorni ogni volta che si esce dal programma). La
strategia scelta determinerà i messaggi da conservare nei database.

L’eliminazione dei messaggi non influenza lo spazio utilizzato su disco. Per
esempio, dopo aver ripulito un database di 1.4 megabytes, il file continuerà
ad avere la stessa dimensione. Anche se i messaggi eliminati sono molti,
lo spazio destinato al file rimane esattamente lo stesso.

Tuttavia, nel momento in cui scaricherete nuovi messaggi questi andranno
ad occupare lo spazio lasciato vuoto. Questo fa sì che il file non si
ingrandisca ulteriormente (almeno fino a quando la sua dimensione non
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supererà quella precedente l’operazione di eliminazione). Per ridurre il file
dovrete invece far seguire all’eliminazione dei messaggi il compattamento
dei database (“compact database”, vedi pag. 115).

Per dire ad Agent quando effettuare l’eliminazione automatica dei
messaggi:

Aprite la scheda Group→Properties→When to Purge per visualizzare quanto
mostrato qui di seguito.

Le prime due opzioni di questa finestra di dialogo comunicano ad Agent quando
eliminare i messaggi. Selezionate quella che meglio si adatta alle vostre
esigenze.

• When Retrieving new headers – Selezionate questa casella affinché Agent
elimini i messaggi di un gruppo ad ogni recupero dei nuovi header.

• When Closing Agent – Selezionate questa casella se volete che Agent
elimini i messaggi di un gruppo ogni volta che uscite dal programma.

Le opzioni di
compattamento
sono descrittte a
pag. 115.
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Nota: Se nessuna delle due opzioni è selezionata, Agent non eliminerà
automaticamente alcun messaggio. Potrete comunque farlo manualmente
aprendo il menu Group→Purge Newsgroups e scegliendo i gruppi che si
desidera ripulire.

• When closing Agent, Prompt for confirmation... – Se questa opzione è
selezionata, Agent vi chiederà conferma prima di eliminare i messaggi (e/o
compattare i database) all’uscita dal programma. Se è deselezionata, Agent
eliminerà i messaggi e/o compatterà i database automaticamente.

Come dire ad Agent cosa eliminare:

Aprite Group→Properties→When to Purge per vedere la scheda sottostante.

Le opzioni sulla scheda What to Purge sono descritte qui sotto:

1. Minimal, Low, Medium, High – Premete il pulsante che corrisponde alla
quantità di spazio del disco che volete sia mediamente occupato. Poiché
questo potrebbe risultare complicato, le quattro opzioni predefinite eseguono
per voi la configurazione, in funzione di quanto siete interessati allo spazio
che Agent può occupare nel sistema. Premuto un pulsante, potete controllare
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le altre configurazioni e modificarle per meglio adeguarle alle vostre
necessità.

2. Purge Read Messages Without Bodies – Elimina gli header dei
messaggi letti e privi di corpo. Scegliete una delle opzioni per specificare
quando effettuare l'operazione: On every purge (Ad ogni eliminazione), When
the message is older than...(Quando il messaggio è più vecchio di…) (a voi
mettere il limite) e When the message is no longer available (Quando il
messaggio non è più disponibile sul vostro server).

3. Purge Read Messages With Bodies – Elimina i messaggi letti, con
corpo. Scegliete una delle opzioni per specificare quando effettuare
l'operazione: On every purge (Ad ogni eliminazione), On every purge delete
body only (Ad ogni eliminazione cancella il solo corpo), When the message is
older than...(Quando il messaggio è più vecchio di…) (a voi mettere il limite),
Never (Mai).

4. Purge Unread Messages Without Bodies – Elimina gli header dei
messaggi non letti e senza corpo. Scegliete una delle opzioni per specificare
quando effettuare l'operazione: On every purge (Ad ogni eliminazione), When
the message is older than...(Quando il messaggio è più vecchio di…) (a voi
mettere il limite) e When the message is no longer available (Quando il
messaggio non è più disponibile sul vostro server).

5. Purge Unread Messages With Bodies – elimina i messaggi non letti,
con corpo. Scegliete una delle opzioni per specificare quando effettuare
l'operazione: On every purge (Ad ogni eliminazione), On every purge delete
body only (Ad ogni eliminazione cancella il solo corpo), When the message is
older than...(Quando il messaggio è più vecchio di…) (a voi mettere il limite),
Never (Mai).

6. Always get complete list of server's available messages –
Selezionate questa casella per far sì che Agent recuperi la lista completa dei
messaggi disponibili ogni volta che scarica nuovi headers. Questa opzione è
utile (ma non indispensabile) quando avete selezionato l’opzione When the
message is no longer available (Quando il messaggio non è più disponibile) in
uno dei precedenti passaggi. L’opzione, tuttavia, aumenta il tempo
necessario a scaricare i nuovi header.

Se lasciate non selezionata questa casella, Agent scaricherà i messaggi con
numeri più bassi dell’intervallo dei messaggi disponibili fornito dal vostro
server. Poiché ci sono spesso dei vuoti nella serie di messaggi disponibili,
questa configurazione può far sì che Agent conservi messaggi non più
disponibili.
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Evitare l’eliminazione di messaggi

Occasionalmente vi capiterà sottomano un messaggio che non volete sia
automaticamente eliminato da Agent (o che non volete sia cancellato per
errore)

Per impedire l’eliminazione di un messaggio:

Evidenziate l’header del messaggio e usate una delle opzioni seguenti:

Pulsante della barra degli strumenti :

Opzioni da menu: Message→Keep
Scorciatoia da tastiera: K

L’icona Keep Message  apparirà vicino al messaggio. Agent non potrà
cancellare il messaggio finché non rimuoverete l’icona. Per rimuoverla,
ripetete una delle opzioni suddette. Una volta disattivata la funzione, Agent
eliminerà il messaggio secondo la configurazione specificata nelle schede
When e What to Purge precedentemente descritte.

Cancellare manualmente i messaggi

Oltre alle opzioni di eliminazione precedentemente descritte, potete sempre
cancellare header e testi dei messaggi.

Per cancellare un messaggio:

Evidenziate l’header del messaggio e usate una delle opzioni seguenti:

Pulsante della barra degli strumenti :
Opzioni da menù: Message→Delete
Scorciatoia da tastiera: Del

Nota: non potete cancellare manualmente un messaggio per cui avete
attivata la funzione “keep”.

Per cancellare il testo di un messaggio:

Quando il pannello Message è attivo, usate una delle opzioni seguenti.

Pulsante della barra degli strumenti :

Opzioni da menu: Message→Delete Body

Scorciatoia da tastiera: Ctrl+Del
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Compacting databases

Il database può essere compattato sia manualmente che automaticamente.
Questa operazione serve a recuperare lo spazio che resta comunque
occupato dai messaggi eliminati con la cancellazione manuale o con
l’eliminazione automatica (purging). Nota: Generalmente non avrete bisogno
di effettuare manualmente la compattazione. La compattazione automatica
da effettuare assieme all’operazione di purging dovrebbe essere sufficiente.

Per compattare manualmente i files del database:

Selezionate File→Compact Databases. Agent controllerà il database per
verificare quanto spazio potrà essere liberato. Un messaggio vi mostrerà
quanto ne potrete recuperare, e potrete decidere se procedere o meno.

Per compattare automaticamente i files del database:

Aprite la scheda Group→Properties→When to Purge per visualizzare le
impostazioni.

Le opzioni per compattare il database sono le seguenti:

• After Manual purges – Selezionate questa opzione per compattare il
database ogni volta che effettuate l’operazione manualmente (Group→
Purge newsgroups).
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• When closing Agent – Selezionate questa opzione per compattare il
database alla chiusura di Agent.

• Compact only if wasted Space is at least... – Prima di compattare il
database, Agent controlla quanto spazio potrebbe essere liberato con la
compattazione. Questa impostazione vi risparmia un’operazione
potenzialmente esosa in termini di utilizzo della CPU, evitando di
sprecare tempo per liberare poco spazio su disco. Inserite la quantità
minima di spazio, in percentuale rispetto alla dimensione totale del
database, che farà eseguire una compattazione automatica sia dopo un
purging manuale sia dopo un purging alla chiusura di Agent.

• When closing Agent, Prompt for confirmation... – Selezionate questa
opzione per far sì che Agent chieda la conferma prima di effettuare il
purge e/o la compattazione del database al momento della chiusura del
programma. Se l’opzione non è selezionata, Agent effettuerà il purge e/o
la compattazione senza avvisarvi.

Stampare i messaggi
Definire le impostazioni di stampa:

Selezionate File→Print Setup per visualizzare la finestra di dialogo standard
per l’impostazione della stampante. Qui potrete specificare la stampante, il
tipo di carta e l’orientamento Portrait (ritratto - verticale) o Landscape
(paesaggio - orizzontale).

Definire le impostazioni di pagina:

Selezionate File→Page Setup per visualizzare la finestra di dialogo Page
Setup.
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Le impostazioni dei margini sono molto simili a quelle di una finestra di
dialogo standard per le impostazioni della pagina. Le altre impostazioni,
presenti solo in Agent, sono descritte di seguito:

1. Print raw (unformatted) message – Selezionate questa casella per
stampare il messaggio in formato grezzo (raw). Ciò significa che
verranno stampati tutti gli header (ad es., Path, From, Subject, Date,
etc.) ed il corpo del messaggio. Inoltre ogni file allegato nel messaggio
verrà stampato come una serie caratteri codificati.

2. Header Fields to Include – Selezionate quali campi dell’header volete
stampare con i messaggi.

3. Page Breaks – Selezionate dove volete l’interruzione di pagina.

Stampare messaggi singoli o multipli:

Selezionate nella lista dei messaggi quelli che volete stampare, poi
selezionate File→Print (o premete Ctrl+P).
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CAPITOLO 5

Comporre ed inviare messaggi
In questo capitolo prenderete confidenza con la Finestra di Composizione dei messaggi e
con le varie opzioni a disposizione per la scrittura e l'invio della posta. Sia nel caso della
composizione di un semplice messaggio di testo, sia nel caso di invio di un file di suono
allegato, Agent effettuerà l’operazione in modo indolore. Questo capitolo tratta i seguenti
argomenti:

1 Panoramica

1 Campi

1 Firme

1 Rubrica

1 Composizione del testo

1 Invio dei messaggi

Panoramica
Con Agent potete comporre vari tipi di messaggi. Qui di seguito la procedura
da seguire quando dovrete scrivere un qualsiasi messaggio.

1. Aprire la Finestra di Composizione  per il tipo di messaggio che volete
scrivere (per esempio un nuovo messaggio email) usando sia i pulsanti della
barra degli strumenti sia da menu Post→New Email Message sia la
Scorciatoia da tastiera CTRL+M

2. Inserire un indirizzo. Nei i messaggi Usenet, Agent inserisce
automaticamente nel campo Newsgroups il gruppo correntemente
selezionato. Con le email (eccezione fatta per i follow-up), dovrete inserire un
indirizzo nel campo To.

Se l’indirizzo da inserire si trova nell’Address Book di Agent, basta

premere il pulsante Pick Address  [scegli indirizzo] nella Finestra di
Composizione e selezionare un indirizzo dall’elenco.

Per
informazioni sui
tipi di
messaggio vai
a pagina 119.

Cfr.
"Selezionare un
indirizzo" a
pagina 132
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3. Inserire il subject (solo per i nuovi messaggi). Scrivere una breve
descrizione che illustri il contenuto del messaggio. Quando si scrivono
messaggi di risposta (reply), Agent inserisce automaticamente il
soggetto preceduto da "Re:", indicando che state dando una risposta
(vedere l’esempio qui sotto).

4. Inserire il testo del messaggio. Scrivete il testo del vostro messaggio
nel riquadro Text.

5. Inserire gli allegati. Premere il pulsante  ed utilizzare la
finestra di dialogo Attachments per allegare il file (per esempio, un
immagine GIF) al vostro messaggio.

6. Inviare il messaggio. Avete le seguenti opzioni:

• Invia ora (Send Now) , Ctrl+N, o Message→Send Now

• Invia più tardi (Send later) , Ctrl+L, o Message→Send Later

Nota: Per salvare il messaggio senza inviarlo, premere , Ctrl+S,
o Message→Save.

Tipi di messaggi che potete inviare

Potete inviare otto tipi di messaggi. Per aprire la rispettiva Finestra di
Composizione, selezionare l’opzione appropriata da menu Post, dalla barra
degli strumenti, o con la Scorciatoia da tastiera.

New Usenet Message  Post→New Usenet Message è usato per creare un nuovo
messaggio da inviare nel newsgroup correntemente selezionato. Agent inserisce
automaticamente il nome del newsgroup nel campo Newsgroups .

Pulsante della barra degli strumenti:

Scorciatoia da tastiera: P
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Follow-Up Usenet Message  Post→Follow-Up Usenet Message è usato per scrivere la
risposta al messaggio del Newsgroup correntemente selezionato. Agent inserisce
automaticamente il Newsgroup a cui state inviando il post di replica e il soggetto preceduto da
"Re:" ad indicare che è una risposta.

Pulsante della barra degli strumenti
Scorciatoia da tastiera: F

New Email Message  Post→New Email Message è usato per creare un nuovo messaggio
email.

Pulsante della barra degli strumenti
Scorciatoia da tastiera: Ctrl+M

Reply via Email Post→Reply via Email è usato per spedire una email in risposta al
messaggio selezionato. Agent inserisce automaticamente l’indirizzo del destinatario ed il
subject, preceduto da “RE:” ad indicare che è una risposta.

Pulsante della barra degli strumenti
Scorciatoia da tastiera: R

Reply to All Post→Reply to All è usato per inviare una risposta a tutti i destinatari del
messaggio originale.

Pulsante della barra degli strumenti
Scorciatoia da tastiera: Shift+R

Forward Quoted Post→Forward Quoted è usato per creare una email che contiene il
testo del messaggio correntemente selezionato. Agent inserisce automaticamente le righe del
testo originale precedute dal segno di citazione (per esempio, ">"), così come inserirà il subject
preceduto da "[fwd]", in modo che il destinatario capisca che si tratta di un messaggio inoltrato.

Pulsante della barra degli strumenti
Scorciatoia da tastiera: Alt+P+W

Forward Unquoted Post→Forward Unquoted è usato per creare una email che contiene
il testo del messaggio correntemente selezionato. Diversamente da Forward Quoted, il testo non
è preceduto dal marcatore di citazione. Agent inserisce automaticamente il subject preceduto da
"[fwd]", in modo che il destinatario capisca che si tratta di un messaggio inoltrato.

Pulsante della barra degli strumenti

Scorciatoia da tastiera: Alt+P+N

Forward Verbatim Post→Forward Verbatim è usato per creare un nuovo messaggio
email in cui il messaggio selezionato viene automaticamente allegato. Agent inserisce
automaticamente il subject del messaggio selezionato, preceduto da "[fwd]", in modo che il
destinatario capisca che si tratta di un messaggio inoltrato.
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Pulsante della barra degli strumenti

Scorciatoia da tastiera: Alt+P+V

Nota: Per ognuna delle opzioni Forward, potete cambiare il prefisso "[fwd]" in Options→Posting
Preferences→General e modificare Subject for forwarded messages.
_____________________________________________________________

OO Per default, ogni volta che selezionate Reply o Forward, Agent
includerà il testo del messaggio originale nel riquadro Text: della
Finestra di Composizione. Questa operazione è chiamata citazione
del testo originale. Comunque se selezionate una parte del
messaggio originale, Agent includerà solo il testo che avete
selezionato.

Quando si effettua un Reply o un Forward, Agent cita l’intero testo
escluse le righe che seguono l’ultima occorrenza dei caratteri “--” o “-
- “ (trattino trattino o trattino trattino spazio). Questo serve ad evitare
di includere lunghe signature, citando solo il testo del messaggio.
Cfr. pag. 195 (delimitatore di firma) per maggiori informazioni su
questa caratteristica, incluso il modo per disattivare questa opzione.

_____________________________________________________________

Troverete che la Finestra di Composizione è abbastanza simile per i
differenti tipi di messaggi. Di seguito viene mostrata la Finestra di
Composizione per un Nuovo Messaggio Usenet.
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Ed ora come appare la Finestra di Composizione per un Nuovo Messaggio
Email.
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Campi
Avete a disposizione un certo numero di campi da utilizzare nella Finestra di
Composizione oltre a quelli predefiniti To, Newsgroups, Subject, così che il
vostro messaggio potrà essere preparato e spedito nel modo che riterrete
opportuno.

Per rendere visibili tutti i campi disponibili nella Finestra di
Composizione:

Premete , o tramite la scorciatoia da tastiera Ctrl+D o
Message→All Fields. Usate il metodo che vi risulta più facile.

Qui sotto vedete l’elenco dei campi (Fields) posizionato al centro della
Finestra di Composizione, ed una descrizione per ogni tipo di campo. Per
impostare o scegliere il valore per ogni campo dovrete selezionarlo <Fields:>
e poi digitare il nuovo valore in Value for <field>.

Nota: Selezionate Use Defaults se desiderate utilizzare i valori predefiniti
nella scheda Group→Properties→Post. Selezionare questa opzione può
essere d’aiuto se cambiate il valore di un campo e decidete in seguito di
ripristinare i valori predefiniti.

Bcc – Inserite gli indirizzi email (separati dalle virgole) delle persone che riceveranno
una copia del messaggio senza che i destinatari principali (quelli inseriti nei campi To
e Cc) ne siano a conoscenza.

Cc - Inserite gli indirizzi email (separati dalle virgole) delle persone che riceveranno
una copia del messaggio.

Distribution - (solo per i messaggi Usenet) Questo campo controlla in quali zone
verrà distribuito il vostro messaggio. Per esempio inserendo in questo campo “Italia”,
il messaggio verrà distribuito ai soli server residenti in Italia. Perché questa opzione
funzioni  correttamente occorre la cooperazione dei provider Internet (ISP) che
gestiscono i news server, ed il suo impiego non è mai stato molto diffuso. Potete
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chiedere informazioni al vostro provider circa l’utilizzo che i suoi server fanno di
questo campo.

Per inserire varie zone separatele con delle virgole (come nel campo Newsgroups). Il
messaggio verrà inviato ai server che ospitano il newsgroup sottoscritto nelle zone da
voi indicate.

Il server ricevente quindi deve poter ricevere sia il newsgroup specificato, che la zona
di distribuzione impostata.

Per esempio, un messaggio che riguarda la vendita di una moto nel Golfo dei Poeti
includerà nell’intestazione i seguenti campi:

Newsgroups: it.annunci.usato.motociclismo,it.annunci.usato
Distribution: sp

per cui il precedente messaggio verrà distribuito agli utenti Usenet che hanno
sottoscritto i newsgroup it.annunci.usato.motociclismo o
it.annunci.usato nella zona di La Spezia.

Un messaggio follow-up avrà per default la stessa zona di distribuzione di quello
originale.

Expires - (solo per i messaggi Usenet) Impostate la data oltre la quale il messaggio
non dovrà più essere diffuso.

Followup-To - (solo per i messaggi Usenet) Indicate i newsgroup cui inviare le
risposte al vostro messaggio. Nota: Inserendo in questo campo "poster", fate in modo
di ottenere risposte personali, via email.

From – Inserite il vostro indirizzo email e, se volete, il vostro nome per esteso.

Keywords – Parole chiave, opzionali, per favorire la catalogazione dei messaggi.

Organization - (solo per i messaggi Usenet) La vostra azienda, scuola, etc.

Reply-To – Inserite l’indirizzo a cui gli utenti dovranno indirizzare le risposte. Se
volete che le risposte vi arrivino allo stesso indirizzo del campo From lasciate questo
campo vuoto.

Sender – È il nome del responsabile dell’invio del messaggio nella rete.
Normalmente questo campo è vuoto per indicare che il responsabile è la stessa
persona indicata nel campo Form. Per esempio, se Mario Rossi va a trovare Paolo
Bianchi e desidera inviare una email, Paolo potrà temporaneamente impostare il
campo Sender con il proprio indirizzo email ed impostare il campo From con
l’indirizzo email di Mario per indicare che il messaggio è stato inviato da Paolo per
conto di Mario.

Summary - (solo per i messaggi Usenet) Una descrizione opzionale del messaggio.
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Firme
La signature (firma) consiste in una o più linee di testo che verranno
automaticamente aggiunte da Agent in fondo al messaggio che verrà inviato.
Quando create un messaggio, potete selezionare da una lista di firme quella
che meglio si adatta al messaggio che state scrivendo. Per esempio potete
definire firme per uso personale e per l’ufficio.
_____________________________________________________________

OO Potete definire tutte le firme che desiderate. Si consiglia di impostare
per default quella che utilizzate più frequentemente.

_____________________________________________________________

Inserimento della firma nel messaggio:

Ci sono due modi per inserire la vostra firma nel messaggio.

• Selezionate la firma nella lista che appare cliccando su Signature: nella
Finestra di Composizione del messaggio. Agent inserirà
automaticamente la firma selezionata alla fine del messaggio. La firma
selezionata non apparirà nella Finestra di Composizione, ma verrà
aggiunta nel momento in cui il messaggio verrà inviato.

• Mentre scrivete il messaggio, selezionate Edit→Paste Signature, poi
selezionate la firma desiderata dalla finestra di dialogo Paste Signature.
La firma verrà inserita nel punto in cui si trova il cursore. Questo metodo
ha il vantaggio di farvi visualizzare come apparirà esattamente la firma
nel messaggio. Quando utilizzate questo metodo Agent non inserirà in
modo automatico la firma indicata nell’elenco Signature: della Finestra di
Composizione.

Creare una firma per i messaggi:

Selezionate la scheda Options→Posting Preferences→Signatures  per
visualizzare la seguente finestra di dialogo:
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Completate le impostazioni della scheda Signatures , come descritto di
seguito:

1. Names – Ogni nome contenuto in questo riquadro corrisponde ad una
firma che avete precedentemente inserito utilizzando la finestra di
dialogo Add Signature (vedi il punto 2. Add).

2. Add – Premete questo pulsante per visualizzare la finestra di dialogo
Add Signature ed inserite quindi un nuovo nome che apparirà nell’elenco
Names.

3. Rename – Premete questo pulsante per modificare il nome
correntemente selezionato nel riquadro Names.

4. Delete – Premete questo pulsante per eliminare la firma selezionata nel
riquadro Names.
__________________________________________________________

OO Se cancellate accidentalmente una firma, premete il pulsante
Cancel per chiudere la finestra di dialogo e perdere tutte le
modifiche.

__________________________________________________________
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5. Default Signature – Selezionate la firma che desiderate utilizzare come
predefinita. Selezionate [None]  se non volete utilizzare nessuna firma
predefinita. Quando inviate un messaggio Agent utilizza
automaticamente la firma predefinita. Potete scegliere una firma
predefinita differente per ogni gruppo o sovrascrivere la firma utilizzata
per uno specifico messaggio, utilizzando l’elenco Signature nella
Finestra di Composizione.

Nota: Cambiando la firma predefinita cambiate anche le impostazioni
della firma nella scheda Group→Properties→Post.

6. Text – Scrivete qui il testo della firma, quello che volete sia accluso in
calce al messaggio quando selezionate il relativo nome nell’elenco
Names. Se volete che appaia un separatore tra il resto del messaggio e
la firma, dovete includerlo ora. È uso comune iniziare la firma con due
trattini seguiti da uno spazio, come mostrato di seguito:
--<inserite qui uno spazio, senza parentesi angolari>
Mark Prince
Forté Support

7. Use Existing File – Se utilizzate la stessa firma con programmi diversi,
inserite il nome del file che contiene la firma. Dopo aver inserito un nome
di file valido, nel riquadro Text verrà mostrato il contenuto del file (punto
6. Test).

Nota: Ogni modifica che effettuerete alla firma in questa finestra di
dialogo, verrà salvata nel file, per cui le modifiche si ripercuoteranno su
tutti i programmi che utilizzano lo stesso file.

8. Browse – Premete questo pulsante per cercare il file contenente la
firma.

Rubrica
Con un semplice click del mouse potete aprire la rubrica di Agent, in cui
potete inserire gli indirizzi email più utilizzati. In questo modo evitate di dover
ricordare ogni dettaglio dei singoli indirizzi. Basta utilizzare un nome o un
alias (pseudonimo) al posto dell’indirizzo, ed Agent farà il resto.

Aprire la Rubrica di Agent:

Selezionate Window→Open Address Book per visualizzare la finestra
Address Book.
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Questa finestra contiene:

L’elenco dei nomi (o pseudonimi) che potete utilizzare quando componete i
messaggi.

L’indirizzo email associato al nome correntemente selezionato.
Commenti (facoltativi) che descrivono il nome correntemente selezionato.

Il campo Field Text (facoltativo) per l’utilizzo con le mailing lists (cfr. pagina
131).

Per creare e modificare i nomi della rubrica, selezionate le opzioni nel menu
Address o i pulsanti della barra degli strumenti.

Utilizzare il menu Address

Potete selezionare sia Address dalla barra dei menu (la finestra Address
Book deve essere già aperta), sia il mouse, portando il puntatore nel riquadro
Names della rubrica e facendo click destro.



Usare gli allegati

129

Selezionate questa
voce ...

... per …

New inserire un nuovo nome con un indirizzo associato.

Rename modificare un nome esistente.

Delete eliminare il nome selezionato dalla rubrica.

Save salvare le modifiche apportate al nome o all’indirizzo.

Reset annullare le modifiche apportate su Addresses  e Comments
se desiderate tornare allo stato originale senza salvare le
modifiche.

To, Cc, Bcc inserire il nome selezionato nella Finestra di Composizione.

Nota: Premendo Shift mentre selezionate questa voce
comunicate ad Agent di inserire l’indirizzo al posto del nome.
Premere Enter o effettuare un doppio click su di un nome
equivale a scegliere la voce To.

Check Addresses far controllare ad Agent la sintassi di un indirizzo per essere
sicuri di aver inserito una struttura valida
(nome@dominio.xxx).

Confirm Edits/
Confirm Deletes

impostare Agent in modo che richieda la conferma per la
modifica o l’eliminazione di un indirizzo.

Expand Addresses espande un indirizzo nel formato esteso nel momento in cui
viene inserito nella Finestra di Composizione.

Per Inserire un nuovo indirizzo nella rubrica;

Per ogni indirizzo che usate frequentemente  - selezionate Address→New
quando la finestra Address Book è aperta.

Per inserire gli autori di un messaggio già esistente - selezionate il
messaggio, quindi selezionate Message→Add Author to the Address
Book . L’indirizzo nel campo From del messaggio verrà inserito nel
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campo Address. Se l’indirizzo include anche il nome dell’autore, Agent lo
inserirà nel campo Name. Potete inserire dei commenti a vostro
piacimento.

In entrambi i casi, verrà aperta la finestra di dialogo New Address. Di seguito
un esempio della finestra di dialogo con i campi compilati.

Creare una Mailing Lists

La finestra di dialogo New Addresses può essere utilizzata anche per creare
le mailing list. Nelle mailing list l'indirizzo è quello scelto da voi anziché
l'intera lista dei destinatari. In questo modo evitate sprechi di spazio e allo
stesso tempo assicurate la privacy dei destinatari. Ecco come lavora:

1. Name – Inserite un nome per la mailing list che volete creare (per
esempio, Elenco di destinatari)
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2. Addresses – Inserite l’indirizzo email di ogni destinatario da inserire
nella mailing list, separato da una virgola o da un invio.

3. Field Text – Inserite un indirizzo email valido. Facendo riferimento
all’esempio del punto 1. potete inserire:

" Elenco di destinatari <lista@amici.it>"

Questo è l’indirizzo che i destinatari vedranno nel campo To dei
messaggi che riceveranno. Se non inserite nulla nel campo text, tutti i
destinatari vedranno gli indirizzi di tutti gli altri. Questo campo vi permette
di nascondere l’elenco dei nomi, così che ogni destinatario vedrà solo
l’indirizzo da voi introdotto.

Nota: Field Text deve contenere un indirizzo email valido, in quanto
apparirà nell’intestazione del messaggio. Alcuni mail server possono
rifiutare i vostri messaggi se contengono un campo con un indirizzo
email non valido.

N.d.t. Come si vede dall’esempio l’indirizzo introdotto deve essere valido. Quindi
potete inserire qualsiasi cosa che risponda alla regola nome@dominio.xxx

Potete decidere di inserire l'indirizzo a cui i destinatari della vostra
mailing list dovranno inviare le risposte. Per esempio potete inserire nel
campo From:

La mia lista <reply-here@my.company.com>

_____________________________________________________________

OO Se volete unire diverse mailing list e visualizzare un singolo indirizzo
nel campo To:, potete specificare l’indirizzo nel campo Field Text di
un’unica mailing list e lasciare vuoti quelli delle altre. Per eliminare gli
indirizzi del campo Field Text delle rimanenti mailing list, basta
sovrascriverli con uno spazio. Agent svuoterà automaticamente i
campi.

Importante! Se nella rubrica utilizzate l’opzione Expand Addresses nel
momento in cui inserite la mailing list nella Finestra di Composizione,
Agent inserirà tutti gli indirizzi dei destinatari senza utilizzare l’indirizzo
del campo Field Text. Agent vi avvertirà di quanto sta per succedere
per verificare se volete realmente espandere gli indirizzi.

_____________________________________________________________

Trovare un indirizzo

Se avete in mente un nome che è al di fuori di ciò che è visibile nell’elenco
Names , potete saltare direttamente sul nome desiderato utilizzando Find.
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Selezionate Edit→Find e verrà visualizzata la finestra di dialogo Find
Address.

Potete effettuare ricerche per ognuno dei componenti della rubrica, inclusi
Name, Address, e Comments.

Per esempio per trovare l’agenzia di viaggio utilizzata dalla vostra azienda,
ma non conoscete ne il nome ne l’indirizzo, selezionate Look in: Comments
ed inserite agenzia di viaggio nel riquadro Find What. Quindi utilizzate il
pulsante Find First ed Agent selezionerà la prima ricorrenza di agenzia di
viaggio.

Nota: Nel caso di ricorrenze multiple utilizzate il pulsante Find Next sino a
trovare il nome desiderato.

Selezionare un indirizzo

Quando editate un nuovo messaggio potete selezionare uno o più nomi dalla
rubrica per inserirli automaticamente in uno dei seguenti campi nella Finestra
di Composizione:

To

Cc

Bcc

La procedura per selezionare gli indirizzi è semplice. Di seguito vi
spieghiamo come fare.

Per selezionare un indirizzo:
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Utilizzate il pulsante Pick Addresses  nella Finestra di Composizione per
visualizzare la finestra di dialogo Pick Addresses. Qui vengono elencati tutti i
nomi inseriti nella rubrica.

Nota: Di seguito due modi equivalenti per aprire la finestra di dialogo Pick
Address.

Menu: Message→Pick Addresses

Scorciatoia da tastiera: Ctrl+K

Di seguito viene spiegato come utilizzare le opzioni della finestra di dialogo
Pick Addresses:

1. Names – Selezionate i nomi che volete inserire in uno dei campi per gli
indirizzi della Finestra di Composizione.
__________________________________________________________

OO Digitate le prime lettere di un nome per selezionarlo velocemente.
__________________________________________________________

2. To/Cc/Bcc – Utilizzate uno di questi tre pulsanti per aggiungere il nome
o i nomi selezionati nei campi To, Cc, o Bcc della Finestra di
Composizione.
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__________________________________________________________

OO Se premete Shift mentre utilizzate i pulsanti To, Cc, or Bcc
inserirete, nei rispettivi campi, gli indirizzi al posto dei nomi.

Inoltre, un doppio click su un nome equivale a premere il pulsante
To.

__________________________________________________________

3. Find – Utilizzatelo per aprire la finestra di dialogo Find e cercare quindi
un nome al di fuori dei nomi visualizzati nell’elenco Names. Vi tornerà
utile nel caso di rubriche con molti nomi.

4. Edit –Vi permette di editare il nome selezionato nell’elenco Names.
Verrà aperta la finestra Address Book, e il cursore verrà posizionato sul
nome precedentemente selezionato. A questo punto potrete modificare il
nome utilizzando le opzioni del menu Address.

5. Comments – Viene visualizzato il commento del nome selezionato.
Questa descrizione, non modificabile, vi aiuta a verificare se avete
trovato il nome che volevate. Per modificarlo utilizzate il pulsante Edit.

6. Expand addresses – Selezionate questa opzione se volete inserire
l’indirizzo del nome correntemente selezionato al posto del nome stesso
(per esempio, mario.rossi@acmeinc.com, al posto di Mario Rossi).

Convalidare gli indirizzi

Agent ha la caratteristica di poter controllare se l’indirizzo da voi inserito ha
un formato valido. Durante la convalida Agent controlla i seguenti
componenti di un indirizzo:

i caratteri che identificano chi ha inviato il messaggio

il simbolo "@"

il suffisso del dominio (per esempio, il nome di un’azienda è seguito
dall’estensione .com, il nome di una scuola è seguito
dall’estensione.edu).

Per esempio:

mrossi@miolavoro.com

A volte è necessario utilizzare indirizzi locali che vengono considerati validi.
Se il vostro ISP è impostato per riconoscere gli indirizzi locali potete
indirizzare un messaggio al nome della persona. Per cui al posto di
mrossi@miolavoro.com potete semplicemente inserire come indirizzo
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mrossi, purché Agent sia impostato per riconoscere l’indirizzo locale come
valido.

Impostare Agent per riconoscere gli indirizzi locali della Rubrica:

Selezionate Options→Posting Preferences→General tab. Quindi selezionate
l’opzione Require that local addresses be in Address Book. Agent ora vi
avvertirà ogni volta che inserirete un indirizzo, non presente in rubrica, senza
il carattere "@". Deselezionando questa opzione forzerete Agent ad
accettare il nome come indirizzo locale.

Controllare la validità di un indirizzo:

Una qualsiasi delle seguenti azioni avvierà il controllo di validità dell’indirizzo.

Premete il pulsante Send o Send Later della Finestra di Composizione (se
l’opzione Validate email addresses box è selezionata).

Selezionate Message→Check Addresses mentre la Finestra di
Composizione è aperta.

Salvate un nome nella finestra Address Book.

Selezionate Address→Check Addresses quando la finestra Address Book è
aperta.

Premete il pulsante OK nella finestra di dialogo Add Address.

Premete il pulsante Check Addresses nella finestra di dialogo Add Address.

Espansione degli indirizzi

Quando Agenti si prepara ad inviare un messaggio, controlla il contenuto
campi To, Cc, e Bcc per produrre un elenco completo dei destinatari con gli
indirizzi completamente espansi. Per ogni nome presente nella rubrica Agent
sostituirà l’indirizzo abbinato al nome stesso.

_____________________________________________________________

OO Agent controlla i riferimenti presenti nella rubrica. Se un indirizzo è
utilizzato più di una volta, Agent semplicemente lo utilizzerà una sola
volta.

_____________________________________________________________

Importare gli indirizzi

Agent è in grado di importare una rubrica di altri programmi, così da non
costringervi a scrivere nuovamente tutti i nominativi. Gli indirizzi devono
essere convertiti e salvati in un file che Agent possa importare. Per
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convertire i dati, utilizzate il programma di conversione appropriato per per il
tipo di rubrica che state importando. Controllate i dettagli contenuti nel file .txt
per ogni tipo di convertitore. (I convertitori sono disponibili presso il server ftp
della Forté, ftp.forteinc.com/pub/converters.) Per importare gli indirizzi,
selezionate File→Addresses→Import, e specificate il percorso ed il nome del
file che contiene gli indirizzi che desiderate.
_____________________________________________________________

OO Si raccomanda di utilizzare l’estensione ".txt" per il file di interscambio
della rubrica.

_____________________________________________________________

Allegati
A volte potreste voler inserire un file grafico o un altro tipo di allegato al
vostro messaggio. Agent rende molto semplice allegare ogni tipo di file (es.
un’immagine GIF) al vostro messaggio. Ecco come:

Allegare un file durante la compsizione di un messaggio:

Premete il pulsante Attachments per visualizzare la finestra di dialogo
relativa agli Allegati. Quindi premete Add e specificate il percorso ed il nome
del file che volete allegare, come mostrato nell’esempio sotto.

Per maggiori
dettagli
rigurdo gli
allegati,
vedere il
Capitolo 6,
"Utilizzo degli
Allegati .”
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Altre Informazioni Relative Al Testo
Con Agent è possibile sistemare il testo nel messaggio che avete composto
per far sì che il destinatario, a seconda del sistema che utilizza, veda
comunque il corpo del messaggio esattamente nel modo in cui volevate
fosse visto. Questa sezione evidenzia i differenti settaggi che Agent fornisce
per controllare il modo in cui il testo appare nei messaggi che scrivete. Per
ulteriori dettagli relativi al modo in cui il messaggio viene visualizzato, vedere
il Capitolo 4, Tutto sui messaggi ed il capitolo 8, Personalizzazione di Agent.

Opzioni di composizione

Agent è preconfigurato di modo che possiate comporre ed inviare messaggi
con minimo sforzo e senza difficoltà. Normalmente, tutto ciò che dovete fare
è scrivere il vostro messaggio e premere il pulsante Send Now. In
determinate situazioni, comunque, potreste voler modificare le impostazioni
predefinite di Agent relative alla posta nel caso sappiate che il programma
utilizzato dal destinatario necessita di particolari accorgimenti per
visualizzare correttamente il messaggio. Ecco cosa occorre fare:

Per specificare differenti preferenze relative alla posta:

Selezionare la scheda Options→Posting Preferences→General. Sotto
trovate le impostazioni predefinite che verranno mostrate.
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Potete modificare tutte queste impostazioni, nel modo seguente:

1. Word-wrap quoted-printable messages – Selezionate questa casella
per far sì che Agent utilizzi la funzione di A capo automatico nei
messaggi "quoted-printable". Deselezionate questa opzione per evitare
l’a capo automatico.

2. Line Length – Inserite la lunghezza massima della singola riga, in
numero di caratteri. Agent applicherà l’a capo automatico su tutte le
righe più lunghe del numero specificato.

3. Validate email address – Selezionate questa casella se volete che
Agent controlli tutti i campi contenenti indirizzi email (ad es. To:, Cc:,
Bcc) prima di inviare i messaggi. Deselezionate la casella se avete
bisogno di inserire indirizzi in formato diverso dallo standard.

 Nota: Agent non verifica che l’indirizzo email esista. Semplicemente ne
controlla il formato per accertarsi che sia un indirizzo Internet valido.

4. Require that local addresses be in Address Book – I "Local
addresses" sono pratici per spedire email a persone appartenenti al
vostro stesso “dominio”, come ad esempio in una rete di computer di
un’azienda. Ma Agent non è in grado di riconoscere un indirizzo locale
da un indirizzo inserito in rubrica.
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Per aiutare Agent, selezionate questa casella ed Agent vi avviserà
quando non è in grado di trovare un indirizzo locale nella Rubrica. A
questo punto potrete correggere l’indirizzo se è stato scritto
erroneamente, oppure dire ad Agent di accettare l’indirizzo come locale.

Se deselezionate la casella, per Agent l’indirizzo è locale se non include
il carattere "@" e non è inserito nella Rubrica.

_____________________________________________________________

OO La maggior parte delle volte , probabilmente manterrete questa
opzione selezionata. Nel caso vogliate forzare Agent a riconoscere un
indirizzo come locale, potrete semplicemente aggiungervi "@" alla fine
(es., gbrown@).

_____________________________________________________________

5. Saving message also Closes Composition window – Quando
selezionate questa opzione, premendo il pulsante Save sulla finestra di
Composizione messaggi otterrete anche la chiusura della finestra
stessa. Se l’opzione è deselezionata, la pressione del pulsante Save
causerà il salvataggio del messaggio, ma non chiuderà la finestra di
Composizione.

6. Follow-up crosspost action – E’ possibile dire ad Agent come
comportarsi ogni volta che viene spedito un messaggio di news a più di
un gruppo. Sono possibili le seguenti opzioni:

• Spedisce la risposta a tutti i newsgroup
• Spedisce la risposta solamente ai newsgroup selezionati
• Richiede come comportarsi ogni volta che viene inviata una risposta,

in modo che possiate scegliere come comportarvi volta per volta.

7. Include original text in follow-ups and replies – Selezionate questa
casella per inserire una copia del testo originale nelle risposte e nei
messaggi seguenti.

8. Prefix for quoted lines – Per i follow-up ed i messaggi di risposta,
inserite il carattere/i che devono precedere il testo citato (come metodo
per distinguerlo da quanto viene scritto).

9. Quoted – Questa è la stringa che appare nel Subject del vostro
messaggio quando viene selezionato Post→Forward Quoted.

10. Unquoted - Questa è la stringa che appare nel Subject di un messaggio
quando viene selezionato Post→Forward Unquoted.
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11. Verbatim - Questa è la stringa che appare nel Subject del vostro
messaggio quando viene selezionato Post→Forward Verbatim.

_____________________________________________________________

OO La stringa predefinita  per le impostazioni 9, 10, e 11 è
"[fwd]%subject%". La parte "[fwd]" della stringa indica che si tratta di
un messaggio inoltrato. Potete modificarla come volete (es.,
"messaggio inoltrato").

La parte "%subject%" rappresenta il subject del messaggio originale.
Agent sostituisce "%subject%" con il testo del subject originale quando
componete il nuovo messaggio. Al posto di "subject", potete utilizzare
un qualsiasi nome di campo valido, ed il valore di quel campo verrà
inserito nella stringa.

_____________________________________________________________

Incollare testo come citazione

A volte, scrivendo una risposta ad un messaggio, potreste voler riportare
alcune parti del testo dal messaggio originale. Con Agent, questo è possibile
con due passaggi.

Inserire il testo come citazione:

1. Selezionate la parte di testo che volete inserire come testo citato, quindi
copiate il testo, utilizzando uno dei seguenti metodi, equivalenti fra loro:

Pulsante sulla barra degli strumenti:  (barra della finestra di Composizione)

Opzione di menu: Edit→Copy

Accesso rapido da tastiera: Ctrl+C

2. Aprite una nuova finestra di composizione e posizionate il cursore nel
riquadro Text. Quindi utilizzate uno dei seguenti metodi equivalenti per
incollare il testo in modo che appaia citato:

Pulsante sulla barra degli strumenti:  (barra della finestra di Composizione)

Opzione di menu: Edit→Paste As Quote

Accesso rapido da tastiera: Ctrl+Q
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Ogni riga del testo apparirà preceduta dal carattere di citazione definito
nella scheda General in  Posting Preferences (menu Options). Per
esempio:

> Ask not what your country can do for you.
> Ask what you can do for your country.

Controllo Ortografico

Agent controllerà l’ortografia di ogni messaggio che verrà composto. Alla
prima installazione di Agent, il dizionario Inglese Americano viene utilizzato
come predefinito per il controllo ortografico. E’ comunque possibile scaricare
dizionari in altre lingue quando scaricate i file di Agent dal sito FTP della
Forté per installare il programma la prima volta. L’indirizzo ftp è il seguente:

ftp.forteinc.com/pub/dictionaries

Per ogni lingua ci sono un file TLX (dizionario generale) e un file CLX
(dizionario personalizzato) al quale potete aggiungere vocaboli non presenti
nel dizionario generale). Ripristinate l’appropriato file zip nella cartella in cui
risiede Agent. I possibili dizionari sono:
• engamer.zip (Inglese Americano)

• engintl.zip (Inglese Internazionale)

• french.zip (Francese)

• german.zip (Tedesco)

• italian.zip (Italiano)

• spanish.zip (Spagnolo)

Come eseguire il controllo ortografico su di un messaggio che avete
composto:

Selezionate Message→Spelling oppure premete F7.

Come specificare un differente dizionario per il controllo ortografico:

1. Per prima cosa, assicuratevi che sia stato definito esattamente il
correttore ortografico per la lingua selezionata. Selezionate la scheda
Options→General Preferences→Languages. Selezionate la lingua, poi il
correttore ortografico per quella lingua.

2. Ora impostate questa lingua come predefinita. Se volete utilizzare
questa lingua (ed i suoi controlli ortografici) per tutti i gruppi ed anche
quando scrivete un messaggio, selezionatela nella scheda
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Group→Default Properties→Language. Se invece la volete utilizzare
solo per alcuni gruppi, selezionate i gruppi che volete ed utilizzate la
scheda Group→Properties→Language.

3. Per utilizzare un differente dizionario per effettuare il controllo su un
messaggio che state scrivendo, aprite la finestra Message→Properties e
scegliete la lingua desiderata.

Altre Informazioni Sull’Invio Dei
Messaggi

Questa sezione va oltre gli elementi fondamentali sull’invio dei messaggi,
indicati nella precedente Panoramica, ed illustra varie preferenze ed opzioni
disponibili per l’invio dei messaggi.

Impostazione delle preferenze per il formato dell’invio

Agent vi consente di specificare il formato dei messaggi che state inviando.
Esistono due formati in cui potete inviare messaggi di testo: "quoted-
printable" e "7bit / 8bit". Potete decidere quale è il formato più appropriato
per i vostri messaggi Usenet e email.

Quoted-printable supporta i caratteri internazionali (ad es., le lettere
accentate) tramite lo standard di trasferimento posta "MIME" (Multipurpose
Internet Mail Extensions).

codifica di testo a 7bit / 8bit è l’altro tipo di codifica del testo comunemente
utilizzato per inviare messaggi su Usenet.

_____________________________________________________________

OO Quando inviate messaggi a destinatari con sistemi in grado di gestire il
MIME, il formato quoted-printable è il migliore per codificare i vostri
messaggi. Non dovrete mai preoccuparvi di paragrafi troncati in
maniera strana.

Se state inviando messaggi a destinatari che non gestiscono il MIME
(es. utenti di America Online) o se state inviando messaggi ad un
newsgroup dove lo standard quoted-printable non è ancora accettato,
il miglior formato da utilizzare è quello a 7bit / 8bit.

_____________________________________________________________
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Vantaggi del formato quoted-printable rispetto a quello 7bit / 8bit:

Se siete certi che il sistema del destinatario del messaggio gestisce MIME,
questa è la situazione ideale. MIME è lo standard riconosciuto
internazionalmente per il trasferimento di dati. Il formato Quoted-printable
(MIME) ha alcuni chiari vantaggi rispetto a quello 7bit / 8bit:

• Quoted-printable previene i problemi di trasferimento. Utilizzando solo 7
bit per codificare caratteri a 8 bit, aiuta ad assicurare che le informazioni
non verranno perse quando i messaggi saranno trasferiti attraverso
sistemi a 7 bit.

• Quoted-printable codifica correttamente caratteri non-ASCII (come le
accentate ed altri caratteri usati in varie lingue).

• Quoted-printable consente di avere linee di testo di lunghezza arbitraria.
Inserisce automaticamente dove necessario delle interruzioni di riga
invisibili al fine di mantenere la lunghezza fisica delle righe all’interno dei
limiti prescritti dal programma di lettura dei messaggi.

Come impostare le preferenze generali per la formattazione del testo:

1. Selezionate la scheda Options→General Preferences→Languages.
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2. Per ciascuna lingua presente nella lista Languages, selezionate 7bit /
8bit oppure Quoted printable (MIME) come formato per il testo dei
messaggi Usenet ed email.

Come non tener conto del formato predefinito per singoli messaggi:

1.  Mentre siete nella finestra di Composizione, selezionate
Message→Properties per aprire la finestra relativa alle proprietà del
messaggio.

2. Selezionare la lingua per il messaggio (se diversa dalla lingua
predefinita), e selezionate la casella Override default settings, come
mostrato nell’esempio sotto.

3. Selezionate il formato preferito per il corpo del messaggio, sia 7bit / 8bit
che Quoted printable (MIME).

Preferenze relative all'a capo automatico:

Uno dei vantaggi del quoted-printable è che le linee di testo possono avere
qualsiasi lunghezza. Se avete scelto quoted-printable nelle preferenze,
Agent tratta il messaggio come un’unica lunga riga di testo. Inserisce ritorni a
capo invisibili dove necessario così che la riga compaia sempre
correttamente all’interno della finestra in cui è visualizzato il messaggio. Un
messaggio di testo in formato a 7bit /8bit, limita le righe alla lunghezza
specificata nelle Posting Preferences di Agent.

Impostare la lunghezza della riga per l’a capo automatico:

Selezionare la scheda Options→Posting Preferences→General. Nella
casella Line Length, specificare il numero massimo di caratteri per riga.
Notate che solamente le righe non citate vengono spezzate con un ritorno a
capo. Le righe di citazione (ad esempio nelle risposte in follow-up o nel
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forward) non vengono mai limitate al momento dell’invio, indipendentemente
dalle impostazioni di questa scheda.

Come attivare l’a capo automatico:

Scegliere tra le seguenti opzioni per mandare a capo il testo di un messaggio
che state scrivendo.

Pulsante sulla barra degli strumenti:

Opzione di menu: Message→Word Wrap

Accesso rapido da tastiera: Alt+M+O

Il testo nella finestra di Composizione verrà mandato a capo in modo da
adattarsi alle dimensioni della finestra.
_____________________________________________________________

OO La funzione word-wrap, qui, influenza esclusivamente l’aspetto del
messaggio sul vostro schermo. Quando inviate il messaggio, ogni riga
viene mandata a capo al valore indicato nella finestra di dialogo
Posting Preferences. Se lo schermo è abbastanza ampio, vedrete il
messaggio nello stesso modo in cui verrà inviato. Se lo schermo non è
abbastanza grande e volete vedere come apparirà il messaggio
quando verrà inviato, deselezionate l’opzione word-wrap dalla finestra
di composizione.

_____________________________________________________________

Controllare lo stato di un messaggio

La cartella Outbox è uno spazio provvisorio in cui vengono immagazzinati i
messaggi fino al momento della loro spedizione. I comandi Send Later e
Save, nella finestra di composizione, inseriscono i messaggi nella Outbox.
Per default, anche il comando Send Now inserisce i messaggi in uscita in
questa cartella. In ogni caso, potete utilizzare la Outbox per verificare lo stato
di un messaggio dopo averlo inviato. E’ comunque preferibile che
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conserviate i messaggi inviati con successo in cartelle differenti dalla Outbox.
Qui di seguito viene illustrato come fare.

Per aprire la cartella Outbox:

Selezionate Window→Open Outbox. La finestra Outbox mostra tutti i
messaggi salvati, quelli in attesa di invio, quelli già spediti ed il loro stato
(vedi sotto).

Icona Descrizione

faccina rossa
triste

E’ intervenuto un problema in fase di invio del messaggio.
Fate doppio click per aprire il messaggio e assicurarvi che tutti
i campi siano compilati correttamente. Quindi premete il
pulsante Send Now oppure Send Later per rispedire il
messaggio.

faccina gialla
felice

Il messaggio è stato inviato con successo. Questa icona
potrebbe non apparire mai nella cartella Outbox se avete
impostato Agent per indirizzare automaticamente specifici
messaggi verso specifiche cartelle.

Il messaggio è in attesa di essere inviato (ad es., avete
premuto il tasto Send Later dopo aver composto un
messaggio). Per inviarlo immediatamente, selezionate
Online→Post Messages and Emails.

Il messaggio è in fase di spedizione.

Come archiviare in una cartella un messaggio inviato:

Potete spostare i messaggi manualmente o (preferibile), farli archiviare
automaticamente da Agent in una cartella a scelta quando vengono inviati
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con successo. Archiviando i messaggi in cartelle potrete utilizzare le
caratteristiche delle cartelle (ordinamento, stampa, viste differenziate e
reinvio dei messaggi) che non sono disponibili nella Outbox.

Per copiare o spostare i messaggi in una cartella, aprite la finestra di dialogo
Message→Copy to Folder o Message→Move to Folder e scegliete una
cartella. Se avete copiato il messaggio in una cartella, questo ora apparirà
sia nella Outbox che nella cartella selezionata. Se avete spostato il
messaggio in una cartella, questo non comparirà più nella Outbox, ma
solamente nella cartella selezionata.

Per far sì che Agent archivi automaticamente i vostri messaggi inviati,
selezionate la cartella desiderata dalla lista File sent Messages in folder:
presente sulla scheda Group→Properties→Post. Potete anche archiviare un
messaggio semplicemente visualizzando tutti gli header nella finestra di
composizione e selezionando la cartella desiderata dalla lista Filing.

Reinvio dei messaggi

Come descritto sopra, i messaggi che inviate possono essere archiviati nella
Outbox o in una cartella. La possibilità di reinviare messaggi dipende da
dove sono stati archiviati.

 Per reinviare un messaggio email da una cartella:

1. Assicuratevi che il messaggio inviato sia stato archiviato in una cartella e
non nell’ Outbox.

2. Visualizzate nel pannello Message List il contenuto della cartella e
selezionate il messaggio da rispedire.

3. Scegliete Post→New Copy of Message.

4. (Opzionale) Modificate il messaggio come preferite (ad es., modificate il
destinatario).

5. Premete Send Now o Send Later per inviare il messaggio. Nella cartella
avrete sia la copia del messaggio originale che la nuova copia del
messaggio appena inviato.

Per reinviare un messaggio email dall’ Outbox:

1. Dopo aver selezionato il messaggio nella Outbox, scegliete
Message→Open.

2. (Opzionale) Modificate il messaggio (ad es., inserite un destinatario
differente).



Capitolo 5

148

3. Premere Send Now o Send Later per reinviare il messaggio. Agent
mostrerà un avvertimento dicendo che il messaggio è già stato inviato, e
vi chiederà se volete inviarlo di nuovo. Premere OK per reinviarlo. Notate
che avrete solamente la nuova copia del messaggio inviato, in
sostituzione del messaggio originale nella Outbox.

Cancellare i messaggi di Usenet

A volte, dopo aver inviato un messaggio ad un newsgroup, potreste decidere
di volerlo far sparire da lì, poiché vi rendete conto che non doveva proprio
essere spedito. Agent vi consente di cancellare ogni messaggio Usenet che
avete inviato, ma non quelli inviati da altre persone .

Utilizzando l’opzione di cancellazione di Agent, viene inviata una richiesta di
cancellazione del messaggio al vostro news server. La stessa richiesta viene
inviata anche agli altri news server Internet di modo che possano anch’essi
cancellare il messaggio.

Cancellare un messaggio:

1. Selezionate l’header del messaggio che volete cancellare.

2. Selezionate Post→Cancel Message.

____________________________________________________________

OO È sufficiente cancellare un messaggio in crosspost da uno solo dei
gruppi cui è stato inviato.

_____________________________________________________________

3. Nella finestra di Composizione messaggi Usenet, premete Send Now o
Send Later per inviare il messaggio al vostro news server, senza
modificarlo in alcun modo.

Dopo aver inviato la richiesta di cancellazione, il messaggio continuerà ad
apparire in Agent finché non verrà automaticamente eliminato dalla funzione
purge o finché non lo cancellerete. Siccome alcuni server non accettano
richieste di cancellazione, potreste voler verificare che il messaggio sia stato
effettivamente cancellato.

Come verificare se il messaggio è stato cancellato:

1. Selezionate l’header del messaggio dopo aver spedito la richiesta di
cancellazione.

2. Eliminate il corpo del messaggio selezionando Message→Delete Body.
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3. Provate a recuperare di nuovo il corpo del messaggio selezionando
Online→Get Selected Message Bodies. Se la richiesta di cancellazione è
stata accettata, l’icona Message Body Not Available  apparirà accanto
al messaggio.

Utilizzo di MAPI

MAPI è uno standard Windows che definisce come i programmi Windows
inviano le email. Potete impostare Agent per inviare email con MAPI se state
utilizzando Agent per leggere e scrivere messaggi, ma volete che l’invio e
l’archiviazione siano  gestiti dal programma di posta in uso nel vostro
sistema.

Come impostare Agent per utilizzare MAPI:

1. Selezionate la scheda Options→User and System Profile→System.

2. Selezionate l’opzione Send email messages with MAPI.

Nota: dovete avere un sistema di posta abilitato alla gestione MAPI per
avere questa opzione disponibile. In altri casi l’opzione apparirà come
grigia.

Selezionando l’opzione Send email messages with MAPI ottenete i seguenti
effetti:

• Agent utilizza la finestra MAPI Send Message piuttosto che la finestra di
composizione messaggi.

 Nota: l’impostazione iniziale degli indirizzi e del corpo del messaggio è
gestita da Agent, ma una volta che la finestra MAPI è stata aperta, Agent
non ha più il controllo sul messaggio. Dopo essere stato inviato, il
messaggio viene salvato nel vostro sistema di posta MAPI, non nelle
cartelle di Agent o nell’Outbox.

• L’opzione Forward Verbatim è disabilitata.

• La firma non viene aggiunta alla fine del messaggio. Al posto di questa
dovrete utilizzare il meccanismo di gestione firme fornito dal vostro
sistema.

• Sulla scheda Group→Properties→Post, l’opzione Copy follow-up
messages to author via email è disabilitata.

• Molte opzioni per l’invio sia di messaggi Usenet che email non sono più
disponibili. Per esempio, Agent ignora i campi "To:", "Cc:", e "Bcc:" nei
messaggi Usenet.
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 Agent non invierà nessun messaggio che potrebbe essere stato messo
in coda nella vostra Outbox prima dell’abilitazione della posta MAPI.
Dovrete assicurarvi di inviare via SMTP tutti i messaggi in coda prima di
abilitare la gestione delle email tramite MAPI.
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CAPITOLO 6

Usare gli allegati
Ci possono essere volte in cui avete bisogno di spedire o ricevere informazioni che non
possono essere contenute in un semplice messaggio di testo. Per esempio, potreste voler
vedere un’immagine o ascoltare un suono presente in un newsgroup. Oppure, spedire un
documento elaborato o un foglio di calcolo a un vostro collega o amico. Per fare questo,
dovete inviare dei file allegati. In questo capitolo discuteremo su come Agent permette di
inviare e ricevere allegati, a partire dalle esigenze di base per arrivare al totale controllo nella
loro gestione.

Questa sezione coprirà i punti principali nell’impiego degli allegati. Tutti i dettagli si possono
trovare nell’Help in linea di Agent. Chi volesse solo una breve panoramica su come vedere gli
allegati, può saltare direttamente alla sezione, “Esempio: un modo per vedere gli allegati” a
pagina 160.

Gli argomenti in questo capitolo sono:

1 Alcuni Concetti Base

1 Caricare Messaggi con Allegati

1 Salvare gli Allegati

1 Inviare un Allegato

1 Messaggi Digest

1 Esempio: un Modo per Vedere gli Allegati

Alcuni concetti base
La prima cosa che dovreste sapere è che per la maggioranza degli utenti è
sufficiente lasciare che Agent si prenda cura degli allegati automaticamente.
Non avrete bisogno di conoscere o fare nulla di speciale per l’impiego di
questa caratteristica. Per conoscere i semplici passi da seguire, leggete le
sezioni “Caricare messaggi con allegati” e “Inviare un allegato” presenti in
questo capitolo.
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Se volete entrare nei dettagli del lavoro con gli allegati, dovreste prendere
familiarità con alcuni termini qui usati. Non vi allarmate di questo…è davvero
molto semplice.

Codificare e decodificare

Email e messaggi news sono trasmessi attraverso Internet come messaggi
di testo. Sfortunatamente, molti dei file presenti sul vostro computer (ad
esempio, fogli di calcolo, immagini, ecc.) non sono file di testo. Prima di
essere spediti, questi file devono essere convertiti in un formato testuale.
Questa conversione è chiamata “codifica” . Allo stesso modo, quando
ricevete un messaggio codificato, questo deve essere riportato allo stato di
informazione binaria, usando un processo chiamato “decodifica”.

UUEncode and UUDecode sono stati i metodi più usati per codificare e
decodificare file binari. Più recentemente, metodi associati allo standard
MIME (Multipurpose Internet Mail Extensions) hanno cominciato a
rimpiazzare UUEncode e UUDecode. Sebbene ci siano certi vantaggi a usare
il MIME rispetto al UUEncode/UUDecode, nella realtà non è importante quale
usare purché la persona dall’altra parte abbia un’applicazione in grado di
processare correttamente l’informazione. Agent è un’applicazione di questo
tipo, determinando quale metodo di codifica è stato usato e applicando la
codifica appropriata per ricevere correttamente l’allegato. Come regola
generale, i newsgroup usano ancora UUEncode/UUDecode per trattare gli
allegati binari, mentre la maggior parte dei messaggi email è attualmente
spedita usando il formato MIME per gli allegati.

In lettura, Agent supporta UUDecode, Base64, e il formato AppleDouble. In
scrittura, Agent supporta UUEncode e Base64.

Allegati Multipart

I file binari possono essere piuttosto pesanti, spesso troppo grandi per
essere inviati come parte di un singolo messaggio. Questo comunemente
comporta l’impiego di più di un messaggio per trasmettere un solo allegato.

Solitamente il titolo del messaggio vi dice se il messaggio è parte di un
allegato multipart. Per esempio, potreste vedere qualcosa come [1/2] (o
[2/2]) come dire che il messaggio contiene la parte 1; in altre parole, il
messaggio contiene la parte 1 (o la parte 2) di un allegato con 2 parti.

Leggi come
controllare il
formato
codificato
quando si
invia un
messaggio a
pag. 159.

Vedi pag. 155 per
dettagli su
ricezione e invio
allegati multipart.
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MIME Types

Lo standard MIME definisce i tipi di allegati, in relazione alla loro funzione.
Gli utenti generici di Agent non hanno bisogno di essere informati sui vari tipi
e sul loro significato, dato che Agent gestisce queste cose automaticamente.
Per lavorare con i tipi MIME in Agent, aprite la scheda Options→General
Preferences→MIME Types.

Lanciare un allegato

Il semplice recupero di un allegato potrebbe non essere sufficiente per
esaminare i suoi contenuti. Se l’allegato fosse un foglio elettronico, avreste
bisogno di leggere il file usando la sua applicazione. Se fosse un’immagine,
avreste bisogno di usare un visualizzatore. La pratica di usare un
applicazione per vedere il file allegato è chiamata “lancio” dell’allegato.

Per default, Agent usa il registro di Windows per determinare quale
applicazione deve essere usata per lanciare l’allegato. Dopo il caricamento di
un messaggio con un allegato, nel pannello Message vedrete l’icona
dell’applicazione che sarà usata. Potete far sì che le impostazioni correnti di
Windows vengano ignorate usando la scheda Options→General
Preferences→MIME Types.

Per dettagli
sulla config.
predefinita di
Agent dei tipi
MIME, leggi
l’Help in linea.
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Per non tener conto delle impostazioni predefinite di Windows:

1. Selezionate il tipo di MIME per il quale volete sostituire l’applicazione
predefinita in Windows.

2. Controllate che nella Extensions box ci siano tutte le estensioni dei tipi.

3. Immettete il percorso della nuova applicazione nell’Application box
(oppure usate il pulsante Browse per trovare l’applicazione).

4. Cliccate su OK.

Salvare un Allegato

Un allegato è parte del messaggio in Agent. Potete estrarre e salvare ogni
allegato come file. Quando salvate l’allegato, potete specificare se Agent
dovrà mantenerlo o rimuoverlo dal messaggio.

Le sezioni del messaggio

 Lo standard MIME permette che un messaggio abbia più sezioni, anche di
tipo differente. Ogni allegato inserito in un messaggio costituisce una
specifica sezione. Ogni sezione può avere la propria disposition (ad es., il
modo in cui è inserita nel messaggio). Le opzioni di disposizione sono:

• Attachment - la sezione viene aggiunta al messaggio. Questo è il tipico
modo per spedire allegati.

• Inline - la sezione rimane in un allegato separato, ma può essere vista in
Agent, piuttosto che attraverso un programma separato.

 Nota: Agent mostrerà solo gli allegati Inline di testo. Per vedere
un’immagine allegata, dovete prima configurare un viewer.

• Text insertion - sezione inserita come testo direttamente nel messaggio

Nel corpo del messaggio, se una sezione di testo riporta una descrizione,
questa appare in una piccola finestra sopra la sezione. Altrimenti, le sezioni
di testo sono precedute da una singola linea orizzontale. Potete usare le
scorciatoie Alt+FrecciaSu and Alt+FrecciaGiu per spostarvi tra le sezioni.

Indice del Messaggio

L’indice del messaggio di Agent vi permette di vedere tutte le sezioni di un
messaggio in un unica finestra di dialogo. Vi mostra tipo, disposizione,
dimensione, metodo di codifica e tipo di file per ogni sezione, e mostra anche
l’icona dell’applicazione che verrà usata per lanciare la sezione. Potete
vedere l’indice di ogni messaggio evidenziandolo e selezionando
Message→Index o con la scorciatoia Ctrl+i. Ecco qui un esempio.
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Scaricare messaggi con allegati
Non c’è nulla di difficile nello scaricare messaggi che potrebbero contenere
allegati. Gli allegati nelle email sono scaricati automaticamente quando si
recupera il messaggio. Nel lavoro con i newsgroup, basta scaricare gli
header del gruppo che vi interessa, controllare la lista dei messaggi e
scaricare il corpo di quelli che reputate interessanti. Per controllare come
Agent scarica gli allegati, usate la scheda Group→Properties→Receive Files.
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Per l’uso comune, selezionate le seguenti caselle nella scheda Receive
Files:

• Detect Uuencoded files automatically

• Join multipart messages when retrieving headers

• Ignore fragments

Per maggiori dettagli, leggete l’help in linea.

I processi di base per scaricare gli allegati

Per scaricare e lanciare un allegato in un newsgroup:

1. Scaricate le nuove intestazioni dal newsgroup.

2. Selezionate un messaggio nel pannello Message List.

Nota: se avete attivato l’opzione Join multipart messages automatically
nella scheda Group→Properties→Receive Files, allora la selezione
comprenderà le varie parti già riunite in un unico messaggio. Se non
avete attivato l’opzione per quel gruppo, dovrete in seguito decodificare
manualmente l’allegato. (Più sotto, potete leggere la procedura per la
decodifica manuale di un allegato).

3. Scaricate e/o visualizzate l’allegato selezionando File→Launch
Attachment. In alternativa, fate doppio click e l’allegato verrà lanciato se
è stata attivata l’opzione Double-clicking launches attachments nella
scheda Group→Properties→Receive Files.
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_____________________________________________________________

OO Per aiutarvi a distinguere i messaggi con allegati da quelli senza,
Agent colora le icone nella lista dei messaggi.

La busta indica email, mentre la pagina indica nuovi messaggi.

  (bianco) Messaggi con testo semplice

  (giallo) Messaggi con allegati

  (verde) Messaggi dove tutti gli allegati sono già stati salvati
_____________________________________________________________

E’ generalmente noto che un messaggio con un allegato è molto più grande
di un semplice messaggio di testo. Nella lista dei messaggi, potete vedere il
numero di righe del messaggio. Se scaricate il corpo del messaggio, potete
leggere nel pannello del messaggio la dimensione dell’allegato espressa in
byte.

Scaricare allegati multipart

Per default, Agent è configurato per riconoscere automaticamente allegati
multipart e riunirli insieme in un singolo messaggio. Per es., se Agent
incontra un messaggio composto da due parti, le unirà insieme e collocherà
[*/2] nel subject per indicare un messaggio creato con la combinazione di
due parti.

Nota: Se tutte le parti non sono disponibili dopo il caricamento delle
intestazioni, nella lista dei messaggi appare l’icona Incomplete Attachment

. Il pannello Message vi dirà quali parti non sono disponibili sul news
server.

Troverete due impostazioni per l’unione di messaggi multipart nella scheda
Group→Properties→Receive Files. La configurazione iniziale mostra
entrambe le opzioni Join multipart messages selezionate.

Una ragione per deselezionare l’opzione Join multipart messages when
retrieving headers si ha quando la lentezza del feed del news server è tale
da provocare il purge di alcune sezioni degli allegati multipart prima
dell’arrivo delle rimanenti. Disabilitando l’unione automatica durante lo
scaricamento delle intestazioni Agent andrà avanti e scaricherà il corpo dei
messaggi multipart incompleti e così potrete poi unirli manualmente,
sfruttando la seguente procedura.

Per unire manualmente un allegato multipart:
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1. Selezionate tutti i messaggi contenenti l’allegato cliccando su ognuno di
essi tenendo premuto il tasto Control.

2. Selezionate Message→Join Sections.

3. Assicuratevi che i messaggi siano in ordine. Se non lo fossero, usate il
pulsante Up and Down nella finestra di dialogo Join Sections per ordinarli
correttamente.

4. Lanciate o salvate l’allegato premendo il corrispondente pulsante. Se
siete offline e non avete ancora scaricato i messaggi degli allegati, Agent
andrà immediatamente online per scaricare e decodificare l’allegato.

Visualizzare un allegato come testo

A volte, potreste ricevere un messaggio come allegato quando è composto
da solo testo. Di solito, questo accade quando qualcuno invia il testo non
correttamente o quando un altro programma formatta le informazioni in modo
tale inviarle come allegato. In entrambi i casi, la soluzione è semplice. Nella
scheda Options→General Preferences→MIME types, selezionate
semplicemente le caselle Display when Inline e Display when attachment per
ogni appropriato tipo di MIME. Agent mostrerà immediatamente il testo del
vostro messaggio.

Salvare Allegati
Agent permette di decidere con molta flessibilità quando e come gli allegati
devono essere salvati. Potete far sì che Agent salvi gli allegati
automaticamente oppure salvarli manualmente.

Salvare gli allegati automaticamente

Potete impostare Agent per salvare gli allegati automaticamente durante
l’operazione di recupero dei messaggi usenet o email selezionando Save
attachments automatically nella scheda Group→Properties→Receive Files.
Questo approccio è conveniente quando sapete di dover salvare tutti gli
allegati come file, anche se lo scaricamento risulterà più lento, dato che
Agent dovrà salvare ogni allegato in un file, ma salvarlo all’interno del
messaggio (almeno temporaneamente) nel caso individui un errore di
codifica.
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Salvare gli allegati manualmente

Un approccio alternativo è lasciare gli allegati dentro al messaggio per
salvarli manualmente. Talvolta, questo metodo ha il vantaggio di rendere lo
scaricamento più veloce senza impegnare il vostro disco con file che
potreste decidere di non salvare.

Ci sono due modi per salvare gli allegati manualmente:

• Selezionate uno o più messaggi, poi selezionate File→Save All
Attachments. Ogni allegato viene salvato con il suo nome, come appare
nel Message Index. Per assicurarvi che Agent riunisca tutte le parti di un
allegato multipart quando salva il messaggio, dovete attivare l’opzione
Join multipart messages when saving or launching attachments (scheda
Group→Properties→Receive Files).

• Selezionate un messaggio e attivate Message→Index. Apparirà la
finestra Message Index (p. 155), che vi permetterà di vedere l’intero e
salvare o lanciare singole sezioni.

Spedire un allegato
Allegare file ai messaggi è facile, con Agent. Seguite questi passaggi:

1. Create un nuovo messaggio (che sia news o email).

2. Verificate il formato del vostro allegato. Potete controllare il formato per
gli allegati nel vostro messaggio direttamente nella finestra di
composizione selezionando Message→Properties per aprire la finestra
Message Properties. Nella sezione Attachments, selezionate
UUEncoded o MIME dall’elenco Format .

Potete anche controllare le opzioni predefinite per gli allegati nella
scheda Group→Properties→Send Files. Qui potete scegliere il formato
predefinito sia per Usenet che per la posta elettronica.



Capitolo 6

160

In questa stessa scheda potete dire a Agent come trattare gli allegati di
grandi dimensioni. Di regola, su Usenet i messaggi con allegati più
grandi di 500 Kbyte circa, sono spediti come messaggi multipli in modo
da assicurare che tutti i news server li possano gestire. Tuttavia,
potrebbe non essere opportuno dividere in parti i messaggi email, dato
che alcuni mailreader potrebbero non essere in grado di ricevere allegati
multipart.

3. Allegate il file che desiderate. Nella finestra di composizione, premi sul
pulsante Attachments per vedere la relativa finestra.

Usando la finestra di dialogo Attachments, potete aggiungere o togliere
gli allegati. Di ogni file allegato al messaggio potete definire la
disposizione (disposition, ovvero come viene allegato), dare una
descrizione a scelta e specificare il tipo, cosa che Agent di solito
determina automaticamente.

4. Aggiungete un messaggio di testo (opzionale). Nel messaggio potete
includere una parte di testo assieme all’allegato. Il testo comparirà prima
dell’allegato. Se inserite del testo, Agent aggiungerà anche la vostra
firma.

5. Inviate il messaggio. Quando avete finito di comporre il messaggio e
siete pronti per spedirlo, Agent lo preparerà per l’invio nell’ordine che
segue:

a. Scriverà il corpo principale (testo) del messaggio.
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b. Aggiungerà al corpo gli allegati del tipo Insert in text body, nell’ordine
in cui compaiono nella finestra di dialogo Attachments.

c. Aggiungerà un’eventuale firma.

d. Aggiungerà tutti gli altri allegati (ovvero tutti gli allegati di tipo diverso
da Insert in text body) nell’ordine in cui appaiono nella finestra
Attachments. Nella finestra di dialogo Attachments, potete usare i
pulsanti Up and Down per cambiare l’ordine degli allegati.

Nota: Gli allegati con placement del tipo Insert in text body costituiscono un
gruppo individuabile, seguito poi da tutti gli altri allegati non appartenenti a
questa categoria.

Messaggi digest
Un "digest" è un gruppo di messaggi i cui corpi sono combinati in un singolo
messaggio MIME di tipo multipart-digest. Spesso le newsletter sono inviate
in questo modo, con le loro varie parti assemblate in un singolo messaggio.

Inviare un digest

Per inviare un digest:

1. Nel pannello Message List, selezionate i messaggi da includere nel
digest.

2. Selezionate Post→Forward Verbatim.

Se una finestra di composizione è già aperta, apparirà la finestra di
dialogo Forward Verbatim. Premete il pulsante Append to selected
message per allegare i messaggi selezionati alla finestra di
composizione.

Se non avete alcuna finestra di composizione aperta, Agent ne aprirà
automaticamente una e allegherà i messaggi ad essa. Nota: Nel campo
Subject della finestra, Agent immetterà il subject del primo dei messaggi
selezionati.

3. Selezionate Message→Properties per aprire la finestra di dialogo
Message Properties. Selezionate la casella Override, poi assicuratevi
che per Attachments Format sia selezionato MIME e che l’opzione Send
attached messages as a Digest sia selezionata.

Se volete aggiungere ulteriori messaggi al digest, potete tornare alla lista dei
messaggi e selezionarne degli altri, scegliendo Post→Forward Verbatim, e
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aggiungendo i nuovi messaggi a quello in uscita già esistente. Quando si
invia il messaggio, Agent colloca il digest alla fine di questo, dopo tutti gli altri
allegati.

Ricezione e bursting di un digest

La ricezione di un digest è semplice come quella di tutti gli altri messaggi.
Tutte le sezioni del digest sono contenute in un singolo messaggio. Per
vedere che cosa è contenuto nel digest, aprite il Message Index, sia
selezionando Message→Index oppure premendo Ctrl+i. Nell’indice, potete
vedere la descrizione di ogni parte del digest. Evidenziate una sezione di
vostro interesse, poi usate l’opzione Go to per vedere il relativo testo.

Se preferite, Agent creerà un messaggio separato per ciascuna parte del
digest, un processo conosciuto come “bursting” (scomposizione) del digest.

Bursting del digest:

Selezionate Burst digests into separate messages  nella scheda
Group→Properties→Receive Files (pag. 156). La volta successiva che
riceverete un digest allegato, il digest si scomporrà in messaggi separati.

Nota: Dopo la scomposizione, Agent mantiene il messaggio originale
completo, così potete:

• accedere al messaggio nella sua forma originale, nel caso qualcosa
andasse storto durante il bursting.

• leggere eventuale testo introduttivo che potrebbe precedere la parte
digest.

• inoltrare (forward) o salvare l’intero messaggio originale

Inoltre, quando Agent scompone un digest, colloca tutti i messaggi nello
stesso gruppo o cartella nel quale si trova il messaggio originale. (I filtri email
non sono applicati ai singoli file man mano che questi vengono estratti dal
digest e salvati separatamente.)

Nota: perché Agent espanda un messaggio o una sezione di messaggio,
questo deve essere di tipo "multipart/digest". Un messaggio di testo che
risulta contenere altri messaggi non è un digest, quindi non sarà espanso da
Agent.
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Esempio: un modo per visualizzare gli
allegati

Questo capitolo chiude con un esempio che illustra come potete usare Agent
per la visione di immagini caricate in un newsgroup binario (es.
alt.binaries.pictures.cartoons). Vedrete come molte delle configurazioni di
Agent possano essere usate per ottimizzare la visualizzazione degli allegati.

Per adattare alle vostre necessità il modo di visualizzare gli attachment:

1. Assicuratevi di aver configurato un’applicazione per la visualizzazione di
immagini. (Benché questa non sia una funzione di Agent, i passi da
seguire sono descritti nell’Help in linea di Agent.)

2. Impostate le proprietà del gruppo appropriato. Con il gruppo selezionato,
aprite la scheda Group→Properties→Receive Files. Poi assicuratevi che
le seguenti opzioni siano abilitate: Detect UUEncoded files automatically,
Ignore fragments, Join multipart messages when retrieving headers, e
Double-clicking launches attachments, come illustrato sotto.
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3. Nella scheda Group→Properties→Directory, assicuratevi che sia
specificata la cartella di Windows dove volete che i file allegati vengano
salvati.

4. Definite un filtro kill per questo gruppo. Usate l’opzione Skip (salta), ad
es. con l’espressione [*,99]. Questo previene il caricamento dei
messaggi non binari, dato che saranno ignorati tutti i messaggi con meno
di 100 righe.

5. Potete ordinare il gruppo per dimensione, con i messaggi più piccoli in
alto (Group→Sort Messages by→Size). Questo può essere utile se
avete una connessione lenta, in modo da far risaltare i messaggi che
possono essere scaricati più velocemente.

6. Definite una vista in modo da nascondere messaggi multipart incompleti
ed attivatela (in Group→View Messages→Manage Views ).

7. Andate online e scaricate i nuovi header del gruppo.

8. Passate in rassegna gli header, selezionate i messaggi di vostro
interesse, e recuperatene il corpo. Nota che i passi 4, 5 e 6 dovrebbero
avervi reso più semplice esaminare la lista dei messaggi.

9. Partendo dall’inizio della la lista dei messaggi, usate il tasto “B” per
trovare rapidamente tutti i messaggi con corpo. Per ognuno di essi, fate
doppio click sull’header (o premete Invio) per lanciare l’allegato.
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Nota: se un messaggio ha più di un allegato, andate all’indice di quel
messaggio e lanciate singolarmente ogni parte.

10. Se volete salvare l’allegato, semplicemente premete il tasto “A” (oppure
fate click destro sul messaggio e selezionate Save All Attachments).
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CAPITOLO 7

 Agent e le altre applicazioni
 Agent si integra in modo completo con le altre applicazioni che usate per Internet,
permettendovi di richiamarle direttamente per gestire le URL. Potete inoltre richiamare Agent
da Internet Explorer e Netscape, per usarlo come programma per le news e l’email. Infine,
con l’impiego di un file newsrc standard, potete sincronizzare e coordinare Agent con un altro
newsreader, o con altre copie dello stesso Agent.

 Questo capitolo tratta i seguenti argomenti:

 1 URL in Agent

 1 Uso dei file newsrc

 URL in Agent

 Che cos’è una URL?

 Una URL (Uniform Resource Locator) è un indirizzo usato per localizzare
una risorsa su Internet. Il formato della URL dipende dal tipo di risorsa. Ecco
alcuni esempi:

 URL Tipo di indirizzo

 http://www.forteinc.com Indirizzo World Wide Web

 agent-info@forteinc.com indirizzo email

 ftp.forteinc.com indirizzo FTP

 Questi sono I tipi di URL che Agent riconosce:
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 file: File  News: Usenet News
 ftp: File Transfer Protocol  nntp: Usenet News
 Gopher: Gopher  snews: Secure Usenet News
 http: Hypertext Transfer
Protocol

 telnet: Telnet

 https: Secure Hypertext
Transfer Protocol

 wais: Wide Area Information
Servers

 mailto: Indirizzo Email  
 

 Visualizzare le URL

 Agent evidenzia le URL che incontra negli header, nel testo dei messaggi o
anche nella finestra di composizione quando scrivete i vostri messaggi.
Nell’impostazione predefinita, le URL appaiono verdi e sottolineate, ma
potete modificare a vostro piacimento lo stile da usare per evidenziarle.

Per controllare lo stile di evidenziazione usato:

 Selezionate la scheda Options→Display Preferences→Messages.

 

 

 Per default, Agent abilita I seguenti attributi per le URL, nella sezione How to
Display URLs. Potete disabilitare quelli che volete.
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 1. Highlight in different color – Selezionate questa casella per
visualizzare le URL in un colore diverso dal testo.

 Nota: per selezionare il colore, usate l’opzione URL nella scheda Display
Preferences Colors.

 2. Underline - Selezionate questa casella per far sì che le URL appaiano
sottolineate. Deselezionatela per eliminare la sottolineatura.

 3. Highlight in Composition Window - Selezionate questa casella per
evidenziare le URL mentre scrivete un messaggio.

 Nota: Per migliorare la velocità di Agent mentre scrivete un messaggio,
disattivate questa opzione.

Per scegliere quali URL siano da evidenziare:

 Selezionate la scheda Options→General Preferences→URL Types.

 

 Usando il menu a discesa potete decidere la possibilità di lancio di ciascun
tipo di URL.

 Se per un certo tipo di URL disattivate l’opzione Enable Highlighting and
Launching, Agent non evidenzierà più quel tipo.

 Altre cose da notare:
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• Se il cursore passa sopra una URL evidenziata, si trasforma in una
freccia.

• Un click destro su di una URL fa apparire un menu contestuale ridotto,
con le opzioni per gestire la URL.

• Un click destro su testo preventivamente selezionato fa apparire un
menu contestuale contenente anche opzioni per gestire le URL.

 Lanciare una URL

 Con un doppio click su una URL, Agent attiverà l’applicazione predefinita per
gestire quel tipo di URL nel vostro sistema. Questa operazione è detta
“lanciare” una URL. Ad esempio, con un doppio click sulla URL
http://www.forteinc.com, Agent attiverà il vostro Browser, che si aprirà sulla
Home Page di Forté. Se fate doppio click su un indirizzo email, Agent aprirà
una sua finestra di composizione dei messaggi inserendo nel campo “To:”
l’indirizzo che avete lanciato.

 Potete adattare il comportamento di Agent in base alle vostre necessità.
Nella scheda Options→General Preferences→URLs, osservate la sezione
Launching URLs.

 

 Descrizione delle opzioni:

 1. Double-click to launch – selezionare questa opzione vi permette di
lanciare le URL in un messaggio con un doppio click. Se disabilitate
l’opzione, il doppio click si limiterà a selezionare il testo (la URL non
verrà lanciata, e il testo non verrà copiato negli appunti).

 Nota: le URL possono presentarsi in una varietà di formati. Nel caso che
una URL non venga riconosciuta da Agent perché è in un formato poco
comune, potete ugualmente lanciarla (vedi sopra) cliccando e
trascinando il mouse sulla URL per selezionarla interamente, poi
facendo click destro sulla selezione e scegliendo Launch URL nel menu
contestuale che appare.

 2. Copy to clipboard – Selezionate questa casella per far sì che Agent,
oltre a lanciare la URL, la copi negli appunti.

 Nota: questa opzione agisce solo quando lanciate una URL.
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 3. Force web browser to open a single Window – Selezionate questa
opzione per far sì che il vostro browser (ad esempio Netscape o Internet
Explorer) apra nella finestra corrente la URL che gli viene inviata da
Agent, anche se il browser è normalmente configurato per aprire un’altra
finestra.

 _____________________________________________________________

 OO Nota tecnica: questa opzione impone che l’argomento passato dal
comando WWW_OpenURL sia:

 "%1",,0xFFFFFFFF,,,,,

 a prescindere dalle impostazioni del registry. Così, se lanciate una
URL a Netscape quando questa opzione è selezionata, non dovreste
aver bisogno d’altro per far sì che Netscape si apra in un’unica copia.

 _____________________________________________________________

 4. Come interpretare una URL del tipo nome@dominio - Scegliete in
che modo Agent debba interpretare le URL che trova nei messaggi. Dal
momento che ci può essere ambiguità tra un indirizzo email e il message
ID di un messaggio usenet, dovete dire ad Agent come comportarsi
quando questa ambiguità si manifesta.

 Per default, Agent tenta di distinguere tra le due possibilità scegliendo
l’ipotesi più attendibile (con l’opzione “make an educated guess”). Ma
avete le seguenti opzioni:

• Prompt for action - Agent vi chiederà sempre come procedere.

• Assume the URL is an email address - presume che la URL sia un
indirizzo email

• Assume the URL is a message-ID – presume che la URL sia un
Message-ID

• Make an educated guess - Sceglie l’ipotesi più attendibile (dettagli
tecnici sui criteri di scelta si trovano nell’Help in linea)

 Lanciare la URL di un messaggio pone determinati problemi. Il message ID
può riferirsi ad un qualsiasi messaggio nel gruppo selezionato, in un diverso
gruppo o folder, o anche sul news server che si sta usando. Dovrete dire ad
Agent dove andare a cercare. Nella scheda Options→General
Preferences→URLs, la sezione Search for message URLs in: vi permette di
specificare le vostre preferenze.
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• Selezionate in quali gruppi volete che Agent cerchi la URL del
messaggio (gruppo corrente, gruppi sottoscritti, tutti).

• Selezionate la casella Folders  per cercare il messaggio nelle cartelle.

• Selezionate la casella News Server per far sì che Agent cerchi il
messaggio sul vostro news server. Se selezionate Prompt before going
online, Agent vi chiederà conferma prima di effettuare la connessione.

• Potete specificare un diverso comportamento per ciascun tipo di URL
usando la scheda Options→General Preferences→URL Types. Per
default, Agent userà le associazioni specificate nel registry di windows
per scegliere quali applicazioni lanciare, ma non ne terrà conto se
selezionate una delle altre opzioni nella sezione How to Launch URLs
della scheda URL Types.

 

 Use Windows registry settings – Questa opzione è disponibile solo nella
versione per Windows 95 e Windows NT 4.0. E’ l’opzione predefinita, che
permette ad Agent di lavorare in armonia coi sistemi Windows 95 e Windows
NT 4.0.

 Use Custom settings (below) – Con questa scelta si attiva la sezione
Custom Settings nella scheda URL Types. Potete usare questa sezione nel
caso stiate usando programmi come Netscape, che richiedono impostazioni
differenti da quelle predefinite. Se ad esempio inserite netscape.exe
come applicazione, Agent attiva le impostazioni adeguate, selezionando
automaticamente l’opzione Use DDE e inserendo Netscape in Application.
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 Send URL to Agent – Questa opzione, normalmente, non è disponibile
(potete vederla in grigio). Si attiva solo se avete selezionato nntp: Usenet
News dal menu a discesa in alto, nella scheda URL Types.

 Rendere Agent l’applicazione predefinita per news ed email

  E’ semplice configurare il vostro sistema in modo che Agent venga attivato
ogni volta che, dal vostro browser, lanciate un message ID o un indirizzo
email.

Per rendere Agent il vostro programma predefinito per news ed email:

 Usate l’opzione Make Agent the web browser service for... nella scheda
Options→General Preferences→URLs. Agent modificherà il registro di
Windows in modo che ogni volta che lanciate la URL di un messaggio news
o di un indirizzo email, Windows attivi Agent per visualizzarli.

• Se lanciate un indirizzo email, Agent aprirà la finestra di composizione di
un nuovo messaggio con l’indirizzo email inserito nel campo "To:".

• Se lanciate un message ID, Agent cercherà il messaggio e lo aprirà,
seguendo i criteri di ricerca che avete specificato nella scheda URLs.
(Vedi pag. 171.)

Per Internet Explorer 3.0 e successive versioni – Selezionate
View→Options→Programs. Agent apparirà come scelta per news ed email.
Selezionate Agent.

Per Netscape 3.0 e versioni successive – non vi servono ulteriori
modifiche. Tuttavia, a causa di limitazioni in Netscape, potete inviare URL da
Netscape ad Agent solo se quest’ultimo è già aperto.

Usare le scorciatoie e la lista dei Preferiti in Internet Explorer

Se avete installato Microsoft Internet Explorer potete agire in questo modo:

 Aggiungere una URL ai Preferiti di Internet Explorer. (solo Agent 32-bit)



Capitolo 7

174

Evidenziate una URL in un messaggio e selezionate Edit→Add URL to
Favorites (oppure usate il menu contestuale accessibile col tasto destro del
mouse). Nella finestra di dialogo Add URL to Favorites che appare, cliccate
su Save per aggiungere la URL alla lista (vedi il seguente esempio).

Usando la finestra di dialogo Add URL to Favorites , potete inserire la URL in
qualsiasi punto della vostra lista di preferiti. Quando volete vedere il
contenuto della vostra cartella dei preferiti, semplicemente selezionate
Window→Open Favorites Folder.

Creare scorciatoie verso email o messaggi news. (solo Agent 32-bit)

Queste scorciatoie attiveranno direttamente Agent. Ad esempio, se Agent è il
vostro programma predefinito per le email, seguite questi passaggi:

1. fate click destro su una URL del tipo mailto in Internet Explorer e
selezionate Copia Collegamento.

2. Fate click destro sul desktop di Windows e selezionate Incolla
Collegamento. Apparirà un nuovo collegamento con l’icona Email di
Agent.

3. Fate doppio click sull’icona e Agent verrà lanciato, mostrando la finestra
di composizione di un nuovo messaggio con l’indirizzo della URL mail-to
inserito nel campo "To:".

_____________________________________________________________

OO Nota per chi usa Netscape: Perché le cose funzionino anche con
Netscape nel modo descritto più sopra, Internet Explorer dovrà
comunque essere installato nel vostro sistema.

_____________________________________________________________
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Che cosa accade se si usano più copie di Agent?

Agent gestisce facilmente le URL anche se ne state usando più copie
contemporaneamente. Potete far sì che una delle copie di Agent sia il
programma predefinito per email e news, ma potete anche impostare una
delle copie per l’email, ed un’altra per le news. Potete quindi far funzionare
Agent nel modo che preferite.

Agent si autoconfigura in modo da permettere a due diversi utenti di
condividere lo stesso computer mantendendo i database dei messaggi del
tutto separati, e nello stesso tempo lanciare correttamente le URL. Ad
esempio, se marito e moglie condividono il computer, quando il marito lancia
una URL dal suo browser, Agent partirà con i database impostati dal marito.
Allo stesso modo, partirà con i database della moglie quando è lei che sta
usando il computer. Questa caratteristica può funzionare solo sotto Windows
95 o Windows NT, ed è necessario che:

• ciascuno abbia il suo proprio nome utente.

• AGENT.EXE si trovi in una cartella in comune, mentre i database
devono trovarsi in cartelle separate.

 Usare un file newsrc
 Un file newsrc è un file di testo, usato dai sistemi Unix e da alcuni altri
newsreader per Windows, per tenere un elenco della lista dei newsgroup
disponibili e di quelli usati da un determinato utente. Il file newsrc contiene la
lista completa dei gruppi, la lista di quelli sottoscritti e l’elenco dei messaggi
che sono stati scaricati e letti per ciascun gruppo.

 Agent mantiene queste stesse informazioni in un suo database, in un
formato proprietario. Finché usate una singola versione di Agent (sempre
sulla stessa macchina) non c’è bisogno di usare un file newsrc. Invece, se ad
esempio usate Agent a casa, mentre al lavoro usate un newsreader per Unix
(oppure un’altra copia di Agent), potete importare/esportare il file newsrc per
mantenere sincronizzati i vostri due newsreader.

 Esportare un file newsrc

 Selezionate File→Newsrc→Export. Apparirà la finestra di dialogo Export
Newsrc File. Fate così:

• Specificate il nome e il percorso del file che Agent dovrà creare.
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• Se volete esportare solo la lista dei gruppi sottoscritti selezionate la
casella Export subscribed groups only nella finestra di dialogo Export
Newsrc.

 Quando si esporta un file newsrc, Agent verifica sia l'elenco dei messaggi
che sono stati caricati, sia lo stato di lettura degli stessi, al fine di costruire il
riepilogo newsrc dei messaggi letti, come segue:

• Il limite inferiore dell'intervallo dei messaggi caricati da Agent è portato al
valore 1.

 Per esempio, se l'intervallo dei messaggi caricati è [100-150,200-240], Agent
estenderà il primo intervallo in questo modo [1-150,200-240]

 Nota: questo è per evitare che messaggi già scaricati vengano marcati come
non letti nel caso che lo stesso file newsrc venga reimportato.

• Nell'elenco newsrc viene eliminato lo stato di lettura.

 Importare un file newsrc

 Se avete messo un file newsrc nella cartella di Agent (esportato da Agent
stesso o proveniente da un’altra applicazione), potete importarlo per
aggiornare la lista dei gruppi in Agent.

 Selezionate File→Newsrc→Import. Apparirà la finestra di dialogo Import
Newsrc File.
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 Specificate il percorso del file da importare, poi selezionate le opzioni che
preferite, qui di seguito descritte.

• Update retrieved message counts – Selezionate questa casella se
volete che Agent aggiorni il conteggio dei messaggi scaricati ed il loro
stato (letto/non letto) quando un file newsrc viene importato. La lista
viene aggiornata in modo da includere sia i messaggi nel file newsrc sia
quelli già contenuti nel database di Agent per ciascun gruppo.

 Quindi ... messaggi che possono non essere stati inclusi nel file newsrc
perché erano marcati come non letti, ma che sono già stati scaricati,
vengono inclusi nella lista aggiornata dei messaggi scaricati. Ogni
messaggio esistente e incluso nel file newsrc viene marcato come letto,
mentre ogni messaggio esistente non incluso viene marcato come non
letto (ma leggete il paragrafo successivo).

• Mark messages read only – Selezionate questa casella per far sì che
Agent usi i contenuti del file newsrc per marcare letti i messaggi esistenti
ma non marcarne alcuno come non letto. Se deselezionate la casella,
Agent marca come non letti tutti i messaggi non compresi nel file newsrc.

• Update list of subscribed groups -- Selezionate questa casella se
volete che Agent aggiorni la lista dei gruppi sottoscritti quando il file
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newsrc che state importando ne include alcuni che non sono compresi
nella attuale lista dei gruppi sottoscritti.

• Add new Groups -- Selezionate questa casella se volete che Agent
aggiunga gruppi contenuti nel file newsrc e ancora non presenti nel
database attuale.

• What to Do With Extinct Groups –Decidete qui cosa fare dei gruppi
estinti (quelli che non sono più disponibili sul vostro news server).

 Importare ed esportare automaticamente i file newsrc

 Potete configurare Agent in modo da importare automaticamente all’avvio un
file newsrc ed esportarlo in chiusura. Usate la scheda Options→General
Preferences→Newsrc per impostare il comportamento di Agent nell’eseguire
tali operazioni. Si tratta delle stesse opzioni descritte più sopra per
importazione ed esportazione eseguite manualmente.
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CAPITOLO 8

Personalizzazione di Agent
In Agent c’è un’ampia gamma di possibilità di personalizzazione, dalla
creazione di barre degli strumenti, alla modifica dei menu Folders, alla
personalizzazione del layout dei pannelli di Agent e anche dell’aspetto del
testo nei messaggi. In poche parole, Agent è uno strumento fortemente
flessibile che si adatta al vostro modo di lavorare.

In questo capitolo imparerete come personalizzare:

1 Barra degli strumenti

1 Menu Folders

1 Visualizzazione delle finestre

1 Visualizzazione dei messaggi

1 Agent.ini

Barre degli strumenti
Questa è probabilmente una delle caratteristiche più interessanti che Agent
offre, poiché le icone delle barre degli strumenti sono sia belle da vedere sia
funzionali. La possibilità di personalizzare le vostre barre degli strumenti è
utile a causa dei modi differenti in cui le persone lavorano e di come variano
le loro preferenze. Le barre degli strumenti possono essere personalizzate
per:

• Il finestra principale di Agent

• La Outbox

• La finestra di composizione messaggi

• L’Address Book

• La finestra Usenet Filters

• La finestra The Email Filters

• Il Log di Agent
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Per personalizzare le barre degli strumenti:

1. Selezionate la scheda Options→Menus and Toolbars→Toolbars,
mostrata qui sotto.

 

2. Dalla lista Window, scegliete in quale barra degli strumenti aggiungere
un comando.

3. Dalla lista Commands, scegliete il comando che volete aggiungere.

4. Nella lista Toolbar, scegliete dove volete che appaia il comando e
premete il pulsante Add. Il comando viene inserito sopra questa
selezione. Sulla barra degli strumenti le icone appaiono nello stesso
ordine (da sinistra a destra) dei comandi nella lista Toolbar. Potete
cambiare l’ordine dei comandi usando i pulsanti Up e Down.

Potete raggruppare tipi di icone simili separando i gruppi con piccole
spaziature. Per inserire una spaziatura tra un’icona e un’altra, premete il
pulsante Separator.

Se cambiate idea riguardo un’icona, potete eliminarla dalla barra degli
strumenti premendo il pulsante Delete. Il comando eliminato riappare come
possibile scelta nella lista Commands. In qualsiasi momento potete
ripristinare le impostazioni predefinite delle barre degli strumenti di Agent
premendo il pulsante Reset.

Infine, potete cambiare le dimensioni delle icone nella scheda
Options→Display Preferences→Main Window. Assicuratevi che Show Tool
Bar sia selezionato; specificate poi la percentuale di rimpicciolimento o
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ingrandimento desiderata. La variazione delle dimensioni avviene ad
incrementi del 5%: per esempio, tutte le percentuali da 101% a 105%
porteranno un ingrandimento dei pulsanti del 5% (a 105%).

Menu Folders
Il menu Folders compare come sottomenu delle opzioni Message→Copy to
Folder e Message→Move to Folder.

Grazie alla seguente procedura potete personalizzare il menu Folder affinché
contenga una o più cartelle in cui voi spostate o copiate spesso i messaggi.

Per personalizzare il sottomenu folder:

Selezionate la scheda Options→Menus and Toolbars→Folder Menus.
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Sotto Folders, vedrete tutte le cartelle attualmente impostate. Selezionate
ognuna delle cartelle che volete aggiungere al sottomenu Folders e premete
Add. La cartella passerà dalla lista Folders a quella Menu. Potete inserire
fino a nove cartelle nel sottomenu Folders.

Per togliere una cartella dal menu, selezionate semplicemente tale cartella
dalla lista Menu e premete Delete. La cartella è rimossa dalla lista Menu e
ricompare nella lista Folders.

Quando chiudete la finestra, potete verificare che le vostre scelte appaiono
nel menu Folders (per esempio nel sottomenu Copy to Folder).

Visualizzazione delle finestre
Per default Agent visualizza tutti e tre i pannelli della finestra all’avvio. Dopo
che avrete usato il programma qualche volta, vorrete forse personalizzarne il
layout risistemando i tre pannelli.

Cambiare il layout dei pannelli

Scegliete Options→Window Layout e compariranno i pulsanti mostrati sotto.
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Le file di pulsanti nella finestra Window Layout sono qui descritte:

• Layout of Panes – Questi pulsanti mostrano tutti i layout possibili per i
pannelli. Premete un pulsante per sceglierne il layout.

• Contents of Panes – Applicati al layout precedente, questi pulsanti
mostrano tutti i modi in cui potete disporre i pannelli Groups/Folders,
Message List e Message. Per distinguere i tre tipi di pannelli, il testo sui
pulsanti è codificato tramite colori:

Il testo nero indica il pannello dei gruppi.

Il testo rosso indica il pannello della lista messaggi.

Il testo blu indica il pannello del messaggio.

Premete un pulsante per sceglierne la disposizione.

Una volta premuti i pulsanti e chiusa la finestra di dialogo, la finestra
principale rifletterà la scelta.

Per ridimensionare i pannelli:

Trascinate semplicemente il bordo tra i due pannelli.

Per impostare la nuova disposizione come predefinita:

Scegliete Options→Save as Default Window Layout . Ogni qual volta
avvierete Agent o aprirete una nuova finestra del browser (Window→Open
New Browser), verrà utilizzata questa disposizione. Il comando Save as
Default Window Layout salva la disposizione dei pannelli, le loro dimensioni
e l’informazione se il pannello è ingrandito o no.

Cambiare l’aspetto e il comportamento delle finestre di Agent

Scegliete la scheda Options→Display Preferences→Main Window.
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Le opzioni della scheda Main Window sono descritte qui:

1. Show Toolbar – Selezionate questa opzione per visualizzare la barra
degli strumenti di Agent subito sotto la barra dei menu.

2. Size of buttons – Specificate la percentuale di cui ingrandire o
rimpiccolire i pulsanti. Le dimensioni predefinite sono 100%, o 20x20
pixel. Un numero maggiore di 100% ingrandisce i pulsanti, uno minore di
100% li rimpiccolisce. Gli incrementi di dimensione effettivi sono a passi
del 5%.

3. Show Status Bar – Selezionate questa opzione per visualizzare la barra
di stato di Agent in basso nella finestra.

4. Reposition on last message when restarting program – Selezionate
questa casella se volete che Agent si posizioni sul messaggio che era
selezionato quando Agent è stato chiuso per l’ultima volta. Se
quest’opzione non è selezionata, quando aprirete Agent la volta
successiva, esso si posizionerà sul primo messaggio del pannello
Message List.

Selezionate la scheda Options→Display Preferences→Browsers  per vedere
le opzioni valide per tutti i pannelli del browser:

1. Scroll Margins – Impostate questo valore per decidere quanto vicina
sarà, dalla cima e dal fondo della finestra, la riga selezionata nei pannelli
Groups/Folders e Message List. Scorrendo questi pannelli con i tasti
freccia Su, Giù, Pagina su, Pagina giù, vedrete sempre il numero
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specificato di righe (2 per default) sopra e sotto la riga a cui Agent passa
(a parte, naturalmente, quando raggiungete la cima o il fondo della lista).

2. Show Author's full email address – Selezionate questa casella per
mostrare l’indirizzo email e il nome completo nella colonna Author. Se la
casella non è selezionata, viene mostrato solo il nome.

Visualizzazione dei messaggi
Agent vi permette di personalizzare il testo dei messaggi che appare nel
pannello Message per adattarlo alle vostre esigenze e preferenze.

Cambiare l’aspetto dei messaggi

Nella sezione precedente avete visto come due delle schede della finestra
Display Preferences possano essere usate per modificare l’aspetto e il
comportamento dei pannelli del browser di Agent. Le tre rimanenti schede
della finestra Display Preferences possono essere usate per personalizzare
cose come la visualizzazione di URL e testo citato, le dimensioni e i tipi di
carattere usati e i colori utilizzati per il testo normale, quello citato e degli
URL.

Aprite la scheda Options→Display Preferences→Messages, che serve per
modificare l’aspetto del corpo dei messaggi.

Queste sono le opzioni presenti nella scheda Messages:
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1. Tab Spacing – Inserite la larghezza delle tabulazioni, in numero di
caratteri.

2. Quoted Text Markers – Inserite il carattere/i che introducono un testo
citato da un messaggio precedente. Gli indicatori di testo citato sono
comunemente usati per indicare parti di un messaggio che sono state
copiate da un altro messaggio. Agent mostra questo testo nel colore
specificato, nella scheda Colors della finestra Finestra di dialogo, per il
testo citato.

3. Show dividers between sections – Segnate questa casella per inserire
una linea orizzontale tra le differenti sezioni del corpo dei messaggi. Per
esempio, se avete abilitato Show All Header Fields  dal menu Message,
ci sarà un separatore tra i campi dell’header e il corpo del messaggio.

4. How to display URLs – Potete scegliere gli attributi da applicare alle
URL, tra cui un nuovo colore, l’eventuale sottolineatura e se le URL
vengono evidenziate quando vengono scritte nella finestra di
composizione.

5. Show Buttons on composition window – Selezionate questa casella
per mostrare i pulsanti Send Now, Send Later, Save, All Fields, Cancel,
e Help direttamente nella finestra di composizione. Per default, questi
pulsanti non sono presenti nelle barre degli strumenti della finestra di
composizione.

Aprendo la scheda Options→Display Preferences→Fonts potrete cambiare i
caratteri nei messaggi e nella finestra principale di Agent.
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Le opzioni per cambiare i caratteri sono descritte qui sotto.

Browser – Premete questo pulsante per cambiare il carattere nella lista dei
gruppi e anche nelle finestre Outbox, Usenet Filters e Address Book. I
caratteri per i pannelli Message List e Message sono definiti poco oltre.

Fonts for the Language - Nel resto della finestra potete scegliere quali
caratteri utilizzare per ogni lingua che avete definito. Usate la casella a
tendina per scegliere la lingua che volete modificare.

Variable-Pitch Body – Premete questo pulsante per cambiare il carattere da
usare quando il testo dei messaggi è visualizzato con un carattere a
spaziatura proporzionale.

Fixed-Pitch Body – Premete questo pulsante per cambiare il carattere da
usare quando il testo dei messaggi è visualizzato con un carattere a
spaziatura fissa.
_____________________________________________________________

OO Spesso, i messaggi contengono delle firme “di fantasia” o altro testo
usato per creare un’immagine grafica. Se l’immagine risulta
incomprensibile o distorta, provate ad usare un carattere a spaziatura
fissa.

_____________________________________________________________

Message list – Premete questo pulsante per cambiare il carattere usato nel
pannello Message List.

Use the variable pitch body font – Selezionate questa casella se volete
usare il carattere scelto nell’impostazione Variable-Pitch Body per il testo nel
pannello Message List.

Message list Subject – Premete questo pulsante per cambiare il carattere
del subject dei messaggi nel pannello Message List.

Use the bold version of the Message List font – Selezionate questa
casella se volete che i subject dei messaggi siano visualizzati nella versione
in grassetto del carattere del pannello Message List.

Printer – Premete questo pulsante per cambiare il carattere usato nella
stampa.

Use the variable-pitch body font for Headers – Quando quest’opzione è
selezionata, Agent usa il carattere a spaziatura proporzionale scelto per il
testo del messaggio anche per visualizzare l’header sulla barra del titolo del
pannello Message e per il campo Subject nella finestra di composizione dei
messaggi. Altrimenti viene usato il carattere predefinito di sistema.

Nota: È utile selezionare questa casella se avete scelto un carattere che non
sfrutta il set di caratteri standard di Windows (per esempio un carattere
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Cirillico per il russo) e desiderate che il testo in questo diverso set di caratteri
venga visualizzato correttamente nel riquadro header sopra il messaggio e/o
nel campo subject dell’editor.

Infine, la scheda Options→Display Preferences→Colors consente di
cambiare il colore del testo e delle URL che appaiono negli header e nel
corpo dei messaggi.

Nella scheda Colors potete scegliere per ognuna delle opzioni uno tra sedici
colori nella tavolozza. Qui è indicato il significato di ognuna di tali
impostazioni:

Normal Lines – il colore per i gruppi, le cartelle ed i titoli dei messaggi letti.

Unread Messages – il colore per il titolo dei messaggi non letti nel pannello
Message List.

Highlighted Unread Messages – il colore del titolo dei messaggi non letti
quando sono selezionati. Di solito questo colore è l’inverso di quello
dell’impostazione precedente.

Normal Text – il colore del testo del messaggio.

Quoted Text – il colore per la parte citata di un messaggio.

URLs – il colore per le URL.
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Personalizzazione di Agent per diverse lingue

.Alcuni dei gruppi che vi interessano possono ospitare thread di
conversazione in lingue diverse dall’inglese. Se per la lingua è disponibile un
dizionario sul sito ftp di Agent, potete installare tale dizionario per il controllo
dell’ortografia dei messaggi che scrivete in tale lingua

Oltre al dizionario, potreste aver bisogno di installare un tipo di carattere
particolare per vedere i messaggi correttamente. L’inglese, per esempio, usa
il set di caratteri Latin, mentre il russo e il giapponese usano set di caratteri
completamente diversi, che richiedono altri tipi di caratteri. In Agent potete
specificare il set di caratteri per un gruppo o per un messaggio.

Per configurare Agent per caratteri internazionali:

1. Installate il tipo di carattere in Windows (consultate la documentazione di
Windows per i dettagli).

2. Mettete la mappa del set di caratteri (.csm) della lingua nella cartella di
lavoro di Agent. Per esempio, potete scaricare il set di caratteri russo,
koi8.csm, dal sito ftp di Agent nella vostra cartella di lavoro per Agent
c:\agent.

3. Configurate le opzioni di Agent come segue:

 a. Selezionate la scheda Options→General Preferences→Languages.
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b. Premete il pulsante Add per far comparire la finestra Add Language
e aggiungete una lingua (p.e. spagnolo) alla lista delle lingue (vedi
sotto).

Nota: Per i tipi di carattere che usano set di caratteri diversi da Latin1
(p.e. russo, giapponese, norvegese, svedese) dovete usare un
carattere a spaziatura proporzionale nei pannelli Message List e
Message. Per fare ciò, usate il pulsante Variable-Pitch Body, e
selezionate le due opzioni Use variable-pitch body font e Use
variable-pitch body font for Headers.

4. Trovate e sottoscrivete i newsgroup che usano i caratteri che avete
installato.

5. Definite Group Properties per i gruppi scelti, come segue:
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a. Nel pannello Groups, selezionate i newsgroup desiderati.

b. Selezionate la scheda Group→Properties→Languages.

c. Impostate queste due opzioni: contrassegnate la casella Override
default settings e scegliete la lingua associata ai newsgroup (vedi
sotto).

A capo automatico

Agent consente di mandare automaticamente a capo le righe troppo lunghe
del corpo dei messaggi scaricati per adattarsi alla finestra in cui sono
visualizzate. Qui si descrive come il testo nei messaggi apparirà quando la
funzione word-wrap, a capo automatico, è abilitata o no:

• A capo automatico abilitato – Tutto il testo del messaggio sarà visibile
indipendentemente dalle dimensioni della finestra di visualizzazione.
Questo consente di vedere tutto il messaggio, ma può rendere
difficoltosa la determinazione del formato originario del messaggio.

• A capo automatico disabilitato – Il testo del messaggio apparirà nel
formato originale, ma potreste dover usare la barra di scorrimento
orizzontale per vederlo tutto.

Per abilitare o disabilitare la funzione di a capo automatico:

Selezionate Message→Word Wrap. Se un segno appare vicino al comando,
la funzione è abilitata e il testo dei messaggi lunghi sarà mandato a capo per
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adattarsi alla dimensione della finestra. Selezionate il comando di nuovo per
disabilitarlo.

Mostrare o nascondere i dettagli nei messaggi

I dettagli (o campi dell’header) di un messaggio scaricato (ad es. author,
location e server) possono essere visualizzati all’inizio del messaggio o
possono essere opportunamente nascosti per rendere la lettura del
messaggio più semplice.

Per visualizzare e nascondere i campi dell’header:

Scegliete uno dei seguenti modi per mostrare i campi dell’header. Ripetete
l’azione per nasconderli.

Barra degli strumenti:  (Per inserire questo pulsante nella barra, vedi pagina 179.)

Menu: Message→Show All Header Fields

Scorciatoia da tastiera: H

Nota: L’opzione Show All Header Fields non nasconderà i dettagli
dell’header che qualcun altro ha copiato nel messaggio come citazione. In tal
caso, questa è parte del messaggio e sarà comunque visualizzata.

Oltre ai dettagli dell’header, avete la possibilità, in qualunque momento, di
vedere il messaggio “grezzo” (raw), cioè il testo originale del messaggio non
formattato. Per esempio, se volete vedere un messaggio scaricato con
un’immagine GIF allegata, vedrete i campi dell’header e le righe originali
codificate dell’allegato (non formattate).

Potete specificare ad Agent quali campi dell’header mostrare. Questo è
possibile attraverso il file Agent.ini, descritto nella prossima sezione.

Per vedere i dettagli del messaggio “grezzo”:

Scegliete uno dei seguenti modi equivalenti per vedere un messaggio
“grezzo”. Ripetete l’azione per tornare alla versione formattata del
messaggio.

Barra degli strumenti:  (Per inserire questo pulsante nella barra, vedi pagina 179.)

Menu: Message→Show Raw Message

Scorciatoia da tastiera: Alt+M+S

_____________________________________________________________
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OO Importante! Se avete selezionato Show Raw Message, Agent non
convertirà i messaggi quoted-printable nel formato corretto, e questo
potrà far sì che i messaggi non vengano visualizzati correttamente
(p.e. compariranno nel messaggio caratteri come =3D o =20).

_____________________________________________________________

Agent.ini
Il file Agent.ini contiene tutte le impostazioni che controllano il modo di
operare di Agent, il suo comportamento in diverse situazioni e il modo di
visualizzare le informazioni. In generale, potete (e dovreste) modificare
queste impostazioni usando le opzioni dei menu e le finestre di impostazione
descritte in questo manuale. Tuttavia non tutte le opzioni sono disponibili
attraverso menu e finestre; alcune possono essere cambiate solo
modificando il file direttamente, usando un editor di testo a vostra scelta.

Quando aprite il file Agent.ini in un editor di testo, noterete che le
impostazioni sono organizzate per funzionalità, in categorie indicate da
parentesi quadre ([ ]) (ad es. [Address], [Online], [Toolbars]). Questo vi
aiuterà a trovare facilmente l’impostazione che desiderate modificare.

Naturalmente dovreste fare una copia di riserva del file Agent.ini prima di
modificarlo. Ciò vi risparmierà la perdita di tutte le personalizzazioni di Agent
in caso qualcosa andasse storto. E tutte le volte che modificate Agent.ini
assicuratevi di disattivare la funzione di a capo automatico dell’editor. Alcune
delle righe di Agent.ini sono piuttosto lunghe, e mandarle a capo
significherebbe dividerle in più righe, nel qual caso non funzionerebbero più
correttamente.

In questa sezione sono descritte in dettaglio alcune delle impostazioni più
utili (che non sono accessibili tramite menu o finestre). Per scoprire ciò che
ogni opzione di Agent.ini significa e dove potete trovare tali impostazioni nel
programma, potete consultare l’Help in linea di Agent. L’argomento “.INI” è il
primo (o quasi) nella lista di ricerca. Nell’argomento dell’Help “AGENT.INI”
potete cliccare su ognuna delle categorie per saltare direttamente alle
impostazioni di quell’area. Se l’impostazione è in una finestra in Agent,
potete saltare dall’argomento dell’Help “AGENT.INI” direttamente all’help su
tale finestra.

Dettagli su alcune impostazioni di Agent.ini

[View]

ProgressStyle=0
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Questa impostazione controlla il formato della barra grafica di avanzamento
dei task nella barra di stato di Agent. Le opzioni sono:

0 Mostra l’indicatore di avanzamento nel proprio riquadro della barra di
stato

1 Mostra l’indicatore di avanzamento nel proprio riquadro, ed include un
testo che mostra la percentuale completata

2 Mostra nel proprio riquadro la percentuale di completamento del task
senza un indicatore grafico di avanzamento.

3 Mostra l’indicatore grafico di avanzamento sotto il testo che descrive il
task corrente

4 Non mostra alcun indicatore di avanzamento.

[Article]

NewsBaseFields="<campi>"
NewsAllFields="<campi>"
MailBaseFields=!to,!subject,!from,!date,cc,bcc
MailAllFields="<campi>"
Queste impostazioni controllano quali campi dell’header sono mostrati in alto
nel pannello Message, prima del corpo del messaggio. I parametri News
controllano i messaggi di Usenet, i parametri Mail controllano i messaggi
email. I parametri “Base” controllano i campi che sono sempre mostrati, se
non sono vuoti (vedi sotto). I parametri “All” controllano i campi che sono
mostrati se “Show All Header Fields” è attivato. Ogni parametro contiene una
lista di nomi di campo separati da virgole, e i campi sono mostrati in Agent
nell’ordine in cui sono in questa lista. Se il nome di un campo è preceduto da
“!” il campo sarà sempre visualizzato; altrimenti sarà visualizzato solo se è
effettivamente presente nel messaggio. Se un parametro “Base” (News o
Mail) è vuoto, nessun campo è mostrato quando “Show All Header Fields” è
disattivato. Se un parametro “All” (News o Mail) è vuoto, quando “Show All
Header Fields” è attivato vengono visualizzati tutti i campi.

[Attachment]

Executables="exe,bat,com,cmd"
Questo parametro imposta quali applicazioni eseguibili sono riconosciute da
Agent. Per questi tipi di file, Agent visualizzerà un messaggio prima di
tentare di avviarli, proteggendovi da eventuali virus.

[Message]

GMTDates=1
Se è diverso da zero, Agent spedirà tutti i messaggi di news ed e-mail in
formato GMT anziché con l’ora locale.
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ShowAllFields=0
Se è diverso da zero, Agent consentirà la modifica dei campi Control e
Approved dei messaggi, usati per spedire messaggi in gruppi moderati.

SignatureDelimiter="^--()?$"
Questa impostazione comunica ad Agent quali caratteri segnano l’inizio di
una firma. Quando Agent rileva la presenza di questa stringa di caratteri in
un testo che deve essere citato, tutto il testo dopo questa stringa di
delimitazione è escluso dalla citazione. Per disattivare questa caratteristica,
inserite una parentesi tonda chiusa subito dopo le prime virgolette della
stringa. Per esempio:

SignatureDelimiter=")^--()?$"

[Timing]

I parametri di questa sezione vi permettono di controllare dopo quanto tempo
Agent visualizza un messaggio di “timeout”. Se credete che il server stia
interrompendo la vostra connessione o stia avendo ritardi nello scaricare i
titoli, potete aumentare il tempo che Agent aspetterà prima di mostrare la
finestra di errore. Tutti i tempi sono in secondi.

GetHostByNameTimeout=30
Questa impostazione controlla il tempo di timeout nella ricerca del nome
dell’host.

ConnectTimeout=10
Questa impostazione controlla il tempo di timeout per la connessione all’host.

ResponseTimeout=120
Questa impostazione controlla il tempo di timeout per l’attesa di risposta
dall’host.

SendTimeout=60
Questa impostazione controlla il tempo di timeout per l’invio di un comando
al server. Questo è il tempo massimo che il programma aspetterà durante un
blocco della trasmissione, non il tempo totale concesso per spedire il
messaggio.

PostTimeout=60
Questa impostazione controlla il timeout per l’invio di un messaggio o e-mail.
Questo è il tempo massimo che il programma aspetterà durante un blocco
della trasmissione, non il tempo totale concesso per spedire il messaggio.

PostResponseTimeout=360
Questa impostazione controlla quanto Agent attenderà per il riconoscimento
da parte del server dopo aver spedito un messaggio o e-mail.
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QuitResponseTimeout=30
Questa impostazione controlla quanti secondi Agent attenderà per il
riconoscimento di chiusura da parte del server.

[Debugging]

ShowUID=0
Se è diverso da zero, Agent mostrerà gli identificativi di gruppo e cartella nel
pannello Groups/Folders. Questo numero è la base del nome del file per i file
IDX e DAT di ogni gruppo, e consente di trovare il file che corrisponde ad un
gruppo o cartella.

ShowArticleDetail=0
Se è diverso da zero, Agent mostrerà alcune informazioni dettagliate sui
messaggi in fondo al pannello Message. In particolare, mostra il numero del
messaggio riportato dal server.

ShowBuild=0
Se diverso da zero, Agent mostrerà il numero di versione interno sulla barra
del titolo.



197

Indice
a capo automatico,  103; 138; 144; 191
AddressBook,  127
Agent.ini,  193–96
aggiornare la lista dei gruppi,  19
aiuto

assistenza clienti,  7
newsgroup,  7
online,  6
ottenere aiuto,  6
sito web di Forté,  7

allegati,  136
aggiungerne,  136
codifica e decodifica,  152
digest,  161–62
formati supportati da Agent,  152
indice dei messaggi,  154
inserimento,  119
invio,  159–61
lanciarli,  153
multipart,  152
salvataggio,  154; 158–59
scaricare allegati multipart,  157
scaricarli,  155–58
sezioni del messaggio,  154
visualizzarli come testo,  158

allegati multipart,  152
scaricarli,  157

APOP,  26
archiviazione automatica della posta in

arrivo,  70
archiviazione messaggi,  46; 47; 49

in cartelle ,  57–60
in un file,  60–62
mentre li si spedisce,  146

assistenza clienti,  7
attachment,  Vedi allegati

autorizzazione,  17
news server,  17

autorizzazione dal news server,  17

barra dei menu,  30
barra del titolo,  30
barra di stato,  32; 44; 70; 184

indicatori,  35
barre degli strumenti,  30; 179–81
barre di scorrimento,  32

campi,  123–24
bcc,  123
Cc,  123
definizione,  123
distribution,  123
expires,  124
follow-up to,  124
from,  124
inserimento automatico dalla rubrica,

132; 133
keywords,  124
nel salvataggio dei messaggi,  61
nelle expression,  83; 106
organization,  124
quando stampare i messaggi,  117
reply-to,  124
sender,  124
summary,  124
text,  131
visualizzazione,  192; 194

campi dei messaggi,  123
campi dell’header

visualizzazione,  192; 194
campione dei messaggi,  21
cancellazione dei messaggi,  114; 148
caratteri internazionali,  189



Indice

198

cartelle
copiare e spostare messaggi,  58
crearle,  57
finestra di dialogo Manage Folder

Menus,  59
trascinamento di messaggi,  58
vederle,  58

catching up nei gruppi,  64
check mail,  67
citazione nei messaggi,  121
codifica e decodifica degli allegati,  152
collegamenti,  173

in Windows,  173
colori,  188
compattare il database,  115
composizione dei messaggi

a capo automatico,  138
allegare un file,  136
campi,  123–24
citare del testo,  139
controllo ortografico,  141–42
firma,  125–27
impostazione,  137
opzioni,  137–40
panoramica,  118–22
salvataggio,  139
scegliere un indirizzo,  133

configurare il comportamento
online/offline,  49

connessione,  52
impostazioni,  52; 53

conservare i messaggi,  34; 47; 49; 110–
12

controllare lo stato del messaggio,  145
controllo della posta,  27; 45; 47; 67
controllo ortografico,  141–42
copiare URL negli appunti,  170
creare cartelle ,  57
creare filtri per i messaggi,  71
creare viste,  71–102
crosspost dei messaggi,  65

dettagli dei messaggi,  192

digest,  161–62
invio,  161
scomposizione,  162

dimensione delle icone delle barre degli
trumenti,  180

disposizione delle sezioni dei messaggi,
154

eliminazione dei messaggi,  110–12
cosa eliminare,  112
prevenzione,  114
quando eliminarli,  111

email,  25
check,  67

esempi di filtri,  92
espandere e restringere i thread,  41
espandere gli indirizzi,  135
espansione

espansione automatica dei thread,  41
expire

filtri,  78
expression dei filtri,  73; 76; 79–84

fields,  123
bcc,  123
Cc,  123
inserimento automatico dalla rubrica,

133
text,  131

file newsrc,  175–78
esportare,  175
importare,  176
importazione ed esportazione

automatiche,  178
filtrare i messaggi,  Vedi filtri dei messaggi
filtri

Viste,  See views
filtri dei messaggi,  71–94

creazione,  71
eliminazione,  79
esempi,  92
esempi di filtri per Usenet,  84–85
expression dei filtri,  73; 76; 79–84



Indice

199

finestra add email filter,  76
finestra add Usenet filter,  73
gestione,  79
modifica,  79
regular expression,  86–89
scadenza,  75; 78
scartare la spam,  90

finestre in Agent,  35
filtri per email,  72; 79
filtri per Usenet,  79
filtri per Usenet,  72
finestra di composizione,  121

showing buttons,  186
Outbox,  145
rubrica,  127

firma,  125–27
creazione,  125
default,  127
inserimento,  125

firma preimpostata,  127
firme

delimitatore,  121
delimitatori,  195
tagliare dalla citazione,  195

follow-up,  38
invio,  46
scrivere,  48

font,  103; 186
formato 7-bit / 8-bit,  142
formato quoted printable,  142
Forté

sito ftp,  136
sito web,  7

fuoco,  31
fuso orario,  17; 194

gestire il crosspost,  65–67
global search,  105–12
gruppi

aggiornamento,  19
campione di messaggi,  21
catching up,  64
nuovi,  33

proprietà,  42
proprietà, gruppi selezionati,  43
proprietà,tutti i gruppi,  42
ricerca,  20
selezionare i gruppi,  44
sottoscrizione,  24
sottoscrizione,subscribe,  32
visualizzazione,  24; 30

header
mostra, nascondi,  192

icone,  32–35
corpo del messaggio,  34
espandi, restringi il thread,  34
Outbox,  146
pannello Groups/Folder

(gruppi/cartelle),  32
pannello Message List,  34
per gli allegati,  157
posta non letta,  70

ignorare i thread,  34; 46
ignorare un thread,  49; 65
importare gli indirizzi,  135
impostare una connessione,  52
impostazione dei server di news e mail,

16
impostazione delle opzioni dei messggi,

137
indice dei messaggi,  154
indirizzi

controllo della validità,  134; 138
espansione,  131; 135
importarli,  135
inserire un nuovo indirizzo,  129
locali,  134; 138
trovarli,  131

indirizzo
sceglierlo,  132–34

inoltrare messaggi,  120
inserimento (tasto),  35
installazione,  11

dai dischi di Agent,  13



Indice

200

direttamente via software ,  13
Internet Explorer,  173
invio degli allegati,  159–61
invio dei messaggi,  119

archiviare i messaggi nelle cartelle,  146
cancellare i messaggi di Usenet,  148
controllo dello stato,  145
formato 7-bit / 8-bit,  142
formato quoted printable,  142
impostazione delle opzioni di formato,

142
in coda,  49
inoltrarli,  120
opzioni per i singoli messaggi,  144
quoted printable contro 7-bit / 8-bit,  143
rispondere,  120
usare MAPI,  149

keep,  110; 114
keep message,  47; 49

lanciare gli allegati,  153
lavorare offline,  45
lavorare online,  45
layout a tre pannelli,  19; 29

modifica del layout,  182
pannello Groups/Folders

(gruppi/cartelle),  30
pannello Message (corpo del

messaggio),  32
pannello Message List (lista dei

messaggi),  31
ridimensionare i pannelli,  183
spostarsi tra i pannelli,  36

lingue,  189
Lista dei Preferiti,  173

in Internet Explorer,  173
liste di distribuzione (vedi mailing list),

130

mail server (SMTP),  16
mailing list,  130

campo text,  131

MAPI,  149
marcare i messaggi

come letti,  39
da scaricare,  32; 34; 48

margini di scorrimento,  184
menu contestuali,  32
menu Folders,  181–82
messaggi

a capo automatico,  103
archiviare i messaggi nelle cartelle,  146
archiviazione,  46; 47; 49

in file,  60–62
archiviazione in cartelle,  57–60
campione,  21
cancellare i messaggi di Usenet,  148
caratteri,  186
caratteri internazionali,  189
composizione,  118
conservare un messaggio,  34; 47; 49;

110–12
creare una rubrica utilizzando il campo

from,  129
digest,  Vedi digest
eliminazione,  114
eliminazione,  110–12
filtri,  71–94
font,  103
grezzi (raw),  61; 192
indice dei messaggi,  154
inoltrarli,  120
invio,  119

dei messaggi in coda,  49
lingue,  189
marcare i messaggi da scaricare,  32;

34; 48
marcare un messaggio come letto,  39
mostra dettagli,  192
non letti,  32; 35
ordinamento,  31
ordinare,  94
proprietà,  144; 159; 161
ricerca,  104–12
rispondere,  120



Indice

201

salvataggio,  119
scaricare

gli header nei gruppi selezionati,  46
gli header nei gruppi selezionati,  47
gli header nei gruppi sottoscritti,  24
i messaggi marcati,  48
il testo,  24

stampa,  116–203
stato,  34
visualizare,  71–104
visualizzare,  103

Messaggi
spedire,  142–45

MIME
tipi MIME,  153

modalità offline,  45
configurazione,  49
sessione tipica,  47

modalità online,  45
configurazione,  49
sessione tipica,  45

mostrare i pulsanti nella finestra di
composizione,  186

multi-tasking,  44

navigazione,  36–42
con un solo tasto,  40
e scaricare i messaggi,  40
saltare e visualizzare,  37
scaricare il successivo messaggio non

letto,  40
scaricare il successivo messaggio non

letto in un thread,  40
spostarsi al messaggio precedente o

successivo,  37
spostarsi al successivo gruppo non

letto,  39
spostarsi al successivo messaggio non

letto,  38
spostarsi al successivo messaggio non

letto nello stesso thread,  38
spostarsi al successivo messaggio non

letto, con corpo,  38

spostarsi tra i messaggi,  37
spostarsi tra i pannelli,  36

Netscape,  173; 174
news server (NNTP),  16
newsgroup

definizione,  4
esempi,  6

nuovi gruppi,  33

offline,  45
configurare il comportamento,  49
sessione tipica,  47

online,  45
online

configurare il comportamento,  49
sessione tipica,  45

ora di Greenwich (GMT),  194
ora legale,  17
ordinamento dei messaggi,  31
ordinare

messaggi,  94
Outbox,  145–48

aprire la outbox,  146
icone,  146
rispedire un messaggio,  147

pannelli
Groups/Folders (gruppi/cartelle),  30
Message (corpo del messaggio),  32
Message List (lista dei messaggi),  31

ridimensionare le colonne,  31
viste,  97
visualizzare l’indirizzo dell’autore,

185
personalizzare il menu Folders,  181–82
personalizzare le barre degli strumenti di

Agent,  179–81
personalizzazione di Agent,  179–96

a capo automatico,  191
Agent.ini,  193–96
barre degli strumenti

dimensioni delle icone delle barre
degli strumenti,  180



Indice

202

caratteri,  186
colori,  188
divisori di sezione,  186
lingue e caratteri internazionali,  189
marcatori del testo citato,  186
spaziatura delle tabulazioni,  186
visualizzazione delle finestre,  182–85

posta
allarmi,  70
controllo,  27; 45; 47; 67
definizione di email,  4
folder di posta ricevuta di default,  25
icona di posta non letta,  70
rispondere,  46
scaricare la posta per la prima volta,  25
scaricarla da più di un sito,  93
scaricarla da più di una postazione,  69

posta in arrivo
archiviazione automatica,  70

programma predefinito per news/email,
173

proprietà
dei messaggi,  144; 159; 161

proprietà dei gruppi,  42
per tutti i gruppi,  42
selezionati,  43

pulsanti della finestra di composizione,
186

purging messages
when to purge,  111

purging messages,  110

quoted printable,  142

recuperare corpi dei messaggi,  63
registrazione,  14

dai dischi di Agent,  15
direttamente via software,  14

registro di Windows,  172
regular expression,  86–89
Release Notes,  7
Remote Access Services (RAS),  52
reply via email,  46

scrivere,  48
requisiti

Agent 16 bit,  12
Agent 32 bit,  12
PC,  12

ricerca dei gruppi,  20
ricerca dei messaggi,  104–12

global search,  105–12
richiesta di assistenza,  7
ridimensionare colonne e pannelli,  31; 36
rispondere

ai messaggi,  120
alla posta,  46

ROT13,  103
rubrica,  118–36

apertura,  127
convertitori,  136
espandere gli indirizzi,  131; 135
importare gli indirizzi,  135
inserire un nuovo indirizzo,  129

da un messaggio,  129
scegliere un indirizzo,  118; 132–34
trovare un indirizzo,  131
utilizzare le mailing list,  130
validazione indirizzi,  134

salvataggio degli allegati,  154; 158–59
salvataggio di messaggi in un file

campi dell’header,  61
sample messages,  21
scaricare

allegati,  155–58
multipart,  157

corpo dei messaggi,  24; 63
header dei messaggi

nei gruppi selezionati,  46; 47
messaggi marcati,  48
messaggi news,  62–67
posta,  25; 67–71

con un server POP,  26
con un server SMTP,  27

scegliere un indirizzo,  118; 132–34; 132–
34



Indice

203

scroll lock (tasto),  35
seguire un thread,  34; 46; 48; 64
selezionare header multipli,  23
selezionare più gruppi,  44
selezione multipla,  23; 44
server

mail (POP),  26
mail (SMTP),  16
news (NNTP),  16

server POP,  26
usare APOP,  26

signature,  125
delimitatore,  121

single key navigation,  40
sottoscrivere dei gruppi,  24
sovrascrivere il testo,  35
SPA (Secure Password Authentication),

27
spam,  90
stampare i messaggi,  116–203
Subscribe,  32
support question,  7

task,  44
testo citato,  139
thread,  31; 38

espandere e restringere,  41
espansione automatica,  41
ignorare,  34
ignorarli,  46; 49; 65
seguire,  34
seguirli,  46; 48; 64

threads
visualizzare,  95

timeout,  195
toolbar,  vedi barre degli strumenti

URL in Agent,  167–73
copiarle negli appunti,  170
e Internet Explorer,  173

e Netscape,  173; 174
interpretazione di una URL,  171
la lista dei Preferiti in Internet Explorer,

173
lanciarle,  170
tipi di URL,  167
usare i collegamenti di Windows,  173
usare il browser,  171
visualizzazione,  168; 186

usare copie multiple di Agent,  175
UUEncode, UUDecode,  152

validazione degli indirizzi,  134
views,  vedi viste

simple views,  99
viste

advanced,  100
corrente,  34
creare,  71–102
selezionare,  98

Viste,  97
visualizzare

messaggi,  71–104
visualizzazione

esempi,  101
gruppi,  24; 30
gruppi sottoscritti,  24
testo dei messaggi,  24; 32

visualizzazione delle finestre,  182–85
finestra principale di Agent,  183

watch thread,  46; 48; 64
winsock,  69
Winsock

caricare,  51
caricare all’avvio,  27

zoom,  31
Zoom,  36

1.5-21102000.doc


